aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-10 13:43:18 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-11 19:24:49 +0100
commit95c1fce821c37d5afcd84df92b58c5ae184f8bcd (patch)
treeba3e482180a3d8859b3e19f5af7020bc68e967cd
parent926f4da2b2348e5f8dbaa1bc119dcf0fea3010ca (diff)
downloadupstream-95c1fce821c37d5afcd84df92b58c5ae184f8bcd.tar.gz
upstream-95c1fce821c37d5afcd84df92b58c5ae184f8bcd.tar.bz2
upstream-95c1fce821c37d5afcd84df92b58c5ae184f8bcd.zip
ipq806x: replace ${} with $()
${} and $() are exactly the same. Follow the convention of using $(). Signed-off-by: Sungbo Eo <mans0n@gorani.run>
-rw-r--r--target/linux/ipq806x/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 33f68b7a60..6f529aca06 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -73,11 +73,11 @@ DEVICE_VARS += TPLINK_BOARD_ID
define Device/ZyXELImage
KERNEL_SUFFIX := -uImage
- KERNEL = kernel-bin | append-dtb | uImage none | pad-to $${KERNEL_SIZE}
+ KERNEL = kernel-bin | append-dtb | uImage none | pad-to $$(KERNEL_SIZE)
KERNEL_NAME := zImage
IMAGES := factory.bin sysupgrade.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to $$$$(BLOCKSIZE) | zyxel-ras-image separate-kernel
- IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to $$$${BLOCKSIZE} | sysupgrade-tar rootfs=$$$$@ | append-metadata
+ IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to $$$$(BLOCKSIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
endef
define Device/buffalo_wxr-2533dhp
@@ -121,7 +121,7 @@ define Device/linksys_ea8500
SUPPORTED_DEVICES += ea8500
UBINIZE_OPTS := -E 5
IMAGES := factory.bin sysupgrade.bin
- IMAGE/factory.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-ubi
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
endef
TARGET_DEVICES += linksys_ea8500
@@ -295,7 +295,7 @@ define Device/tplink_vr2600v
SUPPORTED_DEVICES += vr2600v
DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := pad-extra 512 | append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
+ IMAGE/sysupgrade.bin := pad-extra 512 | append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | append-metadata
endef
TARGET_DEVICES += tplink_vr2600v