aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-02 16:09:15 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-02 16:09:15 +0000
commit6cd84c68386d614b4838346b8b16f0431bd07e3e (patch)
tree658bde36cb97d078f983ececc1bba6953fb84eeb
parent423af6adca85911671066465f68402da4f933622 (diff)
downloadupstream-6cd84c68386d614b4838346b8b16f0431bd07e3e.tar.gz
upstream-6cd84c68386d614b4838346b8b16f0431bd07e3e.tar.bz2
upstream-6cd84c68386d614b4838346b8b16f0431bd07e3e.zip
Use find -exec instead of xargs
SVN-Revision: 6837
-rw-r--r--Makefile2
-rw-r--r--include/image.mk6
-rw-r--r--include/package-ipkg.mk6
-rwxr-xr-xscripts/feeds.sh2
-rw-r--r--target/imagebuilder/Makefile4
-rw-r--r--target/sdk/Makefile4
6 files changed, 12 insertions, 12 deletions
diff --git a/Makefile b/Makefile
index bee47c45cc..ab4c4d57b6 100644
--- a/Makefile
+++ b/Makefile
@@ -171,7 +171,7 @@ docclean:
$(MAKE) -C docs/ clean
symlinkclean:
- find package -type l | xargs rm -f
+ find package -type l -exec rm -f {} \;
.SILENT: clean dirclean distclean symlinkclean config-clean download world
FORCE: ;
diff --git a/include/image.mk b/include/image.mk
index 78e1a2fdc8..eb59ea651c 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -79,9 +79,9 @@ endif
define Image/mkfs/prepare/default
- find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
- find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
- find $(BUILD_DIR)/root -type d | xargs chmod 0755
+ find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' -exec chmod 0644 {} \;
+ find $(BUILD_DIR)/root -type f -perm +0100 -exec chmod 0755 {} \;
+ find $(BUILD_DIR)/root -type d -exec chmod 0755 {} \;
mkdir -p $(BUILD_DIR)/root/tmp
chmod 0777 $(BUILD_DIR)/root/tmp
endef
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 8d6f1956f8..d824d268f4 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -71,9 +71,9 @@ ifeq ($(DUMP),)
$$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
$(call Package/$(1)/install,$$(IDIR_$(1)))
mkdir -p $(PACKAGE_DIR)
- -find $$(IDIR_$(1)) -name CVS | xargs rm -rf
- -find $$(IDIR_$(1)) -name .svn | xargs rm -rf
- -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
+ -find $$(IDIR_$(1)) -name CVS -exec rm -rf {} \;
+ -find $$(IDIR_$(1)) -name .svn -exec rm -rf {} \;
+ -find $$(IDIR_$(1)) -name '.#*' -exec rm -f {} \;
$(RSTRIP) $$(IDIR_$(1))
$(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
@[ -f $$(IPKG_$(1)) ] || false
diff --git a/scripts/feeds.sh b/scripts/feeds.sh
index 351c87c43d..d2dfe9da9f 100755
--- a/scripts/feeds.sh
+++ b/scripts/feeds.sh
@@ -22,7 +22,7 @@ cd $TOPDIR
# Some functions we might call several times a run
delete_symlinks() {
- find $1 -type l | xargs rm -f
+ find $1 -type l -exec rm -f {} \;
}
setup_symlinks() {
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 0cbbfa2835..3d830bbc2d 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -33,8 +33,8 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
$(CP) $(TOPDIR)/target/linux/* $(IB_BUILD_DIR)/target/linux
rm -rf $(IB_BUILD_DIR)/target/linux/*/patches
-cp $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/* $(IB_BUILD_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD) # don't copy subdirectories here
- find $(IB_BUILD_DIR) -name .svn | xargs rm -rf
- find $(IB_BUILD_DIR) -name CVS | xargs rm -rf
+ find $(IB_BUILD_DIR) -name .svn -exec rm -rf {} \;
+ find $(IB_BUILD_DIR) -name CVS -exec rm -rf {} \;
(cd $(BUILD_DIR); \
tar cfj $@ $(IB_NAME); \
)
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index d65b934c95..3cae4b3842 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -35,8 +35,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
$(CP) ./files/package/rules.mk $(SDK_BUILD_DIR)/package/
echo OPENWRTVERSION:=$(OPENWRTVERSION) > $(SDK_BUILD_DIR)/.version.mk
rm -rf $(SDK_BUILD_DIR)/staging_dir*/ccache
- find $(SDK_BUILD_DIR) -name .svn | xargs rm -rf
- find $(SDK_BUILD_DIR) -name CVS | xargs rm -rf
+ find $(SDK_BUILD_DIR) -name .svn -exec rm -rf {} \;
+ find $(SDK_BUILD_DIR) -name CVS -exec rm -rf {} \;
(cd $(BUILD_DIR); \
tar cfj $@ $(SDK_NAME); \
)