aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYanase Yuki <dev@zpc.sakura.ne.jp>2020-04-21 15:06:12 +0900
committerPetr Štetiar <ynezz@true.cz>2020-12-25 10:38:13 +0100
commit3bb16185737c011b74e3166cf436785604b5f47f (patch)
tree42aad308db2862e0d08edf9b8c2949c3f56ca5f0
parentd64102e00a8e3aebda8427df3b2c36bf4639928f (diff)
downloadupstream-3bb16185737c011b74e3166cf436785604b5f47f.tar.gz
upstream-3bb16185737c011b74e3166cf436785604b5f47f.tar.bz2
upstream-3bb16185737c011b74e3166cf436785604b5f47f.zip
ipq806x: add support for NEC Platforms Aterm WG2600HP3
NEC Platforms Aterm WG2600HP3 is a dual-band router based on Qualcomm IPQ8062. Specification ------------- - SoC: Qualcomm IPQ8062 - RAM: 512MiB - Flash memory: SPI-NOR 32MiB (Cypress S25FL256S) - Wi-Fi: Qualcomm QCA9984 (2.4GHz, 1ch - 13ch) - Wi-Fi: Qualcomm QCA9984 (5GHz, 36ch - 64ch, 100ch - 140ch) - Ethernet: 4x 100/1000 Mbps (1x WAN, 4x LAN) - LED: 6x green LED, 6x red LED - Input: 2x tactile switch, 1x SP3T slide switch - Serial console: 115200bps, through-hole J3 - [ ] [GND] [ ] [TX] [RX] ----> DC jack - Power: DC 12V 1.5A This device does not support VHT160 and VHT80+80. Custom BDFs are required to limit VHT capabilities. Flash instructions ------------------ 1. Setup TFTP server (IP address: 192.168.1.2) 2. Put initramfs image into TFTP server directory 3. Connect WG2600HP3 lan port and computer that runs TFTP server 4. Connect to the serial console 5. Interrupt booting by Esc key (password: chiron) 6. Execute the following commands # setenv bootcmd "nboot 0x44000000 1 0x860000" # saveenv # setenv ipaddr 192.168.1.1 # setenv serverip 192.168.1.2 # tftpboot 0x44000000 openwrt-ipq806x-generic-nec_wg2600hp3-initramfs-uImage 7. After booting OpenWrt initramfs image, backup SPI-NOR flash memory 8. Erase firmware partition # mtd erase firmware 9. Run sysupgrade Signed-off-by: Yanase Yuki <dev@zpc.sakura.ne.jp>
-rw-r--r--package/firmware/ipq-wifi/Makefile2
-rw-r--r--package/firmware/ipq-wifi/board-nec_wg2600hp3.qca9984bin0 -> 24332 bytes
-rwxr-xr-xtarget/linux/ipq806x/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ipq806x/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/ipq806x/base-files/etc/hotplug.d/firmware/11-ath10k-caldata6
-rw-r--r--target/linux/ipq806x/files/arch/arm/boot/dts/qcom-ipq8062-wg2600hp3.dts430
-rw-r--r--target/linux/ipq806x/image/Makefile14
-rw-r--r--target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch3
8 files changed, 459 insertions, 3 deletions
diff --git a/package/firmware/ipq-wifi/Makefile b/package/firmware/ipq-wifi/Makefile
index f1a0c1c474..f42704b8d3 100644
--- a/package/firmware/ipq-wifi/Makefile
+++ b/package/firmware/ipq-wifi/Makefile
@@ -43,6 +43,7 @@ ALLWIFIBOARDS:= \
linksys_mr8300-v0 \
luma_wrtq-329acn \
mobipromo_cm520-79f \
+ nec_wg2600hp3 \
plasmacloud_pa1200 \
plasmacloud_pa2200 \
qxwlan_e2600ac
@@ -124,6 +125,7 @@ $(eval $(call generate-ipq-wifi-package,linksys_ea8300,Linksys EA8300))
$(eval $(call generate-ipq-wifi-package,linksys_mr8300-v0,Linksys MR8300))
$(eval $(call generate-ipq-wifi-package,luma_wrtq-329acn,Luma WRTQ-329ACN))
$(eval $(call generate-ipq-wifi-package,mobipromo_cm520-79f,MobiPromo CM520-79F))
+$(eval $(call generate-ipq-wifi-package,nec_wg2600hp3,NEC Platforms WG2600HP3))
$(eval $(call generate-ipq-wifi-package,plasmacloud_pa1200,Plasma Cloud PA1200))
$(eval $(call generate-ipq-wifi-package,plasmacloud_pa2200,Plasma Cloud PA2200))
$(eval $(call generate-ipq-wifi-package,qxwlan_e2600ac,Qxwlan E2600AC))
diff --git a/package/firmware/ipq-wifi/board-nec_wg2600hp3.qca9984 b/package/firmware/ipq-wifi/board-nec_wg2600hp3.qca9984
new file mode 100644
index 0000000000..f95ccd251e
--- /dev/null
+++ b/package/firmware/ipq-wifi/board-nec_wg2600hp3.qca9984
Binary files differ
diff --git a/target/linux/ipq806x/base-files/etc/board.d/01_leds b/target/linux/ipq806x/base-files/etc/board.d/01_leds
index c23f25540b..fed821663a 100755
--- a/target/linux/ipq806x/base-files/etc/board.d/01_leds
+++ b/target/linux/ipq806x/base-files/etc/board.d/01_leds
@@ -27,6 +27,9 @@ nec,wg2600hp)
ucidef_set_led_wlan "wlan5g" "WLAN5G" "green:wlan5g" "phy0tpt"
ucidef_set_led_switch "wan" "WAN" "green:active" "switch0" "0x2"
;;
+nec,wg2600hp3)
+ ucidef_set_led_switch "wan" "WAN" "green:active" "switch0" "0x2"
+ ;;
netgear,d7800 |\
netgear,r7500 |\
netgear,r7500v2 |\
diff --git a/target/linux/ipq806x/base-files/etc/board.d/02_network b/target/linux/ipq806x/base-files/etc/board.d/02_network
index eecf81a8cd..10b2ec0148 100755
--- a/target/linux/ipq806x/base-files/etc/board.d/02_network
+++ b/target/linux/ipq806x/base-files/etc/board.d/02_network
@@ -46,6 +46,10 @@ linksys,ea8500)
ucidef_set_interface_macaddr "lan" "$hw_mac_addr"
ucidef_set_interface_macaddr "wan" "$hw_mac_addr"
;;
+nec,wg2600hp3)
+ ucidef_add_switch "switch0" \
+ "2:lan" "3:lan" "4:lan" "5:lan" "0@eth1" "1:wan" "6@eth0"
+ ;;
netgear,r7800 |\
tplink,c2600)
ucidef_add_switch "switch0" \
diff --git a/target/linux/ipq806x/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ipq806x/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index a22af9b676..8788fc92f6 100644
--- a/target/linux/ipq806x/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ipq806x/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -24,7 +24,8 @@ case "$FIRMWARE" in
caldata_extract "art" 0x1000 0x2f20
ath10k_patch_mac $(macaddr_add $(mtd_get_mac_ascii devinfo hw_mac_addr) +1)
;;
- nec,wg2600hp)
+ nec,wg2600hp |\
+ nec,wg2600hp3)
caldata_extract "ART" 0x1000 0x2f20
ath10k_patch_mac $(mtd_get_mac_binary PRODUCTDATA 0x12)
;;
@@ -62,7 +63,8 @@ case "$FIRMWARE" in
caldata_extract "art" 0x5000 0x2f20
ath10k_patch_mac $(macaddr_add $(mtd_get_mac_ascii devinfo hw_mac_addr) +2)
;;
- nec,wg2600hp)
+ nec,wg2600hp |\
+ nec,wg2600hp3)
caldata_extract "ART" 0x5000 0x2f20
ath10k_patch_mac $(mtd_get_mac_binary PRODUCTDATA 0xc)
;;
diff --git a/target/linux/ipq806x/files/arch/arm/boot/dts/qcom-ipq8062-wg2600hp3.dts b/target/linux/ipq806x/files/arch/arm/boot/dts/qcom-ipq8062-wg2600hp3.dts
new file mode 100644
index 0000000000..d234b94a46
--- /dev/null
+++ b/target/linux/ipq806x/files/arch/arm/boot/dts/qcom-ipq8062-wg2600hp3.dts
@@ -0,0 +1,430 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qcom-ipq8062.dtsi"
+#include <dt-bindings/input/input.h>
+
+/delete-node/ &nand_pins;
+
+/ {
+ model = "NEC Platforms Aterm WG2600HP3";
+ compatible = "nec,wg2600hp3", "qcom,ipq8062", "qcom,ipq8064";
+
+ memory {
+ device_type = "memory";
+ reg = <0x42000000 0x1e000000>;
+ };
+
+ aliases {
+ label-mac-device = &gmac2;
+
+ led-boot = &led_power_green;
+ led-failsafe = &led_power_red;
+ led-running = &led_power_green;
+ led-upgrade = &led_power_red;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ pinctrl-0 = <&buttons_pins>;
+ pinctrl-names = "default";
+
+ reset {
+ label = "reset";
+ gpios = <&qcom_pinmux 24 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&qcom_pinmux 22 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+
+ mode0 {
+ label = "mode0";
+ gpios = <&qcom_pinmux 40 GPIO_ACTIVE_LOW>;
+ linux,code = <BTN_0>;
+ linux,input-type = <EV_SW>;
+ };
+
+ mode1 {
+ label = "mode1";
+ gpios = <&qcom_pinmux 41 GPIO_ACTIVE_LOW>;
+ linux,code = <BTN_1>;
+ linux,input-type = <EV_SW>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ pinctrl-0 = <&leds_pins>;
+ pinctrl-names = "default";
+
+ led_power_green: power_green {
+ label = "green:power";
+ gpios = <&qcom_pinmux 14 GPIO_ACTIVE_HIGH>;
+ };
+
+ led_power_red: power_red {
+ label = "red:power";
+ gpios = <&qcom_pinmux 35 GPIO_ACTIVE_HIGH>;
+ };
+
+ active_green {
+ label = "green:active";
+ gpios = <&qcom_pinmux 42 GPIO_ACTIVE_HIGH>;
+ };
+
+ active_red {
+ label = "red:active";
+ gpios = <&qcom_pinmux 38 GPIO_ACTIVE_HIGH>;
+ };
+
+ wlan2g_green {
+ label = "green:wlan2g";
+ gpios = <&qcom_pinmux 55 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ wlan2g_red {
+ label = "red:wlan2g";
+ gpios = <&qcom_pinmux 56 GPIO_ACTIVE_HIGH>;
+ };
+
+ wlan5g_green {
+ label = "green:wlan5g";
+ gpios = <&qcom_pinmux 57 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ wlan5g_red {
+ label = "red:wlan5g";
+ gpios = <&qcom_pinmux 58 GPIO_ACTIVE_HIGH>;
+ };
+
+ tv_green {
+ label = "green:tv";
+ gpios = <&qcom_pinmux 46 GPIO_ACTIVE_HIGH>;
+ };
+
+ tv_red {
+ label = "red:tv";
+ gpios = <&qcom_pinmux 36 GPIO_ACTIVE_HIGH>;
+ };
+
+ converter_green {
+ label = "green:converter";
+ gpios = <&qcom_pinmux 43 GPIO_ACTIVE_HIGH>;
+ };
+
+ converter_red {
+ label = "red:converter";
+ gpios = <&qcom_pinmux 15 GPIO_ACTIVE_HIGH>;
+ };
+ };
+};
+
+&qcom_pinmux {
+ pinctrl-0 = <&akro_pins>;
+ pinctrl-names = "default";
+
+ spi_pins: spi_pins {
+ mux {
+ pins = "gpio18", "gpio19", "gpio21";
+ function = "gsbi5";
+ bias-pull-down;
+ };
+
+ data {
+ pins = "gpio18", "gpio19";
+ drive-strength = <10>;
+ };
+
+ cs {
+ pins = "gpio20";
+ drive-strength = <10>;
+ };
+
+ clk {
+ pins = "gpio21";
+ drive-strength = <12>;
+ };
+ };
+
+ buttons_pins: buttons_pins {
+ mux {
+ pins = "gpio22", "gpio24", "gpio40",
+ "gpio41";
+ function = "gpio";
+ drive-strength = <2>;
+ bias-pull-up;
+ };
+ };
+
+ leds_pins: leds_pins {
+ mux {
+ pins = "gpio14", "gpio15", "gpio35",
+ "gpio36", "gpio38", "gpio42",
+ "gpio43", "gpio46", "gpio55",
+ "gpio56", "gpio57", "gpio58";
+ function = "gpio";
+ bias-pull-down;
+ };
+
+ akro2 {
+ pins = "gpio15", "gpio35", "gpio38",
+ "gpio42", "gpio43", "gpio46",
+ "gpio55", "gpio56", "gpio57",
+ "gpio58";
+ drive-strength = <2>;
+ };
+
+ akro4 {
+ pins = "gpio14", "gpio36";
+ drive-strength = <4>;
+ };
+ };
+
+ /*
+ * Stock firmware has the following settings, so let's do the same.
+ * I don't sure why these are required.
+ */
+ akro_pins: akro_pinmux {
+ akro {
+ pins = "gpio17", "gpio26", "gpio47";
+ function = "gpio";
+ drive-strength = <2>;
+ bias-pull-down;
+ };
+
+ reset {
+ pins = "gpio45";
+ function = "gpio";
+ drive-strength = <2>;
+ bias-disable;
+ output-low;
+ };
+
+ gmac0_rgmii {
+ pins = "gpio25";
+ function = "gpio";
+ drive-strength = <8>;
+ bias-disable;
+ };
+ };
+};
+
+&gsbi5 {
+ status = "okay";
+ qcom,mode = <GSBI_PROT_SPI>;
+
+ spi@1a280000 {
+ status = "okay";
+
+ pinctrl-0 = <&spi_pins>;
+ pinctrl-names = "default";
+
+ cs-gpios = <&qcom_pinmux 20 GPIO_ACTIVE_HIGH>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <50000000>;
+ m25p,fast-read;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "SBL1";
+ reg = <0x0000000 0x0020000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "MIBIB";
+ reg = <0x0020000 0x0020000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "SBL2";
+ reg = <0x0040000 0x0040000>;
+ read-only;
+ };
+
+ partition@80000 {
+ label = "SBL3";
+ reg = <0x0080000 0x0080000>;
+ read-only;
+ };
+
+ partition@100000 {
+ label = "DDRCONFIG";
+ reg = <0x0100000 0x0010000>;
+ read-only;
+ };
+
+ partition@110000 {
+ label = "SSD";
+ reg = <0x0110000 0x0010000>;
+ read-only;
+ };
+
+ partition@120000 {
+ label = "TZ";
+ reg = <0x0120000 0x0080000>;
+ read-only;
+ };
+
+ partition@1a0000 {
+ label = "RPM";
+ reg = <0x01a0000 0x0080000>;
+ read-only;
+ };
+
+ partition@220000 {
+ label = "APPSBL";
+ reg = <0x0220000 0x0080000>;
+ read-only;
+ };
+
+ partition@2a0000 {
+ label = "APPSBLENV";
+ reg = <0x02a0000 0x0010000>;
+ read-only;
+ };
+
+ factory: partition@2b0000 {
+ label = "PRODUCTDATA";
+ reg = <0x02b0000 0x0030000>;
+ read-only;
+ };
+
+ partition@2e0000 {
+ label = "ART";
+ reg = <0x02e0000 0x0040000>;
+ read-only;
+ };
+
+ partition@320000 {
+ label = "TP";
+ reg = <0x0320000 0x0040000>;
+ read-only;
+ };
+
+ partition@360000 {
+ label = "TINY";
+ reg = <0x0360000 0x0500000>;
+ read-only;
+ };
+
+ partition@860000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x0860000 0x17a0000>;
+ };
+ };
+ };
+ };
+};
+
+&adm_dma {
+ status = "okay";
+};
+
+&pcie0 {
+ status = "okay";
+
+ bridge@0,0 {
+ reg = <0x00000000 0 0 0 0>;
+ #address-cells = <3>;
+ #size-cells = <2>;
+ ranges;
+
+ wifi@1,0 {
+ compatible = "qcom,ath10k";
+ reg = <0x00010000 0 0 0 0>;
+
+ qcom,ath10k-calibration-variant = "NEC-Platforms-WG2600HP3";
+ };
+ };
+};
+
+&pcie1 {
+ status = "okay";
+ force_gen1 = <1>;
+
+ bridge@0,0 {
+ reg = <0x00000000 0 0 0 0>;
+ #address-cells = <3>;
+ #size-cells = <2>;
+ ranges;
+
+ wifi@1,0 {
+ compatible = "qcom,ath10k";
+ reg = <0x00010000 0 0 0 0>;
+
+ ieee80211-freq-limit = <2400000 2483000>;
+ qcom,ath10k-calibration-variant = "NEC-Platforms-WG2600HP3";
+ };
+ };
+};
+
+&mdio0 {
+ status = "okay";
+
+ pinctrl-0 = <&mdio0_pins>;
+ pinctrl-names = "default";
+
+ phy0: ethernet-phy@0 {
+ reg = <0>;
+ qca,ar8327-initvals = <
+ 0x04 0x80080080 /* PAD0_MODE */
+ 0x0c 0x06000000 /* PAD6_MODE */
+ 0x10 0x002613a0 /* PWS_REG */
+ 0x50 0xcc36cc36 /* LED_CTRL0 */
+ 0x54 0xca36ca36 /* LED_CTRL1 */
+ 0x58 0xc936c936 /* LED_CTRL2 */
+ 0x5c 0x03ffff00 /* LED_CTRL3 */
+ 0x7c 0x0000004e /* PORT0_STATUS */
+ 0x94 0x0000004e /* PORT6_STATUS */
+ 0xe0 0xc74164de /* SGMII_CTRL */
+ 0xe4 0x0006a545 /* MAC_PWR_SEL */
+ >;
+ };
+};
+
+&gmac1 {
+ status = "okay";
+
+ pinctrl-0 = <&rgmii2_pins>;
+ pinctrl-names = "default";
+
+ phy-mode = "rgmii";
+ qcom,id = <1>;
+ mdiobus = <&mdio0>;
+ mtd-mac-address = <&factory 0x0>;
+
+ fixed-link {
+ speed = <1000>;
+ full-duplex;
+ };
+};
+
+&gmac2 {
+ status = "okay";
+ phy-mode = "sgmii";
+ qcom,id = <2>;
+ mdiobus = <&mdio0>;
+ mtd-mac-address = <&factory 0x6>;
+
+ fixed-link {
+ speed = <1000>;
+ full-duplex;
+ };
+};
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index ad7c4b94d2..80bfec5ad9 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -193,6 +193,20 @@ define Device/nec_wg2600hp
endef
TARGET_DEVICES += nec_wg2600hp
+define Device/nec_wg2600hp3
+ $(call Device/LegacyImage)
+ DEVICE_VENDOR := NEC Platforms
+ DEVICE_MODEL := Aterm WG2600HP3
+ SOC := qcom-ipq8062
+ BLOCKSIZE := 64k
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+ DEVICE_PACKAGES := -kmod-ata-ahci -kmod-ata-ahci-platform -kmod-usb-ohci -kmod-usb2 \
+ -kmod-usb-ledtrig-usbport -kmod-usb-phy-qcom-dwc3 -kmod-usb3 -kmod-usb-dwc3-qcom \
+ ath10k-firmware-qca9984-ct ipq-wifi-nec_wg2600hp3
+endef
+TARGET_DEVICES += nec_wg2600hp3
+
define Device/netgear_d7800
$(call Device/DniImage)
DEVICE_VENDOR := NETGEAR
diff --git a/target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch b/target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch
index 6bbf184ac7..795684cdf5 100644
--- a/target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch
+++ b/target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch
@@ -10,9 +10,10 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
-@@ -843,6 +843,21 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -843,6 +843,22 @@ dtb-$(CONFIG_ARCH_QCOM) += \
qcom-ipq4019-ap.dk07.1-c1.dtb \
qcom-ipq4019-ap.dk07.1-c2.dtb \
++ qcom-ipq8062-wg2600hp3.dtb \
qcom-ipq8064-ap148.dtb \
+ qcom-ipq8064-c2600.dtb \
+ qcom-ipq8064-d7800.dtb \