aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-07-21 16:18:58 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-07-21 16:48:35 +0100
commit089c2bb2178daa144baa2e3ed20a55fb9a5c11ab (patch)
tree4d96cb251ba49c690811176c9c2ab6a587132252
parent5096f0513b7d2d3fc1004578e8ef3c03fdfa7c1f (diff)
downloadupstream-089c2bb2178daa144baa2e3ed20a55fb9a5c11ab.tar.gz
upstream-089c2bb2178daa144baa2e3ed20a55fb9a5c11ab.tar.bz2
upstream-089c2bb2178daa144baa2e3ed20a55fb9a5c11ab.zip
mediatek: mt7623: yet another legacy image variable restored
Restore BOOTFS_BLOCKS variable until U7623 gets brushed, so things hopefully build now. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--target/linux/mediatek/image/mt7623.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/mt7623.mk b/target/linux/mediatek/image/mt7623.mk
index 653da6b2c0..9a938662c3 100644
--- a/target/linux/mediatek/image/mt7623.mk
+++ b/target/linux/mediatek/image/mt7623.mk
@@ -113,6 +113,11 @@ endef
TARGET_DEVICES += bananapi_bpi-r2
+ifneq ($(CONFIG_MTK_BOOT_PARTSIZE),)
+BOOTFS_BLOCK_SIZE := 1024
+BOOTFS_BLOCKS := $(shell echo $$(($(CONFIG_MTK_BOOT_PARTSIZE)*1024*1024/$(BOOTFS_BLOCK_SIZE))))
+endif
+
define Build/mtk-mmc-img
rm -f $@.boot
mkfs.fat -C $@.boot $(BOOTFS_BLOCKS)
@@ -140,6 +145,7 @@ define Build/scatterfile
$(subst -scatter.txt,,$(notdir $@)) "$(DEVICE_TITLE)" > $@
endef
+
# Full eMMC image including U-Boot and partition table
define Device/unielec_u7623-emmc
DEVICE_VENDOR := UniElec