aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-07-21 15:32:00 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-07-21 15:34:21 +0100
commit5096f0513b7d2d3fc1004578e8ef3c03fdfa7c1f (patch)
treec1cc55417f026dd55c334ca5f094d1be280dc64c
parent373c08bcbb08b49715919597ed400abb4dd169c9 (diff)
downloadupstream-5096f0513b7d2d3fc1004578e8ef3c03fdfa7c1f.tar.gz
upstream-5096f0513b7d2d3fc1004578e8ef3c03fdfa7c1f.tar.bz2
upstream-5096f0513b7d2d3fc1004578e8ef3c03fdfa7c1f.zip
mediatek: mt7623: allow build without ext4 rootfs
The image generation code for the U7623 board expects ext4 filesystem to be selected in menuconfig and CONFIG_TARGET_ROOTFS_PARTSIZE to be defined. Now that ext4 isn't enabled any more, the variable was missing and broke the build. Set the default (104) instead of using the config variable to fix that. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--target/linux/mediatek/image/mt7623.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mediatek/image/mt7623.mk b/target/linux/mediatek/image/mt7623.mk
index 00c1ac4443..653da6b2c0 100644
--- a/target/linux/mediatek/image/mt7623.mk
+++ b/target/linux/mediatek/image/mt7623.mk
@@ -132,7 +132,7 @@ define Build/mtk-mmc-img
$@.boot \
$(IMAGE_ROOTFS) \
$(CONFIG_MTK_BOOT_PARTSIZE) \
- $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+ 104
endef
define Build/scatterfile