aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xrx200/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/xrx200/profiles')
-rw-r--r--target/linux/lantiq/xrx200/profiles/arv.mk46
-rw-r--r--target/linux/lantiq/xrx200/profiles/avm.mk9
-rw-r--r--target/linux/lantiq/xrx200/profiles/bt.mk9
-rw-r--r--target/linux/lantiq/xrx200/profiles/lantiq.mk13
-rw-r--r--target/linux/lantiq/xrx200/profiles/tplink.mk13
-rw-r--r--target/linux/lantiq/xrx200/profiles/zyxel.mk20
6 files changed, 110 insertions, 0 deletions
diff --git a/target/linux/lantiq/xrx200/profiles/arv.mk b/target/linux/lantiq/xrx200/profiles/arv.mk
new file mode 100644
index 0000000..3dc22c0
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/arv.mk
@@ -0,0 +1,46 @@
+define Profile/VG3503J
+ NAME:=BT Openreach - ECI VDSL Modem
+endef
+
+$(eval $(call Profile,VG3503J))
+
+define Profile/VG3503J_V2
+ NAME:=BT Openreach - ECI VDSL Modem v2
+endef
+
+$(eval $(call Profile,VG3503J_V2))
+
+define Profile/VGV7510KW22NOR
+ NAME:=o2 Box 6431 / Arcadyan VGV7510KW22 (NOR)
+ PACKAGES:=kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,VGV7510KW22NOR))
+
+define Profile/VGV7510KW22BRN
+ NAME:=o2 Box 6431 / Arcadyan VGV7510KW22 (BRN)
+ PACKAGES:=kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,VGV7510KW22BRN))
+
+define Profile/VGV7519NOR
+ NAME:=Experiabox 8 VGV7519
+ PACKAGES:=kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,VGV7519NOR))
+
+define Profile/VGV7519BRN
+ NAME:=Experiabox 8 VGV7519 (BRN)
+ PACKAGES:=kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,VGV7519BRN))
+
+define Profile/ARV7519RW22
+ NAME:=Livebox Astoria ARV7519RW22
+ PACKAGES:=kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,ARV7519RW22))
diff --git a/target/linux/lantiq/xrx200/profiles/avm.mk b/target/linux/lantiq/xrx200/profiles/avm.mk
new file mode 100644
index 0000000..89909b9
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/avm.mk
@@ -0,0 +1,9 @@
+define Profile/FRITZ3370
+ NAME:=Fritz!Box WLan - FRITZ3370
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-dwc2
+endef
+
+FRITZ3370_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+FRITZ3370_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,FRITZ3370))
diff --git a/target/linux/lantiq/xrx200/profiles/bt.mk b/target/linux/lantiq/xrx200/profiles/bt.mk
new file mode 100644
index 0000000..a1083bb
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/bt.mk
@@ -0,0 +1,9 @@
+define Profile/BTHOMEHUBV5A
+ NAME:=BT Home Hub 5A
+ PACKAGES:=kmod-ath9k kmod-ath10k wpad-mini kmod-usb-dwc2
+endef
+
+BTHOMEHUBV5A_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+BTHOMEHUBV5A_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,BTHOMEHUBV5A))
diff --git a/target/linux/lantiq/xrx200/profiles/lantiq.mk b/target/linux/lantiq/xrx200/profiles/lantiq.mk
new file mode 100644
index 0000000..0ec6be4
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/lantiq.mk
@@ -0,0 +1,13 @@
+define Profile/EASY80920NOR
+ NAME:=Lantiq VR9 - EASY80920NOR
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,EASY80920NOR))
+
+define Profile/EASY80920NAND
+ NAME:=Lantiq VR9 - EASY80920NAND
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,EASY80920NAND))
diff --git a/target/linux/lantiq/xrx200/profiles/tplink.mk b/target/linux/lantiq/xrx200/profiles/tplink.mk
new file mode 100644
index 0000000..6ae9399
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/tplink.mk
@@ -0,0 +1,13 @@
+define Profile/TDW8970
+ NAME:=TP-LINK TD-W8970
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-dwc2 kmod-ledtrig-usbdev
+endef
+
+$(eval $(call Profile,TDW8970))
+
+define Profile/TDW8980
+ NAME:=TP-LINK TD-W8980
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-dwc2 kmod-ledtrig-usbdev
+endef
+
+$(eval $(call Profile,TDW8980))
diff --git a/target/linux/lantiq/xrx200/profiles/zyxel.mk b/target/linux/lantiq/xrx200/profiles/zyxel.mk
new file mode 100644
index 0000000..f6995f9
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/zyxel.mk
@@ -0,0 +1,20 @@
+define Profile/P2812HNUF1
+ NAME:=ZyXEL P-2812HNU-F1
+ PACKAGES:=kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+P2812HNUF1_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+P2812HNUF1_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,P2812HNUF1))
+
+define Profile/P2812HNUF3
+ NAME:=ZyXEL P-2812HNU-F3
+ PACKAGES:=kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+P2812HNUF3_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+P2812HNUF3_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,P2812HNUF3))
+