aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xrx200
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/xrx200')
-rw-r--r--target/linux/lantiq/xrx200/config-default76
-rw-r--r--target/linux/lantiq/xrx200/profiles/arv.mk46
-rw-r--r--target/linux/lantiq/xrx200/profiles/avm.mk9
-rw-r--r--target/linux/lantiq/xrx200/profiles/bt.mk9
-rw-r--r--target/linux/lantiq/xrx200/profiles/lantiq.mk13
-rw-r--r--target/linux/lantiq/xrx200/profiles/tplink.mk13
-rw-r--r--target/linux/lantiq/xrx200/profiles/zyxel.mk20
-rw-r--r--target/linux/lantiq/xrx200/target.mk23
8 files changed, 209 insertions, 0 deletions
diff --git a/target/linux/lantiq/xrx200/config-default b/target/linux/lantiq/xrx200/config-default
new file mode 100644
index 0000000..c18ad1f
--- /dev/null
+++ b/target/linux/lantiq/xrx200/config-default
@@ -0,0 +1,76 @@
+CONFIG_ADM6996_PHY=y
+CONFIG_AR8216_PHY=y
+# CONFIG_ARCH_HAS_SG_CHAIN is not set
+CONFIG_ARCH_MIGHT_HAVE_PC_PARPORT=y
+CONFIG_ARCH_MIGHT_HAVE_PC_SERIO=y
+CONFIG_CLONE_BACKWARDS=y
+CONFIG_CPU_NEEDS_NO_SMARTMIPS_OR_MICROMIPS=y
+CONFIG_CPU_SUPPORTS_MSA=y
+CONFIG_CRC16=y
+CONFIG_CRYPTO_DEFLATE=y
+CONFIG_CRYPTO_LZO=y
+CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_GPIO_DEVRES=y
+CONFIG_HAS_IOPORT_MAP=y
+# CONFIG_HAVE_64BIT_ALIGNED_ACCESS is not set
+CONFIG_HAVE_ARCH_SECCOMP_FILTER=y
+CONFIG_HAVE_ARCH_TRACEHOOK=y
+# CONFIG_HAVE_BOOTMEM_INFO_NODE is not set
+CONFIG_HAVE_BPF_JIT=y
+CONFIG_HAVE_CC_STACKPROTECTOR=y
+CONFIG_HAVE_CONTEXT_TRACKING=y
+CONFIG_HAVE_DEBUG_STACKOVERFLOW=y
+CONFIG_HAVE_DMA_CONTIGUOUS=y
+CONFIG_HAVE_SYSCALL_TRACEPOINTS=y
+CONFIG_HZ_PERIODIC=y
+CONFIG_INPUT=y
+CONFIG_INPUT_EVDEV=y
+CONFIG_INPUT_POLLDEV=y
+CONFIG_IRQCHIP=y
+CONFIG_IRQ_WORK=y
+# CONFIG_ISDN is not set
+CONFIG_LANTIQ_PHY=y
+CONFIG_LANTIQ_XRX200=y
+CONFIG_LEDS_TRIGGER_HEARTBEAT=y
+CONFIG_LIBFDT=y
+CONFIG_LZO_COMPRESS=y
+CONFIG_LZO_DECOMPRESS=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_PLATFORM=y
+CONFIG_MTD_NAND_XWAY=y
+# CONFIG_MTD_PHYSMAP_OF is not set
+CONFIG_MTD_UBI=y
+CONFIG_MTD_UBI_BEB_LIMIT=20
+CONFIG_MTD_UBI_BLOCK=y
+# CONFIG_MTD_UBI_FASTMAP is not set
+# CONFIG_MTD_UBI_GLUEBI is not set
+CONFIG_MTD_UBI_WL_THRESHOLD=4096
+CONFIG_NLS=y
+# CONFIG_NO_IOPORT_MAP is not set
+CONFIG_OF_ADDRESS_PCI=y
+CONFIG_PCIE_LANTIQ=y
+# CONFIG_RCU_STALL_COMMON is not set
+CONFIG_RTL8306_PHY=y
+CONFIG_RTL8366S_PHY=y
+CONFIG_RTL8367B_PHY=y
+CONFIG_RTL8367_PHY=y
+CONFIG_SPI=y
+CONFIG_SPI_BITBANG=y
+CONFIG_SPI_GPIO=y
+CONFIG_SPI_MASTER=y
+CONFIG_SPI_XWAY=y
+CONFIG_SYS_SUPPORTS_MIPS16=y
+CONFIG_UBIFS_FS=y
+CONFIG_UBIFS_FS_ADVANCED_COMPR=y
+CONFIG_UBIFS_FS_LZO=y
+# CONFIG_UBIFS_FS_XZ is not set
+CONFIG_UBIFS_FS_ZLIB=y
+CONFIG_USB=y
+CONFIG_USB_COMMON=y
+# CONFIG_USB_EHCI_HCD is not set
+CONFIG_USB_SUPPORT=y
+# CONFIG_USB_UHCI_HCD is not set
+CONFIG_XRX200_PHY_FW=y
+CONFIG_ZLIB_DEFLATE=y
+CONFIG_ZLIB_INFLATE=y
diff --git a/target/linux/lantiq/xrx200/profiles/arv.mk b/target/linux/lantiq/xrx200/profiles/arv.mk
new file mode 100644
index 0000000..3dc22c0
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/arv.mk
@@ -0,0 +1,46 @@
+define Profile/VG3503J
+ NAME:=BT Openreach - ECI VDSL Modem
+endef
+
+$(eval $(call Profile,VG3503J))
+
+define Profile/VG3503J_V2
+ NAME:=BT Openreach - ECI VDSL Modem v2
+endef
+
+$(eval $(call Profile,VG3503J_V2))
+
+define Profile/VGV7510KW22NOR
+ NAME:=o2 Box 6431 / Arcadyan VGV7510KW22 (NOR)
+ PACKAGES:=kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,VGV7510KW22NOR))
+
+define Profile/VGV7510KW22BRN
+ NAME:=o2 Box 6431 / Arcadyan VGV7510KW22 (BRN)
+ PACKAGES:=kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,VGV7510KW22BRN))
+
+define Profile/VGV7519NOR
+ NAME:=Experiabox 8 VGV7519
+ PACKAGES:=kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,VGV7519NOR))
+
+define Profile/VGV7519BRN
+ NAME:=Experiabox 8 VGV7519 (BRN)
+ PACKAGES:=kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,VGV7519BRN))
+
+define Profile/ARV7519RW22
+ NAME:=Livebox Astoria ARV7519RW22
+ PACKAGES:=kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,ARV7519RW22))
diff --git a/target/linux/lantiq/xrx200/profiles/avm.mk b/target/linux/lantiq/xrx200/profiles/avm.mk
new file mode 100644
index 0000000..89909b9
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/avm.mk
@@ -0,0 +1,9 @@
+define Profile/FRITZ3370
+ NAME:=Fritz!Box WLan - FRITZ3370
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-dwc2
+endef
+
+FRITZ3370_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+FRITZ3370_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,FRITZ3370))
diff --git a/target/linux/lantiq/xrx200/profiles/bt.mk b/target/linux/lantiq/xrx200/profiles/bt.mk
new file mode 100644
index 0000000..a1083bb
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/bt.mk
@@ -0,0 +1,9 @@
+define Profile/BTHOMEHUBV5A
+ NAME:=BT Home Hub 5A
+ PACKAGES:=kmod-ath9k kmod-ath10k wpad-mini kmod-usb-dwc2
+endef
+
+BTHOMEHUBV5A_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+BTHOMEHUBV5A_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,BTHOMEHUBV5A))
diff --git a/target/linux/lantiq/xrx200/profiles/lantiq.mk b/target/linux/lantiq/xrx200/profiles/lantiq.mk
new file mode 100644
index 0000000..0ec6be4
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/lantiq.mk
@@ -0,0 +1,13 @@
+define Profile/EASY80920NOR
+ NAME:=Lantiq VR9 - EASY80920NOR
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,EASY80920NOR))
+
+define Profile/EASY80920NAND
+ NAME:=Lantiq VR9 - EASY80920NAND
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-dwc2
+endef
+
+$(eval $(call Profile,EASY80920NAND))
diff --git a/target/linux/lantiq/xrx200/profiles/tplink.mk b/target/linux/lantiq/xrx200/profiles/tplink.mk
new file mode 100644
index 0000000..6ae9399
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/tplink.mk
@@ -0,0 +1,13 @@
+define Profile/TDW8970
+ NAME:=TP-LINK TD-W8970
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-dwc2 kmod-ledtrig-usbdev
+endef
+
+$(eval $(call Profile,TDW8970))
+
+define Profile/TDW8980
+ NAME:=TP-LINK TD-W8980
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-dwc2 kmod-ledtrig-usbdev
+endef
+
+$(eval $(call Profile,TDW8980))
diff --git a/target/linux/lantiq/xrx200/profiles/zyxel.mk b/target/linux/lantiq/xrx200/profiles/zyxel.mk
new file mode 100644
index 0000000..f6995f9
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/zyxel.mk
@@ -0,0 +1,20 @@
+define Profile/P2812HNUF1
+ NAME:=ZyXEL P-2812HNU-F1
+ PACKAGES:=kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+P2812HNUF1_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+P2812HNUF1_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,P2812HNUF1))
+
+define Profile/P2812HNUF3
+ NAME:=ZyXEL P-2812HNU-F3
+ PACKAGES:=kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+P2812HNUF3_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+P2812HNUF3_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,P2812HNUF3))
+
diff --git a/target/linux/lantiq/xrx200/target.mk b/target/linux/lantiq/xrx200/target.mk
new file mode 100644
index 0000000..a235015
--- /dev/null
+++ b/target/linux/lantiq/xrx200/target.mk
@@ -0,0 +1,23 @@
+ARCH:=mips
+SUBTARGET:=xrx200
+BOARDNAME:=XRX200
+FEATURES:=squashfs atm mips16 jffs2 nand ubifs
+CPU_TYPE:=34kc
+CPU_SUBTYPE:=dsp
+
+DEFAULT_PACKAGES+=kmod-leds-gpio \
+ kmod-gpio-button-hotplug \
+ ltq-vdsl-vr9-fw-installer \
+ kmod-ltq-vdsl-vr9-mei \
+ kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 \
+ kmod-ltq-ptm-vr9 \
+ kmod-ltq-deu-vr9 \
+ ltq-vdsl-app \
+ ppp-mod-pppoa \
+ swconfig \
+ atm-esi
+
+define Target/Description
+ Lantiq XRX200
+endef