aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/patches-3.18/180-goflexhome.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/kirkwood/patches-3.18/180-goflexhome.patch')
-rw-r--r--target/linux/kirkwood/patches-3.18/180-goflexhome.patch140
1 files changed, 140 insertions, 0 deletions
diff --git a/target/linux/kirkwood/patches-3.18/180-goflexhome.patch b/target/linux/kirkwood/patches-3.18/180-goflexhome.patch
new file mode 100644
index 0000000..e54c853
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.18/180-goflexhome.patch
@@ -0,0 +1,140 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -122,6 +122,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += kirkwood-
+ kirkwood-ds411slim.dtb \
+ kirkwood-ea3500.dtb \
+ kirkwood-ea4500.dtb \
++ kirkwood-goflexhome.dtb \
+ kirkwood-goflexnet.dtb \
+ kirkwood-guruplug-server-plus.dtb \
+ kirkwood-ib62x0.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/kirkwood-goflexhome.dts
+@@ -0,0 +1,127 @@
++/dts-v1/;
++
++#include "kirkwood.dtsi"
++#include "kirkwood-6281.dtsi"
++
++/ {
++ model = "Seagate GoFlex Home";
++ compatible = "seagate,goflexhome", "marvell,kirkwood-88f6281", "marvell,kirkwood";
++
++ memory {
++ device_type = "memory";
++ reg = <0x00000000 0x8000000>;
++ };
++
++ chosen {
++ bootargs = "console=ttyS0,115200n8 earlyprintk root=/dev/sda1 rootdelay=10";
++ stdout-path = &uart0;
++ };
++
++ ocp@f1000000 {
++ pinctrl: pin-controller@10000 {
++ pmx_usb_power_enable: pmx-usb-power-enable {
++ marvell,pins = "mpp29";
++ marvell,function = "gpio";
++ };
++ pmx_led_white: pmx-led-white {
++ marvell,pins = "mpp40";
++ marvell,function = "gpio";
++ };
++ pmx_led_green: pmx-led_green {
++ marvell,pins = "mpp46";
++ marvell,function = "gpio";
++ };
++ pmx_led_orange: pmx-led-orange {
++ marvell,pins = "mpp47";
++ marvell,function = "gpio";
++ };
++ };
++ serial@12000 {
++ status = "ok";
++ };
++
++ sata@80000 {
++ status = "okay";
++ nr-ports = <2>;
++ };
++
++ };
++ gpio-leds {
++ compatible = "gpio-leds";
++
++ health {
++ label = "status:green:health";
++ gpios = <&gpio1 14 1>;
++ linux,default-trigger = "default-on";
++ };
++ fault {
++ label = "status:orange:fault";
++ gpios = <&gpio1 15 1>;
++ };
++ misc {
++ label = "status:white:misc";
++ gpios = <&gpio1 8 1>;
++ linux,default-trigger = "ide-disk";
++ };
++ };
++ regulators {
++ compatible = "simple-bus";
++ #address-cells = <1>;
++ #size-cells = <0>;
++ pinctrl-0 = <&pmx_usb_power_enable>;
++ pinctrl-names = "default";
++
++ usb_power: regulator@1 {
++ compatible = "regulator-fixed";
++ reg = <1>;
++ regulator-name = "USB Power";
++ regulator-min-microvolt = <5000000>;
++ regulator-max-microvolt = <5000000>;
++ enable-active-high;
++ regulator-always-on;
++ regulator-boot-on;
++ gpio = <&gpio0 29 GPIO_ACTIVE_HIGH>;
++ };
++ };
++};
++
++&nand {
++ chip-delay = <40>;
++ status = "okay";
++
++ partition@0 {
++ label = "u-boot";
++ reg = <0x0000000 0x100000>;
++ read-only;
++ };
++
++ partition@100000 {
++ label = "uImage";
++ reg = <0x0100000 0x400000>;
++ };
++
++ partition@500000 {
++ label = "pogoplug";
++ reg = <0x0500000 0x2000000>;
++ };
++
++ partition@2500000 {
++ label = "root";
++ reg = <0x02500000 0xd800000>;
++ };
++};
++
++&mdio {
++ status = "okay";
++
++ ethphy0: ethernet-phy@0 {
++ reg = <0>;
++ };
++};
++
++&eth0 {
++ status = "okay";
++ ethernet0-port@0 {
++ phy-handle = <&ethphy0>;
++ };
++};