aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/patches-3.18
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/kirkwood/patches-3.18')
-rw-r--r--target/linux/kirkwood/patches-3.18/110-ib62x0.patch20
-rw-r--r--target/linux/kirkwood/patches-3.18/120-iomega_ix2_200.patch13
-rw-r--r--target/linux/kirkwood/patches-3.18/130-iconnect.patch41
-rw-r--r--target/linux/kirkwood/patches-3.18/140-dockstar.patch32
-rw-r--r--target/linux/kirkwood/patches-3.18/150-pogoplug_e02.patch127
-rw-r--r--target/linux/kirkwood/patches-3.18/160-ea4500.patch180
-rw-r--r--target/linux/kirkwood/patches-3.18/170-ea3500.patch173
-rw-r--r--target/linux/kirkwood/patches-3.18/180-goflexhome.patch140
-rw-r--r--target/linux/kirkwood/patches-3.18/190-nsa310s.patch300
-rw-r--r--target/linux/kirkwood/patches-3.18/200-disable-tso.patch35
10 files changed, 1061 insertions, 0 deletions
diff --git a/target/linux/kirkwood/patches-3.18/110-ib62x0.patch b/target/linux/kirkwood/patches-3.18/110-ib62x0.patch
new file mode 100644
index 0000000..153c41b
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.18/110-ib62x0.patch
@@ -0,0 +1,20 @@
+--- a/arch/arm/boot/dts/kirkwood-ib62x0.dts
++++ b/arch/arm/boot/dts/kirkwood-ib62x0.dts
+@@ -117,13 +117,13 @@
+ };
+
+ partition@100000 {
+- label = "uImage";
+- reg = <0x0100000 0x600000>;
++ label = "second stage u-boot";
++ reg = <0x100000 0x200000>;
+ };
+
+- partition@700000 {
++ partition@200000 {
+ label = "root";
+- reg = <0x0700000 0xf900000>;
++ reg = <0x200000 0xfe00000>;
+ };
+
+ };
diff --git a/target/linux/kirkwood/patches-3.18/120-iomega_ix2_200.patch b/target/linux/kirkwood/patches-3.18/120-iomega_ix2_200.patch
new file mode 100644
index 0000000..33f7004
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.18/120-iomega_ix2_200.patch
@@ -0,0 +1,13 @@
+--- a/arch/arm/boot/dts/kirkwood-iomega_ix2_200.dts
++++ b/arch/arm/boot/dts/kirkwood-iomega_ix2_200.dts
+@@ -192,8 +192,8 @@
+ };
+
+ partition@400000 {
+- label = "uInitrd";
+- reg = <0x540000 0x1000000>;
++ label = "rootfs";
++ reg = <0x400000 0x1C00000>;
+ };
+ };
+
diff --git a/target/linux/kirkwood/patches-3.18/130-iconnect.patch b/target/linux/kirkwood/patches-3.18/130-iconnect.patch
new file mode 100644
index 0000000..c95579d
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.18/130-iconnect.patch
@@ -0,0 +1,41 @@
+--- a/arch/arm/boot/dts/kirkwood-iconnect.dts
++++ b/arch/arm/boot/dts/kirkwood-iconnect.dts
+@@ -155,28 +155,23 @@
+ status = "okay";
+
+ partition@0 {
+- label = "uboot";
+- reg = <0x0000000 0xc0000>;
++ label = "u-boot";
++ reg = <0x0000000 0xe0000>;
+ };
+
+- partition@a0000 {
+- label = "env";
+- reg = <0xa0000 0x20000>;
++ partition@e0000 {
++ label = "u-boot environment";
++ reg = <0xe0000 0x100000>;
+ };
+
+ partition@100000 {
+- label = "zImage";
+- reg = <0x100000 0x300000>;
++ label = "second stage u-boot";
++ reg = <0x100000 0x200000>;
+ };
+
+- partition@540000 {
+- label = "initrd";
+- reg = <0x540000 0x300000>;
+- };
+-
+- partition@980000 {
+- label = "boot";
+- reg = <0x980000 0x1f400000>;
++ partition@200000 {
++ label = "root";
++ reg = <0x200000 0x1fe00000>;
+ };
+ };
+
diff --git a/target/linux/kirkwood/patches-3.18/140-dockstar.patch b/target/linux/kirkwood/patches-3.18/140-dockstar.patch
new file mode 100644
index 0000000..b1ad669
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.18/140-dockstar.patch
@@ -0,0 +1,32 @@
+--- a/arch/arm/boot/dts/kirkwood-dockstar.dts
++++ b/arch/arm/boot/dts/kirkwood-dockstar.dts
+@@ -77,18 +77,22 @@
+
+ partition@0 {
+ label = "u-boot";
+- reg = <0x0000000 0x100000>;
+- read-only;
++ reg = <0x0000000 0xe0000>;
++ };
++
++ partition@e0000 {
++ label = "u-boot environment";
++ reg = <0xe0000 0x100000>;
+ };
+
+ partition@100000 {
+- label = "uImage";
+- reg = <0x0100000 0x400000>;
++ label = "second stage u-boot";
++ reg = <0x100000 0x200000>;
+ };
+
+- partition@500000 {
+- label = "data";
+- reg = <0x0500000 0xfb00000>;
++ partition@200000 {
++ label = "root";
++ reg = <0x200000 0xfe00000>;
+ };
+ };
+
diff --git a/target/linux/kirkwood/patches-3.18/150-pogoplug_e02.patch b/target/linux/kirkwood/patches-3.18/150-pogoplug_e02.patch
new file mode 100644
index 0000000..561c07f
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.18/150-pogoplug_e02.patch
@@ -0,0 +1,127 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -147,6 +147,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += kirkwood-
+ kirkwood-openrd-base.dtb \
+ kirkwood-openrd-client.dtb \
+ kirkwood-openrd-ultimate.dtb \
++ kirkwood-pogo_e02.dtb \
+ kirkwood-rd88f6192.dtb \
+ kirkwood-rd88f6281-z0.dtb \
+ kirkwood-rd88f6281-a.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/kirkwood-pogo_e02.dts
+@@ -0,0 +1,114 @@
++/dts-v1/;
++
++#include "kirkwood.dtsi"
++#include "kirkwood-6281.dtsi"
++
++/ {
++ model = "Cloud Engines Pogoplug E02";
++ compatible = "cloudengines,pogoe02", "marvell,kirkwood-88f6281", "marvell,kirkwood";
++
++ memory {
++ device_type = "memory";
++ reg = <0x00000000 0x10000000>;
++ };
++
++ chosen {
++ bootargs = "console=ttyS0,115200n8 earlyprintk";
++ };
++
++ ocp@f1000000 {
++ pinctrl: pin-controller@10000 {
++ pmx_usb_power_enable: pmx-usb-power-enable {
++ marvell,pins = "mpp29";
++ marvell,function = "gpio";
++ };
++ pmx_led_green: pmx-led_green {
++ marvell,pins = "mpp48";
++ marvell,function = "gpio";
++ };
++ pmx_led_orange: pmx-led_orange {
++ marvell,pins = "mpp49";
++ marvell,function = "gpio";
++ };
++ };
++ serial@12000 {
++ status = "ok";
++ };
++ };
++ gpio-leds {
++ compatible = "gpio-leds";
++ pinctrl-0 = < &pmx_usb_power_enable &pmx_led_orange
++ &pmx_led_green >;
++ pinctrl-names = "default";
++
++ health {
++ label = "status:green:health";
++ gpios = <&gpio1 16 GPIO_ACTIVE_LOW>;
++ default-state = "keep";
++ };
++ fault {
++ label = "status:orange:fault";
++ gpios = <&gpio1 17 GPIO_ACTIVE_LOW>;
++ };
++ };
++ regulators {
++ compatible = "simple-bus";
++ #address-cells = <1>;
++ #size-cells = <0>;
++ pinctrl-0 = <&pmx_usb_power_enable>;
++ pinctrl-names = "default";
++
++ usb_power: regulator@1 {
++ compatible = "regulator-fixed";
++ reg = <1>;
++ regulator-name = "USB Power";
++ regulator-min-microvolt = <5000000>;
++ regulator-max-microvolt = <5000000>;
++ enable-active-high;
++ regulator-always-on;
++ regulator-boot-on;
++ gpio = <&gpio0 29 GPIO_ACTIVE_HIGH>;
++ };
++ };
++};
++
++&nand {
++ chip-delay = <40>;
++ status = "okay";
++
++ partition@0 {
++ label = "u-boot";
++ reg = <0x0000000 0x100000>;
++ read-only;
++ };
++
++ partition@100000 {
++ label = "uImage";
++ reg = <0x0100000 0x400000>;
++ };
++
++ partition@500000 {
++ label = "pogoplug";
++ reg = <0x0500000 0x2000000>;
++ };
++
++ partition@2500000 {
++ label = "root";
++ reg = <0x02500000 0x5b00000>;
++ };
++};
++
++&mdio {
++ status = "okay";
++
++ ethphy0: ethernet-phy@0 {
++ reg = <0>;
++ };
++};
++
++&eth0 {
++ status = "okay";
++ ethernet0-port@0 {
++ phy-handle = <&ethphy0>;
++ };
++};
diff --git a/target/linux/kirkwood/patches-3.18/160-ea4500.patch b/target/linux/kirkwood/patches-3.18/160-ea4500.patch
new file mode 100644
index 0000000..386b5ea
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.18/160-ea4500.patch
@@ -0,0 +1,180 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -120,6 +120,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += kirkwood-
+ kirkwood-ds411.dtb \
+ kirkwood-ds411j.dtb \
+ kirkwood-ds411slim.dtb \
++ kirkwood-ea4500.dtb \
+ kirkwood-goflexnet.dtb \
+ kirkwood-guruplug-server-plus.dtb \
+ kirkwood-ib62x0.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/kirkwood-ea4500.dts
+@@ -0,0 +1,167 @@
++/*
++ * kirkwood-ea4500.dts - Device Tree file for Linksys EA4500
++ *
++ * (c) 2013 Jonas Gorski <jogo@openwrt.org>
++ * (c) 2013 Deutsche Telekom Innovation Laboratories
++ * (c) 2014 Luka Perkov <luka@openwrt.org>
++ *
++ * This file is licensed under the terms of the GNU General Public
++ * License version 2. This program is licensed "as is" without any
++ * warranty of any kind, whether express or implied.
++ */
++
++/dts-v1/;
++
++#include "kirkwood.dtsi"
++#include "kirkwood-6282.dtsi"
++
++/ {
++ model = "Linksys EA4500";
++ compatible = "linksys,ea4500", "marvell,kirkwood-88f6282", "marvell,kirkwood";
++
++ memory {
++ device_type = "memory";
++ reg = <0x00000000 0x8000000>;
++ };
++
++ chosen {
++ bootargs = "console=ttyS0,115200n8 earlyprintk";
++ };
++
++ mbus {
++ pcie-controller {
++ status = "okay";
++
++ pcie@1,0 {
++ status = "okay";
++ };
++
++ pcie@2,0 {
++ status = "okay";
++ };
++ };
++ };
++
++ ocp@f1000000 {
++ pinctrl: pin-controller@10000 {
++ pmx_led_white_health: pmx-led-white-health {
++ marvell,pins = "mpp7";
++ marvell,function = "gpo";
++ };
++ pmx_led_white_pulse: pmx-led-white-pulse {
++ marvell,pins = "mpp14";
++ marvell,function = "gpio";
++ };
++ pmx_btn_wps: pmx-btn-wps {
++ marvell,pins = "mpp47";
++ marvell,function = "gpio";
++ };
++ pmx_btn_reset: pmx-btn-reset {
++ marvell,pins = "mpp48";
++ marvell,function = "gpio";
++ };
++ };
++
++ rtc@10300 {
++ status = "disabled";
++ };
++
++ serial@12000 {
++ status = "okay";
++ };
++
++ };
++
++ gpio_keys {
++ compatible = "gpio-keys";
++ #address-cells = <1>;
++ #size-cells = <0>;
++ pinctrl-0 = < &pmx_btn_wps &pmx_btn_reset >;
++ pinctrl-names = "default";
++
++ button@15 {
++ label = "WPS Button";
++ linux,code = <KEY_WPS_BUTTON>;
++ gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
++ };
++
++ button@16 {
++ label = "Reset Button";
++ linux,code = <KEY_RESTART>;
++ gpios = <&gpio1 16 GPIO_ACTIVE_LOW>;
++ };
++ };
++
++ gpio-leds {
++ compatible = "gpio-leds";
++ pinctrl-0 = < &pmx_led_white_health &pmx_led_white_pulse >;
++ pinctrl-names = "default";
++
++ white-health {
++ label = "ea4500:white:health";
++ gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
++ };
++
++ white-pulse {
++ label = "ea4500:white:pulse";
++ gpios = <&gpio0 14 GPIO_ACTIVE_HIGH>;
++ };
++ };
++
++ mvsw61xx {
++ compatible = "marvell,88e6171";
++ status = "okay";
++ reg = <0x10>;
++
++ mii-bus = <&mdio>;
++ cpu-port-0 = <5>;
++ cpu-port-1 = <6>;
++ is-indirect;
++ };
++};
++
++&nand {
++ status = "okay";
++ pinctrl-0 = <&pmx_nand>;
++ pinctrl-names = "default";
++
++ partition@0 {
++ label = "u-boot";
++ reg = <0x0000000 0x80000>;
++ };
++
++ partition@80000 {
++ label = "u-boot environment";
++ reg = <0x80000 0x20000>;
++ };
++
++ partition@200000 {
++ label = "kernel";
++ reg = <0x200000 0x200000>;
++ };
++
++ partition@400000 {
++ label = "root";
++ reg = <0x400000 0x1c00000>;
++ };
++};
++
++&mdio {
++ status = "okay";
++};
++
++&eth0 {
++ status = "okay";
++ ethernet0-port@0 {
++ speed = <1000>;
++ duplex = <1>;
++ };
++};
++
++&eth1 {
++ status = "okay";
++ ethernet1-port@0 {
++ speed = <1000>;
++ duplex = <1>;
++ };
++};
diff --git a/target/linux/kirkwood/patches-3.18/170-ea3500.patch b/target/linux/kirkwood/patches-3.18/170-ea3500.patch
new file mode 100644
index 0000000..84645de
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.18/170-ea3500.patch
@@ -0,0 +1,173 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -120,6 +120,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += kirkwood-
+ kirkwood-ds411.dtb \
+ kirkwood-ds411j.dtb \
+ kirkwood-ds411slim.dtb \
++ kirkwood-ea3500.dtb \
+ kirkwood-ea4500.dtb \
+ kirkwood-goflexnet.dtb \
+ kirkwood-guruplug-server-plus.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/kirkwood-ea3500.dts
+@@ -0,0 +1,160 @@
++/*
++ * kirkwood-ea3500.dts - Device Tree file for Linksys EA3500
++ *
++ * (c) 2013 Jonas Gorski <jogo@openwrt.org>
++ * (c) 2013 Deutsche Telekom Innovation Laboratories
++ * (c) 2014 Luka Perkov <luka@openwrt.org>
++ * (c) 2014 Dan Walters <dan@walters.io>
++ *
++ * This file is licensed under the terms of the GNU General Public
++ * License version 2. This program is licensed "as is" without any
++ * warranty of any kind, whether express or implied.
++ */
++
++/dts-v1/;
++
++#include "kirkwood.dtsi"
++#include "kirkwood-6282.dtsi"
++
++/ {
++ model = "Linksys EA3500";
++ compatible = "linksys,ea3500", "marvell,kirkwood-88f6282", "marvell,kirkwood";
++
++ memory {
++ device_type = "memory";
++ reg = <0x00000000 0x4000000>;
++ };
++
++ chosen {
++ bootargs = "console=ttyS0,115200n8 earlyprintk";
++ };
++
++ mbus {
++ pcie-controller {
++ status = "okay";
++
++ pcie@1,0 {
++ status = "okay";
++ };
++
++ pcie@2,0 {
++ status = "okay";
++ };
++ };
++ };
++
++ ocp@f1000000 {
++ pinctrl: pin-controller@10000 {
++ pmx_led_green_power: pmx-led-green-power {
++ marvell,pins = "mpp7";
++ marvell,function = "gpo";
++ };
++ pmx_btn_wps: pmx-btn-wps {
++ marvell,pins = "mpp47";
++ marvell,function = "gpio";
++ };
++ pmx_btn_reset: pmx-btn-reset {
++ marvell,pins = "mpp48";
++ marvell,function = "gpio";
++ };
++ };
++
++ rtc@10300 {
++ status = "disabled";
++ };
++
++ serial@12000 {
++ status = "okay";
++ };
++
++ };
++
++ gpio_keys {
++ compatible = "gpio-keys";
++ #address-cells = <1>;
++ #size-cells = <0>;
++ pinctrl-0 = < &pmx_btn_wps &pmx_btn_reset >;
++ pinctrl-names = "default";
++
++ button@15 {
++ label = "WPS Button";
++ linux,code = <KEY_WPS_BUTTON>;
++ gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
++ };
++
++ button@16 {
++ label = "Reset Button";
++ linux,code = <KEY_RESTART>;
++ gpios = <&gpio1 16 GPIO_ACTIVE_LOW>;
++ };
++ };
++
++ gpio-leds {
++ compatible = "gpio-leds";
++ pinctrl-0 = < &pmx_led_green_power >;
++ pinctrl-names = "default";
++
++ green-power {
++ label = "ea3500:green:power";
++ gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
++ };
++ };
++
++ mvsw61xx {
++ compatible = "marvell,88e6171";
++ status = "okay";
++ reg = <0x10>;
++
++ mii-bus = <&mdio>;
++ cpu-port-0 = <5>;
++ cpu-port-1 = <6>;
++ is-indirect;
++ };
++};
++
++&nand {
++ status = "okay";
++ pinctrl-0 = <&pmx_nand>;
++ pinctrl-names = "default";
++
++ partition@0 {
++ label = "u-boot";
++ reg = <0x0000000 0x80000>;
++ read-only;
++ };
++
++ partition@80000 {
++ label = "u-boot environment";
++ reg = <0x80000 0x20000>;
++ };
++
++ partition@200000 {
++ label = "kernel";
++ reg = <0x200000 0x200000>;
++ };
++
++ partition@400000 {
++ label = "root";
++ reg = <0x400000 0x1200000>;
++ };
++};
++
++&mdio {
++ status = "okay";
++};
++
++&eth0 {
++ status = "okay";
++ ethernet0-port@0 {
++ speed = <1000>;
++ duplex = <1>;
++ };
++};
++
++&eth1 {
++ status = "okay";
++ ethernet1-port@0 {
++ speed = <1000>;
++ duplex = <1>;
++ };
++};
diff --git a/target/linux/kirkwood/patches-3.18/180-goflexhome.patch b/target/linux/kirkwood/patches-3.18/180-goflexhome.patch
new file mode 100644
index 0000000..e54c853
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.18/180-goflexhome.patch
@@ -0,0 +1,140 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -122,6 +122,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += kirkwood-
+ kirkwood-ds411slim.dtb \
+ kirkwood-ea3500.dtb \
+ kirkwood-ea4500.dtb \
++ kirkwood-goflexhome.dtb \
+ kirkwood-goflexnet.dtb \
+ kirkwood-guruplug-server-plus.dtb \
+ kirkwood-ib62x0.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/kirkwood-goflexhome.dts
+@@ -0,0 +1,127 @@
++/dts-v1/;
++
++#include "kirkwood.dtsi"
++#include "kirkwood-6281.dtsi"
++
++/ {
++ model = "Seagate GoFlex Home";
++ compatible = "seagate,goflexhome", "marvell,kirkwood-88f6281", "marvell,kirkwood";
++
++ memory {
++ device_type = "memory";
++ reg = <0x00000000 0x8000000>;
++ };
++
++ chosen {
++ bootargs = "console=ttyS0,115200n8 earlyprintk root=/dev/sda1 rootdelay=10";
++ stdout-path = &uart0;
++ };
++
++ ocp@f1000000 {
++ pinctrl: pin-controller@10000 {
++ pmx_usb_power_enable: pmx-usb-power-enable {
++ marvell,pins = "mpp29";
++ marvell,function = "gpio";
++ };
++ pmx_led_white: pmx-led-white {
++ marvell,pins = "mpp40";
++ marvell,function = "gpio";
++ };
++ pmx_led_green: pmx-led_green {
++ marvell,pins = "mpp46";
++ marvell,function = "gpio";
++ };
++ pmx_led_orange: pmx-led-orange {
++ marvell,pins = "mpp47";
++ marvell,function = "gpio";
++ };
++ };
++ serial@12000 {
++ status = "ok";
++ };
++
++ sata@80000 {
++ status = "okay";
++ nr-ports = <2>;
++ };
++
++ };
++ gpio-leds {
++ compatible = "gpio-leds";
++
++ health {
++ label = "status:green:health";
++ gpios = <&gpio1 14 1>;
++ linux,default-trigger = "default-on";
++ };
++ fault {
++ label = "status:orange:fault";
++ gpios = <&gpio1 15 1>;
++ };
++ misc {
++ label = "status:white:misc";
++ gpios = <&gpio1 8 1>;
++ linux,default-trigger = "ide-disk";
++ };
++ };
++ regulators {
++ compatible = "simple-bus";
++ #address-cells = <1>;
++ #size-cells = <0>;
++ pinctrl-0 = <&pmx_usb_power_enable>;
++ pinctrl-names = "default";
++
++ usb_power: regulator@1 {
++ compatible = "regulator-fixed";
++ reg = <1>;
++ regulator-name = "USB Power";
++ regulator-min-microvolt = <5000000>;
++ regulator-max-microvolt = <5000000>;
++ enable-active-high;
++ regulator-always-on;
++ regulator-boot-on;
++ gpio = <&gpio0 29 GPIO_ACTIVE_HIGH>;
++ };
++ };
++};
++
++&nand {
++ chip-delay = <40>;
++ status = "okay";
++
++ partition@0 {
++ label = "u-boot";
++ reg = <0x0000000 0x100000>;
++ read-only;
++ };
++
++ partition@100000 {
++ label = "uImage";
++ reg = <0x0100000 0x400000>;
++ };
++
++ partition@500000 {
++ label = "pogoplug";
++ reg = <0x0500000 0x2000000>;
++ };
++
++ partition@2500000 {
++ label = "root";
++ reg = <0x02500000 0xd800000>;
++ };
++};
++
++&mdio {
++ status = "okay";
++
++ ethphy0: ethernet-phy@0 {
++ reg = <0>;
++ };
++};
++
++&eth0 {
++ status = "okay";
++ ethernet0-port@0 {
++ phy-handle = <&ethphy0>;
++ };
++};
diff --git a/target/linux/kirkwood/patches-3.18/190-nsa310s.patch b/target/linux/kirkwood/patches-3.18/190-nsa310s.patch
new file mode 100644
index 0000000..9766455
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.18/190-nsa310s.patch
@@ -0,0 +1,300 @@
+--- /dev/null
++++ b/arch/arm/boot/dts/kirkwood-nsa310s.dts
+@@ -0,0 +1,287 @@
++/dts-v1/;
++
++#include "kirkwood.dtsi"
++#include "kirkwood-6281.dtsi"
++
++/ {
++ model = "ZyXEL NSA310S";
++ compatible = "zyxel,nsa320s", "marvell,kirkwood-88f6702", "marvell,kirkwood";
++
++ memory {
++ device_type = "memory";
++ reg = <0x00000000 0x10000000>;
++ };
++
++ chosen {
++ bootargs = "console=ttyS0,115200n8 earlyprintk";
++ stdout-path = &uart0;
++ };
++
++ mbus {
++ pcie-controller {
++ status = "okay";
++
++ pcie@1,0 {
++ status = "okay";
++ };
++ };
++ };
++
++ ocp@f1000000 {
++ pinctrl: pin-controller@10000 {
++ pinctrl-names = "default";
++
++ pmx_sata0: pmx-sata0 {
++ marvell,pins;
++ marvell,function = "sata0";
++ };
++ pmx_sata1: pmx-sata1 {
++ marvell,pins;
++ marvell,function = "sata1";
++ };
++ pmx_usb_power: pmx-usb-power {
++ marvell,pins = "mpp21";
++ marvell,function = "gpio";
++ };
++ pmx_pwr_off: pmx-pwr-off {
++ marvell,pins = "mpp27";
++ marvell,function = "gpio";
++ };
++ pmx_btn_reset: pmx-btn-reset {
++ marvell,pins = "mpp24";
++ marvell,function = "gpio";
++ };
++ pmx_btn_copy: pmx-btn-copy {
++ marvell,pins = "mpp25";
++ marvell,function = "gpio";
++ };
++ pmx_btn_power: pmx-btn-power {
++ marvell,pins = "mpp26";
++ marvell,function = "gpio";
++ };
++ pmx_led_hdd2_green: pmx-led-hdd2-green {
++ marvell,pins = "mpp34";
++ marvell,function = "gpio";
++ };
++ pmx_led_hdd2_red: pmx-led-hdd2-red {
++ marvell,pins = "mpp12";
++ marvell,function = "gpio";
++ };
++ pmx_led_usb_green: pmx-led-usb-green {
++ marvell,pins = "mpp15";
++ marvell,function = "gpio";
++ };
++ pmx_led_copy_green: pmx-led-copy-green {
++ marvell,pins = "mpp22";
++ marvell,function = "gpio";
++ };
++ pmx_led_copy_red: pmx-led-copy-red {
++ marvell,pins = "mpp23";
++ marvell,function = "gpio";
++ };
++ pmx_led_sys_green: pmx-led-sys-green {
++ marvell,pins = "mpp28";
++ marvell,function = "gpio";
++ };
++ pmx_led_sys_orange: pmx-led-sys-orange {
++ marvell,pins = "mpp29";
++ marvell,function = "gpio";
++ };
++ pmx_led_hdd1_green: pmx-led-hdd1-green {
++ marvell,pins = "mpp16";
++ marvell,function = "gpio";
++ };
++ pmx_led_hdd1_red: pmx-led-hdd1-red {
++ marvell,pins = "mpp13";
++ marvell,function = "gpio";
++ };
++ pmx_pwr_sata1: pmx-pwr-sata1 {
++ marvell,pins = "mpp33";
++ marvell,function = "gpio";
++ };
++ };
++
++ serial@12000 {
++ status = "okay";
++ };
++
++ sata@80000 {
++ status = "okay";
++ nr-ports = <2>;
++ };
++
++ rtc@10300 {
++ status = "disabled";
++ };
++
++ i2c@11000 {
++ status = "okay";
++ ht1382: rtc@68 {
++ compatible = "htk,ht1382";
++ reg = <0x68>;
++ };
++ };
++ };
++
++ regulators {
++ compatible = "simple-bus";
++ #address-cells = <1>;
++ #size-cells = <0>;
++ pinctrl-names = "default";
++ pinctrl-0 = <&pmx_usb_power &pmx_pwr_sata1>;
++
++ usb0_power: regulator@1 {
++ compatible = "regulator-fixed";
++ reg = <1>;
++ regulator-name = "USB Power";
++ regulator-min-microvolt = <5000000>;
++ regulator-max-microvolt = <5000000>;
++ regulator-always-on;
++ regulator-boot-on;
++ enable-active-high;
++ gpio = <&gpio0 21 GPIO_ACTIVE_HIGH>;
++ };
++
++ sata1_power: regulator@2 {
++ compatible = "regulator-fixed";
++ reg = <2>;
++ regulator-name = "SATA1 Power";
++ regulator-min-microvolt = <5000000>;
++ regulator-max-microvolt = <5000000>;
++ regulator-always-on;
++ regulator-boot-on;
++ enable-active-high;
++ gpio = <&gpio1 1 GPIO_ACTIVE_HIGH>;
++ };
++ };
++
++
++ gpio_keys {
++ compatible = "gpio-keys";
++ #address-cells = <1>;
++ #size-cells = <0>;
++ pinctrl-0 = <&pmx_btn_reset &pmx_btn_copy &pmx_btn_power>;
++ pinctrl-names = "default";
++
++ button@1 {
++ label = "Power Button";
++ linux,code = <KEY_POWER>;
++ gpios = <&gpio0 26 GPIO_ACTIVE_HIGH>;
++ };
++ button@2 {
++ label = "Copy Button";
++ linux,code = <KEY_COPY>;
++ gpios = <&gpio0 25 GPIO_ACTIVE_LOW>;
++ };
++ button@3 {
++ label = "Reset Button";
++ linux,code = <KEY_RESTART>;
++ gpios = <&gpio0 24 GPIO_ACTIVE_LOW>;
++ };
++ };
++
++ gpio-leds {
++ compatible = "gpio-leds";
++ pinctrl-0 = <&pmx_led_hdd2_green &pmx_led_hdd2_red
++ &pmx_led_usb_green
++ &pmx_led_sys_green &pmx_led_sys_orange
++ &pmx_led_copy_green &pmx_led_copy_red
++ &pmx_led_hdd1_green &pmx_led_hdd1_red>;
++ pinctrl-names = "default";
++
++ green-sys {
++ label = "nsa310s:green:sys";
++ gpios = <&gpio0 28 GPIO_ACTIVE_HIGH>;
++ linux,default-trigger = "timer";
++ };
++ orange-sys {
++ label = "nsa310s:orange:sys";
++ gpios = <&gpio0 29 GPIO_ACTIVE_HIGH>;
++ };
++ green-hdd1 {
++ label = "nsa310s:green:hdd1";
++ gpios = <&gpio0 16 GPIO_ACTIVE_HIGH>;
++ };
++ red-hdd1 {
++ label = "nsa310s:red:hdd1";
++ gpios = <&gpio0 13 GPIO_ACTIVE_HIGH>;
++ };
++ green-hdd2 {
++ label = "nsa310s:green:hdd2";
++ gpios = <&gpio1 2 GPIO_ACTIVE_HIGH>;
++ };
++ red-hdd2 {
++ label = "nsa310s:red:hdd2";
++ gpios = <&gpio0 12 GPIO_ACTIVE_HIGH>;
++ };
++ green-usb {
++ label = "nsa310s:green:usb";
++ gpios = <&gpio0 15 GPIO_ACTIVE_HIGH>;
++ };
++ green-copy {
++ label = "nsa310s:green:copy";
++ gpios = <&gpio0 22 GPIO_ACTIVE_HIGH>;
++ linux,default-trigger = "ide-disk";
++ };
++ red-copy {
++ label = "nsa310s:red:copy";
++ gpios = <&gpio0 23 GPIO_ACTIVE_HIGH>;
++ };
++ };
++
++ gpio_poweroff {
++ compatible = "gpio-poweroff";
++ pinctrl-0 = <&pmx_pwr_off>;
++ pinctrl-names = "default";
++ gpios = <&gpio0 27 GPIO_ACTIVE_HIGH>;
++ };
++};
++
++&nand {
++ status = "okay";
++ chip-delay = <35>;
++
++ partition@0 {
++ label = "u-boot";
++ reg = <0x0000000 0xe0000>;
++ };
++
++ partition@e0000 {
++ label = "u-boot environment";
++ reg = <0xe0000 0x100000>;
++ };
++
++ partition@100000 {
++ label = "second stage u-boot";
++ reg = <0x100000 0x200000>;
++ };
++
++ partition@200000 {
++ label = "root";
++ reg = <0x200000 0xfe00000>;
++ };
++};
++
++&mdio {
++ status = "okay";
++ ethphy0: ethernet-phy@1 {
++ compatible = "marvell,88e1318s";
++ reg = <1>;
++ marvell,reg-init = <0x1 0x16 0x0 0x3>,
++ <0x1 0x10 0x0 0x1017>,
++ <0x1 0x11 0x0 0x4408>,
++ <0x1 0x16 0x0 0x0>,
++ <0x1 0x4 0x0 0x1e1>,
++ <0x1 0x9 0x0 0x300>,
++ <0x1 0x10 0x0 0x3860>,
++ <0x1 0x0 0x0 0x9140>;
++ };
++};
++
++&eth0 {
++ status = "okay";
++
++ ethernet0-port@0 {
++ phy-handle = <&ethphy0>;
++ };
++};
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -145,6 +145,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += kirkwood-
+ kirkwood-ns2mini.dtb \
+ kirkwood-nsa310.dtb \
+ kirkwood-nsa310a.dtb \
++ kirkwood-nsa310s.dtb \
+ kirkwood-openblocks_a6.dtb \
+ kirkwood-openblocks_a7.dtb \
+ kirkwood-openrd-base.dtb \
diff --git a/target/linux/kirkwood/patches-3.18/200-disable-tso.patch b/target/linux/kirkwood/patches-3.18/200-disable-tso.patch
new file mode 100644
index 0000000..4e8126e
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.18/200-disable-tso.patch
@@ -0,0 +1,35 @@
+From: Ezequiel Garcia <ezequiel.garcia@free-electrons.com>
+Subject: [PATCH] net: mv643xx_eth: Make TSO disabled by default
+
+Data corruption has been observed to be produced by TSO. For instance,
+accessing files on a NFS-server with TSO enabled results in different data
+transferred each time.
+
+This has been observed only on Kirkwood platforms, i.e. with the mv643xx_eth
+driver. Same tests on platforms using the mvneta ethernet driver have
+passed without errors.
+
+Make TSO disabled by default for now, until we can found a proper fix
+for the regression.
+
+Fixes: 3ae8f4e0b98 ('net: mv643xx_eth: Implement software TSO')
+Reported-by: Slawomir Gajzner <slawomir.gajzner <at> gmail.com>
+Reported-by: Julien D'Ascenzio <jdascenzio <at> yahoo.fr>
+Signed-off-by: Ezequiel Garcia <ezequiel.garcia <at> free-electrons.com>
+---
+--- a/drivers/net/ethernet/marvell/mv643xx_eth.c
++++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
+@@ -3112,11 +3112,11 @@ static int mv643xx_eth_probe(struct plat
+ dev->watchdog_timeo = 2 * HZ;
+ dev->base_addr = 0;
+
+- dev->features = NETIF_F_SG | NETIF_F_IP_CSUM | NETIF_F_TSO;
++ dev->features = NETIF_F_SG | NETIF_F_IP_CSUM;
+ dev->vlan_features = dev->features;
+
+ dev->features |= NETIF_F_RXCSUM;
+- dev->hw_features = dev->features;
++ dev->hw_features = dev->features | NETIF_F_TSO;
+
+ dev->priv_flags |= IFF_UNICAST_FLT;
+ dev->gso_max_segs = MV643XX_MAX_TSO_SEGS;