aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/llvm/patches/.svn
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /toolchain/llvm/patches/.svn
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'toolchain/llvm/patches/.svn')
-rw-r--r--toolchain/llvm/patches/.svn/entries96
-rw-r--r--toolchain/llvm/patches/.svn/text-base/100-darwin_arch_auto.patch.svn-base19
-rw-r--r--toolchain/llvm/patches/.svn/text-base/110-darwin_version_detect.patch.svn-base16
3 files changed, 131 insertions, 0 deletions
diff --git a/toolchain/llvm/patches/.svn/entries b/toolchain/llvm/patches/.svn/entries
new file mode 100644
index 0000000..4ccd796
--- /dev/null
+++ b/toolchain/llvm/patches/.svn/entries
@@ -0,0 +1,96 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/toolchain/llvm/patches
+svn://svn.openwrt.org/openwrt
+
+
+
+2009-10-10T19:25:48.592604Z
+18019
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+100-darwin_arch_auto.patch
+file
+
+
+
+
+2013-03-17T12:13:24.000000Z
+444671fca7a670d1a5b32bdf5afacdbe
+2009-10-10T19:25:48.592604Z
+18019
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+409
+
+110-darwin_version_detect.patch
+file
+
+
+
+
+2013-03-17T12:13:24.000000Z
+9b7b65ca905b56aedb3bae972dd6aeca
+2009-10-10T19:25:48.592604Z
+18019
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+619
+
diff --git a/toolchain/llvm/patches/.svn/text-base/100-darwin_arch_auto.patch.svn-base b/toolchain/llvm/patches/.svn/text-base/100-darwin_arch_auto.patch.svn-base
new file mode 100644
index 0000000..a48e131
--- /dev/null
+++ b/toolchain/llvm/patches/.svn/text-base/100-darwin_arch_auto.patch.svn-base
@@ -0,0 +1,19 @@
+--- a/Makefile.rules
++++ b/Makefile.rules
+@@ -618,16 +618,6 @@ ifdef UNIVERSAL
+
+ # Building universal cannot compute dependencies automatically.
+ DISABLE_AUTO_DEPENDENCIES=1
+-else
+- ifeq ($(TARGET_OS),Darwin)
+- ifeq ($(ARCH),x86_64)
+- TargetCommonOpts = -m64
+- else
+- ifeq ($(ARCH),x86)
+- TargetCommonOpts = -m32
+- endif
+- endif
+- endif
+ endif
+
+ ifeq ($(HOST_OS),SunOS)
diff --git a/toolchain/llvm/patches/.svn/text-base/110-darwin_version_detect.patch.svn-base b/toolchain/llvm/patches/.svn/text-base/110-darwin_version_detect.patch.svn-base
new file mode 100644
index 0000000..7fd62f9
--- /dev/null
+++ b/toolchain/llvm/patches/.svn/text-base/110-darwin_version_detect.patch.svn-base
@@ -0,0 +1,16 @@
+--- a/Makefile.rules
++++ b/Makefile.rules
+@@ -506,11 +506,13 @@ endif
+ #--------------------------------------------------------------------
+
+ ifeq ($(HOST_OS),Darwin)
++ ifndef DARWIN_VERSION
+ DARWIN_VERSION := `sw_vers -productVersion`
+ # Strip a number like 10.4.7 to 10.4
+ DARWIN_VERSION := $(shell echo $(DARWIN_VERSION)| sed -E 's/(10.[0-9]).*/\1/')
+ # Get "4" out of 10.4 for later pieces in the makefile.
+ DARWIN_MAJVERS := $(shell echo $(DARWIN_VERSION)| sed -E 's/10.([0-9]).*/\1/')
++ endif
+
+ SharedLinkOptions=-Wl,-flat_namespace -Wl,-undefined -Wl,suppress \
+ -dynamiclib