aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/llvm/patches/.svn/text-base/110-darwin_version_detect.patch.svn-base
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/llvm/patches/.svn/text-base/110-darwin_version_detect.patch.svn-base')
-rw-r--r--toolchain/llvm/patches/.svn/text-base/110-darwin_version_detect.patch.svn-base16
1 files changed, 16 insertions, 0 deletions
diff --git a/toolchain/llvm/patches/.svn/text-base/110-darwin_version_detect.patch.svn-base b/toolchain/llvm/patches/.svn/text-base/110-darwin_version_detect.patch.svn-base
new file mode 100644
index 0000000..7fd62f9
--- /dev/null
+++ b/toolchain/llvm/patches/.svn/text-base/110-darwin_version_detect.patch.svn-base
@@ -0,0 +1,16 @@
+--- a/Makefile.rules
++++ b/Makefile.rules
+@@ -506,11 +506,13 @@ endif
+ #--------------------------------------------------------------------
+
+ ifeq ($(HOST_OS),Darwin)
++ ifndef DARWIN_VERSION
+ DARWIN_VERSION := `sw_vers -productVersion`
+ # Strip a number like 10.4.7 to 10.4
+ DARWIN_VERSION := $(shell echo $(DARWIN_VERSION)| sed -E 's/(10.[0-9]).*/\1/')
+ # Get "4" out of 10.4 for later pieces in the makefile.
+ DARWIN_MAJVERS := $(shell echo $(DARWIN_VERSION)| sed -E 's/10.([0-9]).*/\1/')
++ endif
+
+ SharedLinkOptions=-Wl,-flat_namespace -Wl,-undefined -Wl,suppress \
+ -dynamiclib