aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/eglibc/headers
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /toolchain/eglibc/headers
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'toolchain/eglibc/headers')
-rw-r--r--toolchain/eglibc/headers/.svn/entries62
-rw-r--r--toolchain/eglibc/headers/.svn/text-base/Makefile.svn-base26
-rw-r--r--toolchain/eglibc/headers/Makefile26
3 files changed, 114 insertions, 0 deletions
diff --git a/toolchain/eglibc/headers/.svn/entries b/toolchain/eglibc/headers/.svn/entries
new file mode 100644
index 0000000..a136d56
--- /dev/null
+++ b/toolchain/eglibc/headers/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/toolchain/eglibc/headers
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-07-03T14:23:32.719514Z
+32584
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+f91f160dbe6ebeb1eaf7bace09890518
+2012-07-03T14:23:32.719514Z
+32584
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+639
+
diff --git a/toolchain/eglibc/headers/.svn/text-base/Makefile.svn-base b/toolchain/eglibc/headers/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..69495c9
--- /dev/null
+++ b/toolchain/eglibc/headers/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,26 @@
+PATH_PREFIX:=..
+VARIANT:=headers
+
+include ../common.mk
+
+define Host/Compile
+
+endef
+
+define Host/Install
+ $(call Host/SetToolchainInfo)
+ mkdir -p $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/{include,lib}
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ install_root="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev" \
+ install-bootstrap-headers=yes \
+ install-headers
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ csu/subdir_lib
+ ( cd $(CUR_BUILD_DIR); \
+ $(CP) csu/crt1.o csu/crti.o csu/crtn.o $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/lib/ \
+ )
+ $(TARGET_CC) -nostdlib -nostartfiles -shared -x c /dev/null \
+ -o $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/lib/libc.so
+endef
+
+$(eval $(call HostBuild))
diff --git a/toolchain/eglibc/headers/Makefile b/toolchain/eglibc/headers/Makefile
new file mode 100644
index 0000000..69495c9
--- /dev/null
+++ b/toolchain/eglibc/headers/Makefile
@@ -0,0 +1,26 @@
+PATH_PREFIX:=..
+VARIANT:=headers
+
+include ../common.mk
+
+define Host/Compile
+
+endef
+
+define Host/Install
+ $(call Host/SetToolchainInfo)
+ mkdir -p $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/{include,lib}
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ install_root="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev" \
+ install-bootstrap-headers=yes \
+ install-headers
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ csu/subdir_lib
+ ( cd $(CUR_BUILD_DIR); \
+ $(CP) csu/crt1.o csu/crti.o csu/crtn.o $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/lib/ \
+ )
+ $(TARGET_CC) -nostdlib -nostartfiles -shared -x c /dev/null \
+ -o $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/lib/libc.so
+endef
+
+$(eval $(call HostBuild))