aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/eglibc/headers/.svn/text-base/Makefile.svn-base
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/eglibc/headers/.svn/text-base/Makefile.svn-base')
-rw-r--r--toolchain/eglibc/headers/.svn/text-base/Makefile.svn-base26
1 files changed, 26 insertions, 0 deletions
diff --git a/toolchain/eglibc/headers/.svn/text-base/Makefile.svn-base b/toolchain/eglibc/headers/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..69495c9
--- /dev/null
+++ b/toolchain/eglibc/headers/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,26 @@
+PATH_PREFIX:=..
+VARIANT:=headers
+
+include ../common.mk
+
+define Host/Compile
+
+endef
+
+define Host/Install
+ $(call Host/SetToolchainInfo)
+ mkdir -p $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/{include,lib}
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ install_root="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev" \
+ install-bootstrap-headers=yes \
+ install-headers
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ csu/subdir_lib
+ ( cd $(CUR_BUILD_DIR); \
+ $(CP) csu/crt1.o csu/crti.o csu/crtn.o $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/lib/ \
+ )
+ $(TARGET_CC) -nostdlib -nostartfiles -shared -x c /dev/null \
+ -o $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/lib/libc.so
+endef
+
+$(eval $(call HostBuild))