aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mxs/profiles/01-duckbill.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mxs/profiles/01-duckbill.mk')
-rw-r--r--target/linux/mxs/profiles/01-duckbill.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/mxs/profiles/01-duckbill.mk b/target/linux/mxs/profiles/01-duckbill.mk
new file mode 100644
index 0000000..85a1237
--- /dev/null
+++ b/target/linux/mxs/profiles/01-duckbill.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/duckbill
+ NAME:=I2SE Duckbill boards
+ DEPENDS:=+@TARGET_ROOTFS_INCLUDE_KERNEL +@TARGET_ROOTFS_INCLUDE_DTB
+ FEATURES+=usbgadget
+ PACKAGES+= \
+ -dnsmasq -firewall -ppp -ip6tables -iptables -6relayd -mtd uboot-envtools \
+ kmod-leds-gpio kmod-ledtrig-timer kmod-usb-mxs-phy -kmod-ipt-nathelper \
+ kmod-i2c-mxs kmod-spi-mxs uboot-mxs-duckbill
+endef
+
+define Profile/duckbill/Description
+ I2SE's Duckbill devices
+endef
+
+$(eval $(call Profile,duckbill))