aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mxs/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mxs/profiles')
-rw-r--r--target/linux/mxs/profiles/01-duckbill.mk22
-rw-r--r--target/linux/mxs/profiles/02-olinuxino-maxi.mk21
-rw-r--r--target/linux/mxs/profiles/03-olinuxino-micro.mk21
3 files changed, 64 insertions, 0 deletions
diff --git a/target/linux/mxs/profiles/01-duckbill.mk b/target/linux/mxs/profiles/01-duckbill.mk
new file mode 100644
index 0000000..85a1237
--- /dev/null
+++ b/target/linux/mxs/profiles/01-duckbill.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/duckbill
+ NAME:=I2SE Duckbill boards
+ DEPENDS:=+@TARGET_ROOTFS_INCLUDE_KERNEL +@TARGET_ROOTFS_INCLUDE_DTB
+ FEATURES+=usbgadget
+ PACKAGES+= \
+ -dnsmasq -firewall -ppp -ip6tables -iptables -6relayd -mtd uboot-envtools \
+ kmod-leds-gpio kmod-ledtrig-timer kmod-usb-mxs-phy -kmod-ipt-nathelper \
+ kmod-i2c-mxs kmod-spi-mxs uboot-mxs-duckbill
+endef
+
+define Profile/duckbill/Description
+ I2SE's Duckbill devices
+endef
+
+$(eval $(call Profile,duckbill))
diff --git a/target/linux/mxs/profiles/02-olinuxino-maxi.mk b/target/linux/mxs/profiles/02-olinuxino-maxi.mk
new file mode 100644
index 0000000..7885d1f
--- /dev/null
+++ b/target/linux/mxs/profiles/02-olinuxino-maxi.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/olinuxino-maxi
+ NAME:=Olimex OLinuXino Maxi/Mini boards
+ PACKAGES += imx-bootlets uboot-mxs-mx23_olinuxino \
+ kmod-usb-mxs-phy kmod-usb-net kmod-usb-net-smsc95xx \
+ kmod-gpio-mcp23s08 kmod-leds-gpio kmod-ledtrig-heartbeat kmod-rtc-stmp3xxx \
+ kmod-sound-core kmod-sound-soc-mxs kmod-iio-mxs-lradc kmod-crypto-hw-dcp \
+ kmod-i2c-mxs kmod-spi-mxs
+endef
+
+define Profile/olinuxino-maxi/Description
+ Olimex OLinuXino Maxi/Mini boards
+endef
+
+$(eval $(call Profile,olinuxino-maxi))
diff --git a/target/linux/mxs/profiles/03-olinuxino-micro.mk b/target/linux/mxs/profiles/03-olinuxino-micro.mk
new file mode 100644
index 0000000..356a877
--- /dev/null
+++ b/target/linux/mxs/profiles/03-olinuxino-micro.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/olinuxino-micro
+ NAME:=Olimex OLinuXino Micro/Nano boards
+ PACKAGES += imx-bootlets uboot-mxs-mx23_olinuxino \
+ kmod-usb-mxs-phy kmod-gpio-mcp23s08 kmod-leds-gpio \
+ kmod-ledtrig-heartbeat kmod-rtc-stmp3xxx \
+ kmod-iio-mxs-lradc kmod-crypto-hw-dcp \
+ kmod-i2c-mxs kmod-spi-mxs
+endef
+
+define Profile/olinuxino-micro/Description
+ Olimex OLinuXino Micro/Nano boards
+endef
+
+$(eval $(call Profile,olinuxino-micro))