aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ixp4xx/modules.mk')
-rw-r--r--target/linux/ixp4xx/modules.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/modules.mk b/target/linux/ixp4xx/modules.mk
index e088497793..8bf6e693b7 100644
--- a/target/linux/ixp4xx/modules.mk
+++ b/target/linux/ixp4xx/modules.mk
@@ -39,3 +39,20 @@ define KernelPackage/ixp4xx-beeper/description
endef
$(eval $(call KernelPackage,ixp4xx-beeper))
+
+
+define KernelPackage/crypto-hw-ixp4xx
+ TITLE:=Intel IXP4xx hardware crypto module
+ DEPENDS:=@TARGET_ixp4xx
+ KCONFIG:= \
+ CONFIG_CRYPTO_DEV_IXP4XX
+ FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.ko
+ AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
+ $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
+endef
+
+define KernelPackage/crypto-hw-ixp4xx/description
+ Kernel support for the Intel IXP4xx HW crypto engine.
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ixp4xx))