aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/modules.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:16 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:16 +0000
commitd13f533d5fe138fc118ce4c2eae4b78f1993d110 (patch)
tree888062506bc5b7d5806262fa25077897de87faba /target/linux/ixp4xx/modules.mk
parent16ffb690a4488df02a767579b18b0a79e808fb7b (diff)
downloadmaster-187ad058-d13f533d5fe138fc118ce4c2eae4b78f1993d110.tar.gz
master-187ad058-d13f533d5fe138fc118ce4c2eae4b78f1993d110.tar.bz2
master-187ad058-d13f533d5fe138fc118ce4c2eae4b78f1993d110.zip
[ixp4xx] move crypto module to target specific modules.mk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32856 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx/modules.mk')
-rw-r--r--target/linux/ixp4xx/modules.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/modules.mk b/target/linux/ixp4xx/modules.mk
index e088497793..8bf6e693b7 100644
--- a/target/linux/ixp4xx/modules.mk
+++ b/target/linux/ixp4xx/modules.mk
@@ -39,3 +39,20 @@ define KernelPackage/ixp4xx-beeper/description
endef
$(eval $(call KernelPackage,ixp4xx-beeper))
+
+
+define KernelPackage/crypto-hw-ixp4xx
+ TITLE:=Intel IXP4xx hardware crypto module
+ DEPENDS:=@TARGET_ixp4xx
+ KCONFIG:= \
+ CONFIG_CRYPTO_DEV_IXP4XX
+ FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.ko
+ AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
+ $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
+endef
+
+define KernelPackage/crypto-hw-ixp4xx/description
+ Kernel support for the Intel IXP4xx HW crypto engine.
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ixp4xx))