aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/etrax/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/etrax/Makefile')
-rw-r--r--target/linux/etrax/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/target/linux/etrax/Makefile b/target/linux/etrax/Makefile
index 7c9b76fa65..c837550062 100644
--- a/target/linux/etrax/Makefile
+++ b/target/linux/etrax/Makefile
@@ -12,7 +12,10 @@ BOARDNAME:=Foxboard (ETRAX 100LX)
FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.19.2
-include $(INCLUDE_DIR)/kernel-build.mk
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="zImage"
+DEFAULT_PACKAGES += foxboard-utils
define Target/Description
Build fimware images for the FOXBOARD made by acmesystems.it
@@ -31,14 +34,10 @@ define Kernel/Prepare
$(call Kernel/Prepare/Fox)
endef
-DEFAULT_PACKAGES += foxboard-utils
+#include the profiles
+-include profiles/*.mk
+$(eval $(call BuildTarget))
$(eval $(call RequireCommand,/usr/local/cris/gcc-cris, \
Please install the binary cris toolchain. \
))
-
-#include the profiles
--include profiles/*.mk
-
-KERNELNAME:="zImage"
-$(eval $(call BuildKernel))