aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/etrax/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
commit6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e (patch)
tree30cacdb892969714d2a079f391ba6786b7c36489 /target/linux/etrax/Makefile
parent9647361f814667b536160d416666bd25ab4b82fa (diff)
downloadmaster-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.tar.gz
master-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.tar.bz2
master-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.zip
major target cleanup. it is now possible to have subtargets that can override many target settings, including arch - merge adm5120, adm5120eb. target profiles still need to be adapted for subtargets
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8694 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/etrax/Makefile')
-rw-r--r--target/linux/etrax/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/target/linux/etrax/Makefile b/target/linux/etrax/Makefile
index 7c9b76fa65..c837550062 100644
--- a/target/linux/etrax/Makefile
+++ b/target/linux/etrax/Makefile
@@ -12,7 +12,10 @@ BOARDNAME:=Foxboard (ETRAX 100LX)
FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.19.2
-include $(INCLUDE_DIR)/kernel-build.mk
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="zImage"
+DEFAULT_PACKAGES += foxboard-utils
define Target/Description
Build fimware images for the FOXBOARD made by acmesystems.it
@@ -31,14 +34,10 @@ define Kernel/Prepare
$(call Kernel/Prepare/Fox)
endef
-DEFAULT_PACKAGES += foxboard-utils
+#include the profiles
+-include profiles/*.mk
+$(eval $(call BuildTarget))
$(eval $(call RequireCommand,/usr/local/cris/gcc-cris, \
Please install the binary cris toolchain. \
))
-
-#include the profiles
--include profiles/*.mk
-
-KERNELNAME:="zImage"
-$(eval $(call BuildKernel))