aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/alfa.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/alfa.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/alfa.mk23
1 files changed, 18 insertions, 5 deletions
diff --git a/target/linux/ar71xx/generic/profiles/alfa.mk b/target/linux/ar71xx/generic/profiles/alfa.mk
index 06baf240c2..97c843ace1 100644
--- a/target/linux/ar71xx/generic/profiles/alfa.mk
+++ b/target/linux/ar71xx/generic/profiles/alfa.mk
@@ -1,12 +1,12 @@
#
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
define Profile/ALFAAP96
- NAME:=ALFA Network AP96 board
+ NAME:=ALFA Network AP96 board
PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-rtc-pcf2123
endef
@@ -18,17 +18,31 @@ $(eval $(call Profile,ALFAAP96))
define Profile/HORNETUB
- NAME:=ALFA Network Hornet-UB board
+ NAME:=ALFA Network Hornet-UB board (8MB flash, 32MB ram)
PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
endef
define Profile/HORNETUB/Description
- Package set optimized for the ALFA Network Hornet-UB board.
+ Package set optimized for the ALFA Network Hornet-UB board with 8MB
+ flash and 32MB ram.
endef
$(eval $(call Profile,HORNETUB))
+define Profile/HORNETUBx2
+ NAME:=ALFA Network Hornet-UB-x2 board (16MB flash, 64MB ram)
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/HORNETUBx2/Description
+ Package set optimized for the ALFA Network Hornet-UB board with 16MB
+ flash and 64MB ram.
+endef
+
+$(eval $(call Profile,HORNETUBx2))
+
+
define Profile/ALFANX
NAME:=ALFA Network N2/N5 board
PACKAGES:=
@@ -39,4 +53,3 @@ define Profile/ALFANX/Description
endef
$(eval $(call Profile,ALFANX))
-