aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/alfa.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-08-15 00:57:47 +0000
committerLuka Perkov <luka@openwrt.org>2013-08-15 00:57:47 +0000
commit9a00f5936206f493bfd3ae9df44ccf2941018aa3 (patch)
tree2e8c2b482d60ebaadcc475894a3c393147ad6fe8 /target/linux/ar71xx/generic/profiles/alfa.mk
parente57b180a0144641969016eb266ea1d17239da976 (diff)
downloadmaster-187ad058-9a00f5936206f493bfd3ae9df44ccf2941018aa3.tar.gz
master-187ad058-9a00f5936206f493bfd3ae9df44ccf2941018aa3.tar.bz2
master-187ad058-9a00f5936206f493bfd3ae9df44ccf2941018aa3.zip
ar71xx: add support for hornet-ub-x2
The hornet-ub-x2 is hornet-ub variant with double more flash and ram. Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37788 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/alfa.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/alfa.mk23
1 files changed, 18 insertions, 5 deletions
diff --git a/target/linux/ar71xx/generic/profiles/alfa.mk b/target/linux/ar71xx/generic/profiles/alfa.mk
index 06baf240c2..97c843ace1 100644
--- a/target/linux/ar71xx/generic/profiles/alfa.mk
+++ b/target/linux/ar71xx/generic/profiles/alfa.mk
@@ -1,12 +1,12 @@
#
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
define Profile/ALFAAP96
- NAME:=ALFA Network AP96 board
+ NAME:=ALFA Network AP96 board
PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-rtc-pcf2123
endef
@@ -18,17 +18,31 @@ $(eval $(call Profile,ALFAAP96))
define Profile/HORNETUB
- NAME:=ALFA Network Hornet-UB board
+ NAME:=ALFA Network Hornet-UB board (8MB flash, 32MB ram)
PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
endef
define Profile/HORNETUB/Description
- Package set optimized for the ALFA Network Hornet-UB board.
+ Package set optimized for the ALFA Network Hornet-UB board with 8MB
+ flash and 32MB ram.
endef
$(eval $(call Profile,HORNETUB))
+define Profile/HORNETUBx2
+ NAME:=ALFA Network Hornet-UB-x2 board (16MB flash, 64MB ram)
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/HORNETUBx2/Description
+ Package set optimized for the ALFA Network Hornet-UB board with 16MB
+ flash and 64MB ram.
+endef
+
+$(eval $(call Profile,HORNETUBx2))
+
+
define Profile/ALFANX
NAME:=ALFA Network N2/N5 board
PACKAGES:=
@@ -39,4 +53,3 @@ define Profile/ALFANX/Description
endef
$(eval $(call Profile,ALFANX))
-