aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1a218df586..04a07ddbf6 100644
--- a/Makefile
+++ b/Makefile
@@ -74,7 +74,9 @@ world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install pac
.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install
package_index:
- $(STAGING_DIR)/usr/bin/ipkg-make-index $(PACKAGE_DIR) > $(PACKAGE_DIR)/Packages
+ (cd $(PACKAGE_DIR); \
+ $(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages \
+ )
target_prepare:
$(MAKE) -C target prepare