aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-03-07 16:25:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-03-07 16:25:40 +0000
commitfffa7d392369093d279c2353b1056dfccbca2a07 (patch)
tree3d4833d4063fe3a71c28cddf6c38fa6e13554354 /Makefile
parent3c366e287b855d1c5db56efbc56f3b86295d967a (diff)
downloadmaster-187ad058-fffa7d392369093d279c2353b1056dfccbca2a07.tar.gz
master-187ad058-fffa7d392369093d279c2353b1056dfccbca2a07.tar.bz2
master-187ad058-fffa7d392369093d279c2353b1056dfccbca2a07.zip
fix package_index
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@339 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1a218df586..04a07ddbf6 100644
--- a/Makefile
+++ b/Makefile
@@ -74,7 +74,9 @@ world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install pac
.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install
package_index:
- $(STAGING_DIR)/usr/bin/ipkg-make-index $(PACKAGE_DIR) > $(PACKAGE_DIR)/Packages
+ (cd $(PACKAGE_DIR); \
+ $(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages \
+ )
target_prepare:
$(MAKE) -C target prepare