aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/eglibc/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-03-12 19:50:57 +0000
committerJohn Crispin <blogic@openwrt.org>2015-03-12 19:50:57 +0000
commitd5f527f3cee5cec5744d2a6f3ccd2cdae7adaca8 (patch)
tree5236aa6a2ac180eacc86c1739a57f41619119077 /toolchain/eglibc/Makefile
parenta00f7e5cb5fbb3dd1486a3623d2b3428a6b07a79 (diff)
downloadmaster-187ad058-d5f527f3cee5cec5744d2a6f3ccd2cdae7adaca8.tar.gz
master-187ad058-d5f527f3cee5cec5744d2a6f3ccd2cdae7adaca8.tar.bz2
master-187ad058-d5f527f3cee5cec5744d2a6f3ccd2cdae7adaca8.zip
toolchain: The glorious return of glibc, ver 2.21
It's the eglibc packaging with a bit of spit-polishing. And testing. :-) [blogic: merged glibc and eglibc into 1 and made eglibc a glibc variant] Signed-off-by: Jeff Waugh <jdub@bethesignal.org> Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44701 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/eglibc/Makefile')
-rw-r--r--toolchain/eglibc/Makefile31
1 files changed, 0 insertions, 31 deletions
diff --git a/toolchain/eglibc/Makefile b/toolchain/eglibc/Makefile
deleted file mode 100644
index f880db81ed..0000000000
--- a/toolchain/eglibc/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-PATH_PREFIX := .
-VARIANT:=final
-HOST_BUILD_PARALLEL:=0
-
-include ./common.mk
-
-define Host/Compile
- $(MAKE) -C $(CUR_BUILD_DIR) \
- PARALLELMFLAGS="$(HOST_JOBS)" \
- BUILD_CFLAGS="$(HOST_CFLAGS)" \
- all
-endef
-
-define Host/Install
- $(call Host/SetToolchainInfo)
- $(MAKE) -C $(CUR_BUILD_DIR) \
- BUILD_CFLAGS="$(HOST_CFLAGS)" \
- install_root="$(TOOLCHAIN_DIR)" \
- install
- ( cd $(TOOLCHAIN_DIR) ; \
- for d in lib usr/lib ; do \
- for f in libc.so libpthread.so libgcc_s.so ; do \
- if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
- $(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
- fi \
- done \
- done \
- )
-endef
-
-$(eval $(call HostBuild))