aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2016-07-25 13:32:53 +0200
committerGitHub <noreply@github.com>2016-07-25 13:32:53 +0200
commit558b38f4b8e615fb5262c94dad7db2071e394ac1 (patch)
treeb0e903fc8e8000a0159988310ced3a27da8e88b5 /target
parent99ddb65eac90bd20ab08f76190bbfcc5d4676ae2 (diff)
parent019be77f6b24cf372e8ebc77d28e51cf550ff064 (diff)
downloadmaster-187ad058-558b38f4b8e615fb5262c94dad7db2071e394ac1.tar.gz
master-187ad058-558b38f4b8e615fb5262c94dad7db2071e394ac1.tar.bz2
master-187ad058-558b38f4b8e615fb5262c94dad7db2071e394ac1.zip
Merge pull request #38 from qinfengling/orangepi2
sunxi: add support for Orange Pi 2 (H3)
Diffstat (limited to 'target')
-rw-r--r--target/linux/sunxi/image/Makefile4
-rw-r--r--target/linux/sunxi/patches-4.4/210-dt-sun8i-add-orangepi-2.patch302
-rw-r--r--target/linux/sunxi/profiles/orangepi_2.mk18
3 files changed, 324 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index bda690e39c..0525e08ed9 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -111,6 +111,10 @@ define Image/Build/Profile/orangepi_plus
$(call Image/Build/SDCard,$(1),sun8i-h3-orangepi-plus)
endef
+define Image/Build/Profile/orangepi_2
+ $(call Image/Build/SDCard,$(1),sun8i-h3-orangepi-2)
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
$(call Image/Build/Profile/$(PROFILE),$(1))
diff --git a/target/linux/sunxi/patches-4.4/210-dt-sun8i-add-orangepi-2.patch b/target/linux/sunxi/patches-4.4/210-dt-sun8i-add-orangepi-2.patch
new file mode 100644
index 0000000000..5f40cec3d4
--- /dev/null
+++ b/target/linux/sunxi/patches-4.4/210-dt-sun8i-add-orangepi-2.patch
@@ -0,0 +1,302 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -662,6 +662,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \
+ sun8i-a33-ippo-q8h-v1.2.dtb \
+ sun8i-a33-q8-tablet.dtb \
+ sun8i-a33-sinlinx-sina33.dtb \
++ sun8i-h3-orangepi-2.dtb \
+ sun8i-h3-orangepi-plus.dtb
+ dtb-$(CONFIG_MACH_SUN9I) += \
+ sun9i-a80-optimus.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/sun8i-h3-orangepi-2.dts
+@@ -0,0 +1,186 @@
++/*
++ * Copyright (C) 2016 Hans de Goede <hdegoede@redhat.com>
++ *
++ * This file is dual-licensed: you can use it either under the terms
++ * of the GPL or the X11 license, at your option. Note that this dual
++ * licensing only applies to this file, and not this project as a
++ * whole.
++ *
++ * a) This file is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU General Public License as
++ * published by the Free Software Foundation; either version 2 of the
++ * License, or (at your option) any later version.
++ *
++ * This file is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ * GNU General Public License for more details.
++ *
++ * Or, alternatively,
++ *
++ * b) Permission is hereby granted, free of charge, to any person
++ * obtaining a copy of this software and associated documentation
++ * files (the "Software"), to deal in the Software without
++ * restriction, including without limitation the rights to use,
++ * copy, modify, merge, publish, distribute, sublicense, and/or
++ * sell copies of the Software, and to permit persons to whom the
++ * Software is furnished to do so, subject to the following
++ * conditions:
++ *
++ * The above copyright notice and this permission notice shall be
++ * included in all copies or substantial portions of the Software.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ * OTHER DEALINGS IN THE SOFTWARE.
++ */
++
++/dts-v1/;
++#include "sun8i-h3.dtsi"
++#include "sunxi-common-regulators.dtsi"
++
++#include <dt-bindings/gpio/gpio.h>
++#include <dt-bindings/input/input.h>
++#include <dt-bindings/pinctrl/sun4i-a10.h>
++
++/ {
++ model = "Xunlong Orange Pi 2";
++ compatible = "xunlong,orangepi-2", "allwinner,sun8i-h3";
++
++ aliases {
++ serial0 = &uart0;
++ };
++
++ chosen {
++ stdout-path = "serial0:115200n8";
++ };
++
++ leds {
++ compatible = "gpio-leds";
++ pinctrl-names = "default";
++ pinctrl-0 = <&leds_opc>, <&leds_r_opc>;
++
++ status_led {
++ label = "orangepi:red:status";
++ gpios = <&pio 0 15 GPIO_ACTIVE_HIGH>;
++ };
++
++ pwr_led {
++ label = "orangepi:green:pwr";
++ gpios = <&r_pio 0 10 GPIO_ACTIVE_HIGH>;
++ default-state = "on";
++ };
++ };
++
++ r_gpio_keys {
++ compatible = "gpio-keys";
++ pinctrl-names = "default";
++ pinctrl-0 = <&sw_r_opc>;
++
++ sw2 {
++ label = "sw2";
++ linux,code = <BTN_1>;
++ gpios = <&r_pio 0 4 GPIO_ACTIVE_LOW>;
++ };
++
++ sw4 {
++ label = "sw4";
++ linux,code = <BTN_0>;
++ gpios = <&r_pio 0 3 GPIO_ACTIVE_LOW>;
++ };
++ };
++
++ wifi_pwrseq: wifi_pwrseq {
++ compatible = "mmc-pwrseq-simple";
++ pinctrl-names = "default";
++ pinctrl-0 = <&wifi_pwrseq_pin_orangepi>;
++ reset-gpios = <&r_pio 0 7 GPIO_ACTIVE_LOW>; /* PL7 WIFI_EN */
++ };
++};
++
++&ehci1 {
++ status = "okay";
++};
++
++&ir {
++ pinctrl-names = "default";
++ pinctrl-0 = <&ir_pins_a>;
++ status = "okay";
++};
++
++&mmc0 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&mmc0_pins_a>, <&mmc0_cd_pin>;
++ vmmc-supply = <&reg_vcc3v3>;
++ bus-width = <4>;
++ cd-gpios = <&pio 5 6 GPIO_ACTIVE_HIGH>; /* PF6 */
++ cd-inverted;
++ status = "okay";
++};
++
++&mmc1 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&mmc1_pins_a>;
++ vmmc-supply = <&reg_vcc3v3>;
++ mmc-pwrseq = <&wifi_pwrseq>;
++ bus-width = <4>;
++ non-removable;
++ status = "okay";
++};
++
++&pio {
++ leds_opc: led_pins@0 {
++ allwinner,pins = "PA15";
++ allwinner,function = "gpio_out";
++ allwinner,drive = <SUN4I_PINCTRL_10_MA>;
++ allwinner,pull = <SUN4I_PINCTRL_NO_PULL>;
++ };
++};
++
++&r_pio {
++ leds_r_opc: led_pins@0 {
++ allwinner,pins = "PL10";
++ allwinner,function = "gpio_out";
++ allwinner,drive = <SUN4I_PINCTRL_10_MA>;
++ allwinner,pull = <SUN4I_PINCTRL_NO_PULL>;
++ };
++
++ sw_r_opc: key_pins@0 {
++ allwinner,pins = "PL3", "PL4";
++ allwinner,function = "gpio_in";
++ allwinner,drive = <SUN4I_PINCTRL_10_MA>;
++ allwinner,pull = <SUN4I_PINCTRL_NO_PULL>;
++ };
++
++ wifi_pwrseq_pin_orangepi: wifi_pwrseq_pin@0 {
++ allwinner,pins = "PL7";
++ allwinner,function = "gpio_out";
++ allwinner,drive = <SUN4I_PINCTRL_10_MA>;
++ allwinner,pull = <SUN4I_PINCTRL_NO_PULL>;
++ };
++};
++
++&reg_usb1_vbus {
++ gpio = <&pio 6 13 GPIO_ACTIVE_HIGH>;
++ status = "okay";
++};
++
++&uart0 {
++ pinctrl-names = "default";
++ pinctrl-0 = <&uart0_pins_a>;
++ status = "okay";
++};
++
++&usb1_vbus_pin_a {
++ allwinner,pins = "PG13";
++};
++
++&usbphy {
++ usb1_vbus-supply = <&reg_usb1_vbus>;
++ status = "okay";
++};
+--- a/arch/arm/boot/dts/sun8i-h3.dtsi
++++ b/arch/arm/boot/dts/sun8i-h3.dtsi
+@@ -288,6 +288,33 @@
+ clocks = <&osc24M>, <&pll6 1>, <&pll5>;
+ clock-output-names = "mbus";
+ };
++
++ apb0: apb0_clk {
++ compatible = "fixed-factor-clock";
++ #clock-cells = <0>;
++ clock-div = <1>;
++ clock-mult = <1>;
++ clocks = <&osc24M>;
++ clock-output-names = "apb0";
++ };
++
++ apb0_gates: clk@01f01428 {
++ compatible = "allwinner,sun8i-h3-apb0-gates-clk",
++ "allwinner,sun4i-a10-gates-clk";
++ reg = <0x01f01428 0x4>;
++ #clock-cells = <1>;
++ clocks = <&apb0>;
++ clock-indices = <0>, <1>;
++ clock-output-names = "apb0_pio", "apb0_ir";
++ };
++
++ ir_clk: ir_clk@01f01454 {
++ compatible = "allwinner,sun4i-a10-mod0-clk";
++ reg = <0x01f01454 0x4>;
++ #clock-cells = <0>;
++ clocks = <&osc32k>, <&osc24M>;
++ clock-output-names = "ir";
++ };
+ };
+
+ soc {
+@@ -472,7 +499,7 @@
+ gpio-controller;
+ #gpio-cells = <3>;
+ interrupt-controller;
+- #interrupt-cells = <2>;
++ #interrupt-cells = <3>;
+
+ uart0_pins_a: uart0@0 {
+ allwinner,pins = "PA4", "PA5";
+@@ -503,6 +530,16 @@
+ allwinner,drive = <SUN4I_PINCTRL_30_MA>;
+ allwinner,pull = <SUN4I_PINCTRL_NO_PULL>;
+ };
++
++ mmc2_8bit_pins: mmc2_8bit {
++ allwinner,pins = "PC5", "PC6", "PC8",
++ "PC9", "PC10", "PC11",
++ "PC12", "PC13", "PC14",
++ "PC15", "PC16";
++ allwinner,function = "mmc2";
++ allwinner,drive = <SUN4I_PINCTRL_30_MA>;
++ allwinner,pull = <SUN4I_PINCTRL_NO_PULL>;
++ };
+ };
+
+ ahb_rst: reset@01c202c0 {
+@@ -606,5 +643,40 @@
+ interrupts = <GIC_SPI 40 IRQ_TYPE_LEVEL_HIGH>,
+ <GIC_SPI 41 IRQ_TYPE_LEVEL_HIGH>;
+ };
++
++ apb0_reset: reset@01f014b0 {
++ reg = <0x01f014b0 0x4>;
++ compatible = "allwinner,sun6i-a31-clock-reset";
++ #reset-cells = <1>;
++ };
++
++ ir: ir@01f02000 {
++ compatible = "allwinner,sun5i-a13-ir";
++ clocks = <&apb0_gates 1>, <&ir_clk>;
++ clock-names = "apb", "ir";
++ resets = <&apb0_reset 1>;
++ interrupts = <GIC_SPI 37 IRQ_TYPE_LEVEL_HIGH>;
++ reg = <0x01f02000 0x40>;
++ status = "disabled";
++ };
++
++ r_pio: pinctrl@01f02c00 {
++ compatible = "allwinner,sun8i-h3-r-pinctrl";
++ reg = <0x01f02c00 0x400>;
++ interrupts = <GIC_SPI 45 IRQ_TYPE_LEVEL_HIGH>;
++ clocks = <&apb0_gates 0>;
++ resets = <&apb0_reset 0>;
++ gpio-controller;
++ #gpio-cells = <3>;
++ interrupt-controller;
++ #interrupt-cells = <3>;
++
++ ir_pins_a: ir@0 {
++ allwinner,pins = "PL11";
++ allwinner,function = "s_cir_rx";
++ allwinner,drive = <SUN4I_PINCTRL_10_MA>;
++ allwinner,pull = <SUN4I_PINCTRL_NO_PULL>;
++ };
++ };
+ };
+ };
diff --git a/target/linux/sunxi/profiles/orangepi_2.mk b/target/linux/sunxi/profiles/orangepi_2.mk
new file mode 100644
index 0000000000..a398921879
--- /dev/null
+++ b/target/linux/sunxi/profiles/orangepi_2.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/orangepi_2
+ NAME:=orangepi_2
+ PACKAGES:=\
+ kmod-rtc-sunxi uboot-sunxi-orangepi_2
+endef
+
+define Profile/orangepi_2/Description
+ Package set optimized for the OrangePi 2 (H3)
+endef
+
+$(eval $(call Profile,orangepi_2))