aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2015-08-15 15:10:14 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2015-08-15 15:10:14 +0000
commitee811ead95415d4849e139a455eab5604ca37068 (patch)
tree6ed40d4950e951faa2f3aeb699cb6a99618e3ed5 /target/linux/sunxi
parent96966f9dc92f3437e83b7b5be694a840b0882e5e (diff)
downloadmaster-187ad058-ee811ead95415d4849e139a455eab5604ca37068.tar.gz
master-187ad058-ee811ead95415d4849e139a455eab5604ca37068.tar.bz2
master-187ad058-ee811ead95415d4849e139a455eab5604ca37068.zip
sunxi: respect CONFIG_TARGET_IMAGES_GZIP
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46608 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 10d2200aa3..5a5c98a7c0 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -45,6 +45,10 @@ define Image/Build/SDCard
$(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE) \
$(KDIR)/uboot-sunxi-$(PROFILE)-u-boot-with-spl.bin
+
+ ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+ gzip -f9n $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-sdcard-vfat-$(1).img
+ endif
endef
define Image/Build/Profile/A10-OLinuXino-Lime