aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2015-08-15 14:56:21 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2015-08-15 14:56:21 +0000
commit96966f9dc92f3437e83b7b5be694a840b0882e5e (patch)
tree87ec39f159db958c9c2f976adc8bad4faaef4685 /target/linux/sunxi
parent85723b80e9d4278537fde5509f9a865ffe09b50b (diff)
downloadmaster-187ad058-96966f9dc92f3437e83b7b5be694a840b0882e5e.tar.gz
master-187ad058-96966f9dc92f3437e83b7b5be694a840b0882e5e.tar.bz2
master-187ad058-96966f9dc92f3437e83b7b5be694a840b0882e5e.zip
sunxi: create KDIR_TMP, build boot.img in it
It's nice to have a distinction between files which are built during the normal OpenWrt build process and ones that are created by the ImageBuilder (like it already exists on some other targets). This also gives boot.img a profile-specific prefix as it contains profile- specific data. KDIR_TMP does not need to be specified since include/image.mk already sets it. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46607 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/image/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 19ab935f3b..10d2200aa3 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -12,6 +12,8 @@ FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_SUNXI_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
define Image/BuildKernel
+ -mkdir -p $(KDIR_TMP)
+
mkimage -A arm -O linux -T kernel -C none \
-a 0x40008000 -e 0x40008000 \
-n 'ARM OpenWrt Linux-$(LINUX_VERSION)' \
@@ -29,16 +31,16 @@ define Image/BuildKernel
endef
define Image/Build/SDCard
- rm -f $(KDIR)/boot.img
- mkdosfs $(KDIR)/boot.img -C $(FAT32_BLOCKS)
+ rm -f $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img
+ mkdosfs $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img -C $(FAT32_BLOCKS)
- mcopy -i $(KDIR)/boot.img $(KDIR)/uboot-sunxi-$(PROFILE)-boot.scr ::boot.scr
- mcopy -i $(KDIR)/boot.img $(DTS_DIR)/$(2).dtb ::dtb
- mcopy -i $(KDIR)/boot.img $(BIN_DIR)/$(IMG_PREFIX)-uImage ::uImage
+ mcopy -i $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img $(KDIR)/uboot-sunxi-$(PROFILE)-boot.scr ::boot.scr
+ mcopy -i $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img $(DTS_DIR)/$(2).dtb ::dtb
+ mcopy -i $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img $(BIN_DIR)/$(IMG_PREFIX)-uImage ::uImage
./gen_sunxi_sdcard_img.sh \
$(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-sdcard-vfat-$(1).img \
- $(KDIR)/boot.img \
+ $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img \
$(KDIR)/root.$(1) \
$(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE) \