aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-04 20:18:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-04 20:18:35 +0000
commit244425cb5092aa78d49cfba551c7cd270381e49d (patch)
tree9126b19704d974dbbae0a674e831dd4701999a29 /target/linux/rules.mk
parent0c21f02b558f55dac155435b85e292e4a015efe2 (diff)
downloadmaster-187ad058-244425cb5092aa78d49cfba551c7cd270381e49d.tar.gz
master-187ad058-244425cb5092aa78d49cfba551c7cd270381e49d.tar.bz2
master-187ad058-244425cb5092aa78d49cfba551c7cd270381e49d.zip
change kernel package name to kernel-VERSION-BOARD to work around ipkg bug
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1340 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rules.mk')
-rw-r--r--target/linux/rules.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/rules.mk b/target/linux/rules.mk
index 9446c343fa..75a96b4e65 100644
--- a/target/linux/rules.mk
+++ b/target/linux/rules.mk
@@ -6,9 +6,9 @@ KDEPEND_$(1):=$($(4))
endif
ifeq ($$(strip $(5)),)
-IDEPEND_$(1):=kernel ($(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE))
+IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE))
else
-IDEPEND_$(1):=kernel ($(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)), $(5)
+IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE)), $(5)
endif
PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)_$(ARCH).ipk