aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.1/350-oxnas-reset.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-17 06:03:57 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-17 06:03:57 +0000
commit46d4c7a7d0d49edaf79b8f92e9c1b54405e56157 (patch)
tree54c265fd011c147f0febcb7c86c0163df9747ec2 /target/linux/oxnas/patches-4.1/350-oxnas-reset.patch
parentd3ea787445646907237906a5c33c49fed6a95a68 (diff)
downloadmaster-187ad058-46d4c7a7d0d49edaf79b8f92e9c1b54405e56157.tar.gz
master-187ad058-46d4c7a7d0d49edaf79b8f92e9c1b54405e56157.tar.bz2
master-187ad058-46d4c7a7d0d49edaf79b8f92e9c1b54405e56157.zip
oxnas: prepare for kernel 4.1
Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46636 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/oxnas/patches-4.1/350-oxnas-reset.patch')
-rw-r--r--target/linux/oxnas/patches-4.1/350-oxnas-reset.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.1/350-oxnas-reset.patch b/target/linux/oxnas/patches-4.1/350-oxnas-reset.patch
new file mode 100644
index 0000000000..1cecd28dc7
--- /dev/null
+++ b/target/linux/oxnas/patches-4.1/350-oxnas-reset.patch
@@ -0,0 +1,20 @@
+--- a/drivers/reset/Kconfig
++++ b/drivers/reset/Kconfig
+@@ -12,4 +12,9 @@ menuconfig RESET_CONTROLLER
+
+ If unsure, say no.
+
++config RESET_CONTROLLER_OXNAS
++ bool
++ select RESET_CONTROLLER
++
+ source "drivers/reset/sti/Kconfig"
++
+--- a/drivers/reset/Makefile
++++ b/drivers/reset/Makefile
+@@ -1,4 +1,5 @@
+ obj-$(CONFIG_RESET_CONTROLLER) += core.o
++obj-$(CONFIG_RESET_CONTROLLER_OXNAS) += reset-ox820.o
+ obj-$(CONFIG_ARCH_SOCFPGA) += reset-socfpga.o
+ obj-$(CONFIG_ARCH_BERLIN) += reset-berlin.o
+ obj-$(CONFIG_ARCH_SUNXI) += reset-sunxi.o