aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-11-26 09:00:08 +0000
committerJohn Crispin <blogic@openwrt.org>2014-11-26 09:00:08 +0000
commit7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9 (patch)
tree24af078d708bfb6b3027ff4064114d439e4213e1 /target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch
parent2088d1ea438e14be13e9d579ebf847f9cc50245d (diff)
downloadmaster-187ad058-7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9.tar.gz
master-187ad058-7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9.tar.bz2
master-187ad058-7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9.zip
add new target 'oxnas'
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43388 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch')
-rw-r--r--target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch b/target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch
new file mode 100644
index 0000000000..0959e53648
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch
@@ -0,0 +1,29 @@
+Index: linux-3.18-rc4/drivers/clocksource/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/drivers/clocksource/Kconfig
++++ linux-3.18-rc4/drivers/clocksource/Kconfig
+@@ -156,6 +156,12 @@ config VF_PIT_TIMER
+ help
+ Support for Period Interrupt Timer on Freescale Vybrid Family SoCs.
+
++config CLKSRC_RPS_TIMER
++ def_bool y if ARCH_OXNAS
++ select CLKSRC_MMIO
++ help
++ This option enables support for the oxnas rps timers.
++
+ config SYS_SUPPORTS_SH_CMT
+ bool
+
+Index: linux-3.18-rc4/drivers/clocksource/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/clocksource/Makefile
++++ linux-3.18-rc4/drivers/clocksource/Makefile
+@@ -36,6 +36,7 @@ obj-$(CONFIG_CLKSRC_EFM32) += time-efm32
+ obj-$(CONFIG_CLKSRC_EXYNOS_MCT) += exynos_mct.o
+ obj-$(CONFIG_CLKSRC_SAMSUNG_PWM) += samsung_pwm_timer.o
+ obj-$(CONFIG_FSL_FTM_TIMER) += fsl_ftm_timer.o
++obj-$(CONFIG_CLKSRC_RPS_TIMER) += oxnas_rps_timer.o
+ obj-$(CONFIG_VF_PIT_TIMER) += vf_pit_timer.o
+ obj-$(CONFIG_CLKSRC_QCOM) += qcom-timer.o
+ obj-$(CONFIG_MTK_TIMER) += mtk_timer.o