aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.18
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-11-26 09:00:08 +0000
committerJohn Crispin <blogic@openwrt.org>2014-11-26 09:00:08 +0000
commit7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9 (patch)
tree24af078d708bfb6b3027ff4064114d439e4213e1 /target/linux/oxnas/patches-3.18
parent2088d1ea438e14be13e9d579ebf847f9cc50245d (diff)
downloadmaster-187ad058-7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9.tar.gz
master-187ad058-7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9.tar.bz2
master-187ad058-7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9.zip
add new target 'oxnas'
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43388 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/oxnas/patches-3.18')
-rw-r--r--target/linux/oxnas/patches-3.18/010-arm_introduce-dma-fiq-irq-broadcast.patch62
-rw-r--r--target/linux/oxnas/patches-3.18/250-add-plxtech-vendor-prefix.patch12
-rw-r--r--target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch79
-rw-r--r--target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch29
-rw-r--r--target/linux/oxnas/patches-3.18/320-oxnas-irqchip.patch40
-rw-r--r--target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch32
-rw-r--r--target/linux/oxnas/patches-3.18/340-oxnas-pcie.patch26
-rw-r--r--target/linux/oxnas/patches-3.18/350-oxnas-reset.patch24
-rw-r--r--target/linux/oxnas/patches-3.18/400-oxnas-nand.patch28
-rw-r--r--target/linux/oxnas/patches-3.18/500-oxnas-sata.patch30
-rw-r--r--target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch30
-rw-r--r--target/linux/oxnas/patches-3.18/900-more-boards.patch16
12 files changed, 408 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.18/010-arm_introduce-dma-fiq-irq-broadcast.patch b/target/linux/oxnas/patches-3.18/010-arm_introduce-dma-fiq-irq-broadcast.patch
new file mode 100644
index 0000000000..fb7547f96b
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/010-arm_introduce-dma-fiq-irq-broadcast.patch
@@ -0,0 +1,62 @@
+Index: linux-3.18-rc4/arch/arm/include/asm/glue-cache.h
+===================================================================
+--- linux-3.18-rc4.orig/arch/arm/include/asm/glue-cache.h
++++ linux-3.18-rc4/arch/arm/include/asm/glue-cache.h
+@@ -156,11 +156,19 @@ static inline void nop_dma_unmap_area(co
+ #define __cpuc_flush_user_range __glue(_CACHE,_flush_user_cache_range)
+ #define __cpuc_coherent_kern_range __glue(_CACHE,_coherent_kern_range)
+ #define __cpuc_coherent_user_range __glue(_CACHE,_coherent_user_range)
++#ifndef CONFIG_DMA_CACHE_FIQ_BROADCAST
+ #define __cpuc_flush_dcache_area __glue(_CACHE,_flush_kern_dcache_area)
+
+ #define dmac_map_area __glue(_CACHE,_dma_map_area)
+ #define dmac_unmap_area __glue(_CACHE,_dma_unmap_area)
+ #define dmac_flush_range __glue(_CACHE,_dma_flush_range)
++#else
++#define __cpuc_flush_dcache_area __glue(fiq,_flush_kern_dcache_area)
++
++#define dmac_map_area __glue(fiq,_dma_map_area)
++#define dmac_unmap_area __glue(fiq,_dma_unmap_area)
++#define dmac_flush_range __glue(fiq,_dma_flush_range)
++#endif /* CONFIG_DMA_CACHE_FIQ_BROADCAST */
+ #endif
+
+ #endif
+Index: linux-3.18-rc4/arch/arm/mm/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/arch/arm/mm/Kconfig
++++ linux-3.18-rc4/arch/arm/mm/Kconfig
+@@ -843,6 +843,17 @@ config DMA_CACHE_RWFO
+ in hardware, other workarounds are needed (e.g. cache
+ maintenance broadcasting in software via FIQ).
+
++config DMA_CACHE_FIQ_BROADCAST
++ bool "Enable fiq broadcast DMA cache maintenance"
++ depends on CPU_V6K && SMP
++ select FIQ
++ help
++ The Snoop Control Unit on ARM11MPCore does not detect the
++ cache maintenance operations and the dma_{map,unmap}_area()
++ functions may leave stale cache entries on other CPUs. By
++ enabling this option, fiq broadcast in the ARMv6
++ DMA cache maintenance functions is performed.
++
+ config OUTER_CACHE
+ bool
+
+Index: linux-3.18-rc4/arch/arm/mm/flush.c
+===================================================================
+--- linux-3.18-rc4.orig/arch/arm/mm/flush.c
++++ linux-3.18-rc4/arch/arm/mm/flush.c
+@@ -314,7 +314,11 @@ void flush_dcache_page(struct page *page
+
+ mapping = page_mapping(page);
+
++#ifndef CONFIG_DMA_CACHE_FIQ_BROADCAST
+ if (!cache_ops_need_broadcast() &&
++#else
++ if (
++#endif
+ mapping && !page_mapped(page))
+ clear_bit(PG_dcache_clean, &page->flags);
+ else {
diff --git a/target/linux/oxnas/patches-3.18/250-add-plxtech-vendor-prefix.patch b/target/linux/oxnas/patches-3.18/250-add-plxtech-vendor-prefix.patch
new file mode 100644
index 0000000000..c495258d30
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/250-add-plxtech-vendor-prefix.patch
@@ -0,0 +1,12 @@
+Index: linux-3.18-rc4/Documentation/devicetree/bindings/vendor-prefixes.txt
+===================================================================
+--- linux-3.18-rc4.orig/Documentation/devicetree/bindings/vendor-prefixes.txt
++++ linux-3.18-rc4/Documentation/devicetree/bindings/vendor-prefixes.txt
+@@ -113,6 +113,7 @@ panasonic Panasonic Corporation
+ phytec PHYTEC Messtechnik GmbH
+ picochip Picochip Ltd
+ plathome Plat'Home Co., Ltd.
++plxtech PLX Technology, Inc.
+ pixcir PIXCIR MICROELECTRONICS Co., Ltd
+ powervr PowerVR (deprecated, use img)
+ qca Qualcomm Atheros, Inc.
diff --git a/target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch b/target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch
new file mode 100644
index 0000000000..17ec83b63f
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch
@@ -0,0 +1,79 @@
+Index: linux-3.18-rc4/arch/arm/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/arch/arm/Kconfig
++++ linux-3.18-rc4/arch/arm/Kconfig
+@@ -369,6 +369,17 @@ config ARCH_VERSATILE
+ help
+ This enables support for ARM Ltd Versatile board.
+
++config ARCH_OXNAS
++ bool "Oxford Semiconductor 815/820/825 NAS SoC"
++ select ARCH_REQUIRE_GPIOLIB
++ select CLKDEV_LOOKUP
++ select GENERIC_CLOCKEVENTS
++ select COMMON_CLK
++ select MIGHT_HAVE_PCI
++ select ARCH_HAS_RESET_CONTROLLER
++ help
++ This enables support for Oxsemi 815/820/825 NAS SoC
++
+ config ARCH_AT91
+ bool "Atmel AT91"
+ select ARCH_REQUIRE_GPIOLIB
+@@ -922,6 +933,8 @@ source "arch/arm/mach-omap2/Kconfig"
+
+ source "arch/arm/mach-orion5x/Kconfig"
+
++source "arch/arm/mach-oxnas/Kconfig"
++
+ source "arch/arm/mach-picoxcell/Kconfig"
+
+ source "arch/arm/mach-pxa/Kconfig"
+Index: linux-3.18-rc4/arch/arm/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/arch/arm/Makefile
++++ linux-3.18-rc4/arch/arm/Makefile
+@@ -187,6 +187,7 @@ machine-$(CONFIG_ARCH_NSPIRE) += nspire
+ machine-$(CONFIG_ARCH_OMAP1) += omap1
+ machine-$(CONFIG_ARCH_OMAP2PLUS) += omap2
+ machine-$(CONFIG_ARCH_ORION5X) += orion5x
++machine-$(CONFIG_ARCH_OXNAS) += oxnas
+ machine-$(CONFIG_ARCH_PICOXCELL) += picoxcell
+ machine-$(CONFIG_ARCH_PXA) += pxa
+ machine-$(CONFIG_ARCH_QCOM) += qcom
+Index: linux-3.18-rc4/arch/arm/boot/dts/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/arch/arm/boot/dts/Makefile
++++ linux-3.18-rc4/arch/arm/boot/dts/Makefile
+@@ -352,6 +352,7 @@ dtb-$(CONFIG_ARCH_ORION5X) += orion5x-la
+ orion5x-lacie-ethernet-disk-mini-v2.dtb \
+ orion5x-maxtor-shared-storage-2.dtb \
+ orion5x-rd88f5182-nas.dtb
++dtb-$(CONFIG_ARCH_OXNAS) += ox820-pogoplug-pro.dtb
+ dtb-$(CONFIG_ARCH_PRIMA2) += prima2-evb.dtb
+ dtb-$(CONFIG_ARCH_QCOM) += \
+ qcom-apq8064-cm-qs600.dtb \
+Index: linux-3.18-rc4/arch/arm/tools/mach-types
+===================================================================
+--- linux-3.18-rc4.orig/arch/arm/tools/mach-types
++++ linux-3.18-rc4/arch/arm/tools/mach-types
+@@ -228,6 +228,7 @@ edb9302a MACH_EDB9302A EDB9302A 1127
+ edb9307a MACH_EDB9307A EDB9307A 1128
+ omap_3430sdp MACH_OMAP_3430SDP OMAP_3430SDP 1138
+ vstms MACH_VSTMS VSTMS 1140
++ox820 MACH_OX820 OX820 1152
+ micro9m MACH_MICRO9M MICRO9M 1169
+ bug MACH_BUG BUG 1179
+ at91sam9263ek MACH_AT91SAM9263EK AT91SAM9263EK 1202
+Index: linux-3.18-rc4/drivers/clk/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/clk/Makefile
++++ linux-3.18-rc4/drivers/clk/Makefile
+@@ -29,6 +29,7 @@ obj-$(CONFIG_COMMON_CLK_MAX77802) += clk
+ obj-$(CONFIG_ARCH_MOXART) += clk-moxart.o
+ obj-$(CONFIG_ARCH_NOMADIK) += clk-nomadik.o
+ obj-$(CONFIG_ARCH_NSPIRE) += clk-nspire.o
++obj-$(CONFIG_ARCH_OXNAS) += clk-oxnas.o
+ obj-$(CONFIG_COMMON_CLK_PALMAS) += clk-palmas.o
+ obj-$(CONFIG_CLK_PPC_CORENET) += clk-ppc-corenet.o
+ obj-$(CONFIG_COMMON_CLK_RK808) += clk-rk808.o
diff --git a/target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch b/target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch
new file mode 100644
index 0000000000..0959e53648
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch
@@ -0,0 +1,29 @@
+Index: linux-3.18-rc4/drivers/clocksource/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/drivers/clocksource/Kconfig
++++ linux-3.18-rc4/drivers/clocksource/Kconfig
+@@ -156,6 +156,12 @@ config VF_PIT_TIMER
+ help
+ Support for Period Interrupt Timer on Freescale Vybrid Family SoCs.
+
++config CLKSRC_RPS_TIMER
++ def_bool y if ARCH_OXNAS
++ select CLKSRC_MMIO
++ help
++ This option enables support for the oxnas rps timers.
++
+ config SYS_SUPPORTS_SH_CMT
+ bool
+
+Index: linux-3.18-rc4/drivers/clocksource/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/clocksource/Makefile
++++ linux-3.18-rc4/drivers/clocksource/Makefile
+@@ -36,6 +36,7 @@ obj-$(CONFIG_CLKSRC_EFM32) += time-efm32
+ obj-$(CONFIG_CLKSRC_EXYNOS_MCT) += exynos_mct.o
+ obj-$(CONFIG_CLKSRC_SAMSUNG_PWM) += samsung_pwm_timer.o
+ obj-$(CONFIG_FSL_FTM_TIMER) += fsl_ftm_timer.o
++obj-$(CONFIG_CLKSRC_RPS_TIMER) += oxnas_rps_timer.o
+ obj-$(CONFIG_VF_PIT_TIMER) += vf_pit_timer.o
+ obj-$(CONFIG_CLKSRC_QCOM) += qcom-timer.o
+ obj-$(CONFIG_MTK_TIMER) += mtk_timer.o
diff --git a/target/linux/oxnas/patches-3.18/320-oxnas-irqchip.patch b/target/linux/oxnas/patches-3.18/320-oxnas-irqchip.patch
new file mode 100644
index 0000000000..e6262da78d
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/320-oxnas-irqchip.patch
@@ -0,0 +1,40 @@
+Index: linux-3.18-rc4/drivers/irqchip/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/drivers/irqchip/Kconfig
++++ linux-3.18-rc4/drivers/irqchip/Kconfig
+@@ -15,6 +15,11 @@ config ARM_GIC_V3
+ select IRQ_DOMAIN
+ select MULTI_IRQ_HANDLER
+
++config PLXTECH_RPS
++ def_bool y if ARHC_OXNAS
++ depends on ARCH_OXNAS
++ select IRQ_DOMAIN
++
+ config ARM_NVIC
+ bool
+ select IRQ_DOMAIN
+Index: linux-3.18-rc4/drivers/irqchip/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/irqchip/Makefile
++++ linux-3.18-rc4/drivers/irqchip/Makefile
+@@ -28,6 +28,7 @@ obj-$(CONFIG_IMGPDC_IRQ) += irq-imgpdc.
+ obj-$(CONFIG_SIRF_IRQ) += irq-sirfsoc.o
+ obj-$(CONFIG_RENESAS_INTC_IRQPIN) += irq-renesas-intc-irqpin.o
+ obj-$(CONFIG_RENESAS_IRQC) += irq-renesas-irqc.o
++obj-$(CONFIG_PLXTECH_RPS) += irq-rps.o
+ obj-$(CONFIG_VERSATILE_FPGA_IRQ) += irq-versatile-fpga.o
+ obj-$(CONFIG_ARCH_NSPIRE) += irq-zevio.o
+ obj-$(CONFIG_ARCH_VT8500) += irq-vt8500.o
+Index: linux-3.18-rc4/drivers/irqchip/irq-gic.c
+===================================================================
+--- linux-3.18-rc4.orig/drivers/irqchip/irq-gic.c
++++ linux-3.18-rc4/drivers/irqchip/irq-gic.c
+@@ -1044,6 +1044,7 @@ IRQCHIP_DECLARE(gic_400, "arm,gic-400",
+ IRQCHIP_DECLARE(cortex_a15_gic, "arm,cortex-a15-gic", gic_of_init);
+ IRQCHIP_DECLARE(cortex_a9_gic, "arm,cortex-a9-gic", gic_of_init);
+ IRQCHIP_DECLARE(cortex_a7_gic, "arm,cortex-a7-gic", gic_of_init);
++IRQCHIP_DECLARE(arm11_mpcore_gic, "arm,arm11mp-gic", gic_of_init);
+ IRQCHIP_DECLARE(msm_8660_qgic, "qcom,msm-8660-qgic", gic_of_init);
+ IRQCHIP_DECLARE(msm_qgic2, "qcom,msm-qgic2", gic_of_init);
+
diff --git a/target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch b/target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch
new file mode 100644
index 0000000000..3ecc6ebe77
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch
@@ -0,0 +1,32 @@
+Index: linux-3.18-rc4/drivers/pinctrl/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/drivers/pinctrl/Kconfig
++++ linux-3.18-rc4/drivers/pinctrl/Kconfig
+@@ -67,6 +67,15 @@ config PINCTRL_AT91
+ help
+ Say Y here to enable the at91 pinctrl driver
+
++config PINCTRL_OXNAS
++ bool "OXNAS pinctrl driver"
++ depends on OF
++ depends on ARCH_OXNAS
++ select PINMUX
++ select PINCONF
++ help
++ Say Y here to enable the oxnas pinctrl driver
++
+ config PINCTRL_BAYTRAIL
+ bool "Intel Baytrail GPIO pin control"
+ depends on GPIOLIB && ACPI && X86
+Index: linux-3.18-rc4/drivers/pinctrl/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/pinctrl/Makefile
++++ linux-3.18-rc4/drivers/pinctrl/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_PINCTRL_BCM2835) += pinctrl
+ obj-$(CONFIG_PINCTRL_BAYTRAIL) += pinctrl-baytrail.o
+ obj-$(CONFIG_PINCTRL_BCM281XX) += pinctrl-bcm281xx.o
+ obj-$(CONFIG_PINCTRL_FALCON) += pinctrl-falcon.o
++obj-$(CONFIG_PINCTRL_OXNAS) += pinctrl-oxnas.o
+ obj-$(CONFIG_PINCTRL_PALMAS) += pinctrl-palmas.o
+ obj-$(CONFIG_PINCTRL_ROCKCHIP) += pinctrl-rockchip.o
+ obj-$(CONFIG_PINCTRL_SINGLE) += pinctrl-single.o
diff --git a/target/linux/oxnas/patches-3.18/340-oxnas-pcie.patch b/target/linux/oxnas/patches-3.18/340-oxnas-pcie.patch
new file mode 100644
index 0000000000..6549db01a9
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/340-oxnas-pcie.patch
@@ -0,0 +1,26 @@
+Index: linux-3.18-rc4/drivers/pci/host/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/drivers/pci/host/Kconfig
++++ linux-3.18-rc4/drivers/pci/host/Kconfig
+@@ -91,4 +91,9 @@ config PCI_XGENE
+ There are 5 internal PCIe ports available. Each port is GEN3 capable
+ and have varied lanes from x1 to x8.
+
++config PCI_OXNAS
++ bool "PLX Oxnas PCIe controller"
++ depends on ARCH_OXNAS
++ select PCIEPORTBUS
++
+ endmenu
+Index: linux-3.18-rc4/drivers/pci/host/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/pci/host/Makefile
++++ linux-3.18-rc4/drivers/pci/host/Makefile
+@@ -3,6 +3,7 @@ obj-$(CONFIG_PCI_DRA7XX) += pci-dra7xx.o
+ obj-$(CONFIG_PCI_EXYNOS) += pci-exynos.o
+ obj-$(CONFIG_PCI_IMX6) += pci-imx6.o
+ obj-$(CONFIG_PCI_MVEBU) += pci-mvebu.o
++obj-$(CONFIG_PCI_OXNAS) += pcie-oxnas.o
+ obj-$(CONFIG_PCI_TEGRA) += pci-tegra.o
+ obj-$(CONFIG_PCI_RCAR_GEN2) += pci-rcar-gen2.o
+ obj-$(CONFIG_PCI_RCAR_GEN2_PCIE) += pcie-rcar.o
diff --git a/target/linux/oxnas/patches-3.18/350-oxnas-reset.patch b/target/linux/oxnas/patches-3.18/350-oxnas-reset.patch
new file mode 100644
index 0000000000..5540920414
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/350-oxnas-reset.patch
@@ -0,0 +1,24 @@
+Index: linux-3.18-rc4/drivers/reset/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/drivers/reset/Kconfig
++++ linux-3.18-rc4/drivers/reset/Kconfig
+@@ -12,4 +12,9 @@ menuconfig RESET_CONTROLLER
+
+ If unsure, say no.
+
++config RESET_CONTROLLER_OXNAS
++ bool
++ select RESET_CONTROLLER
++
+ source "drivers/reset/sti/Kconfig"
++
+Index: linux-3.18-rc4/drivers/reset/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/reset/Makefile
++++ linux-3.18-rc4/drivers/reset/Makefile
+@@ -1,4 +1,5 @@
+ obj-$(CONFIG_RESET_CONTROLLER) += core.o
++obj-$(CONFIG_RESET_CONTROLLER_OXNAS) += reset-ox820.o
+ obj-$(CONFIG_ARCH_SOCFPGA) += reset-socfpga.o
+ obj-$(CONFIG_ARCH_SUNXI) += reset-sunxi.o
+ obj-$(CONFIG_ARCH_STI) += sti/
diff --git a/target/linux/oxnas/patches-3.18/400-oxnas-nand.patch b/target/linux/oxnas/patches-3.18/400-oxnas-nand.patch
new file mode 100644
index 0000000000..90827e5b8a
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/400-oxnas-nand.patch
@@ -0,0 +1,28 @@
+Index: linux-3.18-rc4/drivers/mtd/nand/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/drivers/mtd/nand/Kconfig
++++ linux-3.18-rc4/drivers/mtd/nand/Kconfig
+@@ -516,4 +516,12 @@ config MTD_NAND_XWAY
+ Enables support for NAND Flash chips on Lantiq XWAY SoCs. NAND is attached
+ to the External Bus Unit (EBU).
+
++config MTD_NAND_OXNAS
++ tristate "Support for NAND on Plxtech NAS782X SoC"
++ depends on ARCH_OXNAS
++ select MTD_NAND_PLATFORM
++ help
++ Enables support for NAND Flash chips on Plxtech NAS782X SoCs. NAND is attached
++ to the STATIC Unit.
++
+ endif # MTD_NAND
+Index: linux-3.18-rc4/drivers/mtd/nand/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/mtd/nand/Makefile
++++ linux-3.18-rc4/drivers/mtd/nand/Makefile
+@@ -50,5 +50,6 @@ obj-$(CONFIG_MTD_NAND_JZ4740) += jz4740
+ obj-$(CONFIG_MTD_NAND_GPMI_NAND) += gpmi-nand/
+ obj-$(CONFIG_MTD_NAND_XWAY) += xway_nand.o
+ obj-$(CONFIG_MTD_NAND_BCM47XXNFLASH) += bcm47xxnflash/
++obj-$(CONFIG_MTD_NAND_OXNAS) += oxnas_nand.o
+
+ nand-objs := nand_base.o nand_bbt.o nand_timings.o
diff --git a/target/linux/oxnas/patches-3.18/500-oxnas-sata.patch b/target/linux/oxnas/patches-3.18/500-oxnas-sata.patch
new file mode 100644
index 0000000000..94b792b136
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/500-oxnas-sata.patch
@@ -0,0 +1,30 @@
+Index: linux-3.18-rc4/drivers/ata/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/drivers/ata/Kconfig
++++ linux-3.18-rc4/drivers/ata/Kconfig
+@@ -385,6 +385,13 @@ config SATA_VITESSE
+
+ If unsure, say N.
+
++config SATA_OXNAS
++ tristate "PLXTECH NAS782X SATA support"
++ help
++ This option enables support for Nas782x Serial ATA controller.
++
++ If unsure, say N.
++
+ comment "PATA SFF controllers with BMDMA"
+
+ config PATA_ALI
+Index: linux-3.18-rc4/drivers/ata/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/ata/Makefile
++++ linux-3.18-rc4/drivers/ata/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_SATA_SVW) += sata_svw.o
+ obj-$(CONFIG_SATA_ULI) += sata_uli.o
+ obj-$(CONFIG_SATA_VIA) += sata_via.o
+ obj-$(CONFIG_SATA_VITESSE) += sata_vsc.o
++obj-$(CONFIG_SATA_OXNAS) += sata_oxnas.o
+
+ # SFF PATA w/ BMDMA
+ obj-$(CONFIG_PATA_ALI) += pata_ali.o
diff --git a/target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch b/target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch
new file mode 100644
index 0000000000..f2221dda88
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch
@@ -0,0 +1,30 @@
+Index: linux-3.18-rc4/drivers/usb/host/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/drivers/usb/host/Kconfig
++++ linux-3.18-rc4/drivers/usb/host/Kconfig
+@@ -302,6 +302,13 @@ config USB_OCTEON_EHCI
+ USB 2.0 device support. All CN6XXX based chips with USB are
+ supported.
+
++config USB_EHCI_OXNAS
++ tristate "OXNAS EHCI Module"
++ depends on USB_EHCI_HCD && ARCH_OXNAS
++ select USB_EHCI_ROOT_HUB_TT
++ ---help---
++ Enable support for the OX820 SOC's on-chip EHCI controller.
++
+ endif # USB_EHCI_HCD
+
+ config USB_OXU210HP_HCD
+Index: linux-3.18-rc4/drivers/usb/host/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/usb/host/Makefile
++++ linux-3.18-rc4/drivers/usb/host/Makefile
+@@ -44,6 +44,7 @@ obj-$(CONFIG_USB_EHCI_HCD_AT91) += ehci-
+ obj-$(CONFIG_USB_EHCI_MSM) += ehci-msm.o
+ obj-$(CONFIG_USB_EHCI_TEGRA) += ehci-tegra.o
+ obj-$(CONFIG_USB_W90X900_EHCI) += ehci-w90x900.o
++obj-$(CONFIG_USB_EHCI_OXNAS) += ehci-oxnas.o
+
+ obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
+ obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o
diff --git a/target/linux/oxnas/patches-3.18/900-more-boards.patch b/target/linux/oxnas/patches-3.18/900-more-boards.patch
new file mode 100644
index 0000000000..b31967ad81
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/900-more-boards.patch
@@ -0,0 +1,16 @@
+Index: linux-3.18-rc4/arch/arm/boot/dts/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/arch/arm/boot/dts/Makefile
++++ linux-3.18-rc4/arch/arm/boot/dts/Makefile
+@@ -352,7 +352,10 @@ dtb-$(CONFIG_ARCH_ORION5X) += orion5x-la
+ orion5x-lacie-ethernet-disk-mini-v2.dtb \
+ orion5x-maxtor-shared-storage-2.dtb \
+ orion5x-rd88f5182-nas.dtb
+-dtb-$(CONFIG_ARCH_OXNAS) += ox820-pogoplug-pro.dtb
++dtb-$(CONFIG_ARCH_OXNAS) += ox820-pogoplug-pro.dtb \
++ ox820-pogoplug-v3.dtb \
++ ox820-stg212.dtb \
++ ox820-kd20.dtb
+ dtb-$(CONFIG_ARCH_PRIMA2) += prima2-evb.dtb
+ dtb-$(CONFIG_ARCH_QCOM) += \
+ qcom-apq8064-cm-qs600.dtb \