aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-11-08 12:37:39 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-11-08 12:37:39 +0000
commitd07f0dcda12a06a8c40606610ff606fab54bd123 (patch)
treec3effa30424c6b4638df5ff1804b229ec12367dd /target/linux/omap/Makefile
parente3b2c6418f6bad433429969526590831c0cb97e4 (diff)
downloadmaster-187ad058-d07f0dcda12a06a8c40606610ff606fab54bd123.tar.gz
master-187ad058-d07f0dcda12a06a8c40606610ff606fab54bd123.tar.bz2
master-187ad058-d07f0dcda12a06a8c40606610ff606fab54bd123.zip
[omap]: rename the omap4 target to omap
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38691 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap/Makefile')
-rw-r--r--target/linux/omap/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/omap/Makefile b/target/linux/omap/Makefile
new file mode 100644
index 0000000000..3a62911ca3
--- /dev/null
+++ b/target/linux/omap/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2012-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=omap
+BOARDNAME:=TI OMAP3/4/AM33xx
+FEATURES:=usb targz audio display
+CPU_TYPE:=cortex-a9
+CPU_SUBTYPE:=vfpv3
+
+LINUX_VERSION:=3.3.8
+
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+
+KERNELNAME:="uImage"
+
+DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
+
+DEVICE_TYPE=developerboard
+
+define Target/Description
+ TI OMAP boards
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))