aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-omap/Makefile10
-rw-r--r--package/kernel/mac80211/Makefile2
-rw-r--r--target/linux/omap/Makefile (renamed from target/linux/omap4/Makefile)10
-rw-r--r--target/linux/omap/base-files/etc/inittab (renamed from target/linux/omap4/base-files/etc/inittab)0
-rw-r--r--target/linux/omap/config-default (renamed from target/linux/omap4/config-default)0
-rw-r--r--target/linux/omap/image/Makefile (renamed from target/linux/omap4/image/Makefile)0
-rw-r--r--target/linux/omap/image/boot.script (renamed from target/linux/omap4/image/boot.script)2
-rw-r--r--target/linux/omap/patches/001-omap4_pandaboard-wlan_fix.patch (renamed from target/linux/omap4/patches/001-omap4_pandaboard-wlan_fix.patch)0
8 files changed, 12 insertions, 12 deletions
diff --git a/package/boot/uboot-omap/Makefile b/package/boot/uboot-omap/Makefile
index 356be5183e..73d1dc5795 100644
--- a/package/boot/uboot-omap/Makefile
+++ b/package/boot/uboot-omap/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -46,10 +46,10 @@ endef
UBOOTS:=omap4_panda am335x_evm omap3_overo omap3_beagle
define Package/uboot/template
-define Package/uboot-omap4-$(1)
+define Package/uboot-omap-$(1)
SECTION:=boot
CATEGORY:=Boot Loaders
- DEPENDS:=@TARGET_omap4
+ DEPENDS:=@TARGET_omap
TITLE:=$(2)
URL:=http://www.denx.de/wiki/U-Boot
VARIANT:=$(1)
@@ -85,7 +85,7 @@ define Package/uboot/install/default
endef
define Package/uboot/install/template
-define Package/uboot-omap4-$(1)/install
+define Package/uboot-omap-$(1)/install
$(call Package/uboot/install/default,$(2))
endef
endef
@@ -96,5 +96,5 @@ $(foreach u,$(UBOOTS), \
$(foreach u,$(UBOOTS), \
$(eval $(call BuildUBootPackage,$(u))) \
- $(eval $(call BuildPackage,uboot-omap4-$(u))) \
+ $(eval $(call BuildPackage,uboot-omap-$(u))) \
)
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index ae04ddeebe..16bfb6fb73 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -916,7 +916,7 @@ define KernelPackage/wl12xx
$(call KernelPackage/mac80211/Default)
TITLE:=Driver for TI WL12xx
URL:=http://wireless.kernel.org/en/users/Drivers/wl12xx
- DEPENDS+= @TARGET_omap4 +kmod-mac80211
+ DEPENDS+= @TARGET_omap +kmod-mac80211
FILES:= \
$(PKG_BUILD_DIR)/drivers/net/wireless/ti/wl12xx/wl12xx.ko \
$(PKG_BUILD_DIR)/drivers/net/wireless/ti/wlcore/wlcore.ko \
diff --git a/target/linux/omap4/Makefile b/target/linux/omap/Makefile
index 4deeddab88..3a62911ca3 100644
--- a/target/linux/omap4/Makefile
+++ b/target/linux/omap/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,8 +7,8 @@
include $(TOPDIR)/rules.mk
ARCH:=arm
-BOARD:=omap4
-BOARDNAME:=TI OMAP4
+BOARD:=omap
+BOARDNAME:=TI OMAP3/4/AM33xx
FEATURES:=usb targz audio display
CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=vfpv3
@@ -19,12 +19,12 @@ MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
KERNELNAME:="uImage"
-DEFAULT_PACKAGES += uboot-omap4-omap4_panda
+DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
DEVICE_TYPE=developerboard
define Target/Description
- TI OMAP4
+ TI OMAP boards
endef
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/omap4/base-files/etc/inittab b/target/linux/omap/base-files/etc/inittab
index cc6c31a129..cc6c31a129 100644
--- a/target/linux/omap4/base-files/etc/inittab
+++ b/target/linux/omap/base-files/etc/inittab
diff --git a/target/linux/omap4/config-default b/target/linux/omap/config-default
index d51ebc47de..d51ebc47de 100644
--- a/target/linux/omap4/config-default
+++ b/target/linux/omap/config-default
diff --git a/target/linux/omap4/image/Makefile b/target/linux/omap/image/Makefile
index e118122bd4..e118122bd4 100644
--- a/target/linux/omap4/image/Makefile
+++ b/target/linux/omap/image/Makefile
diff --git a/target/linux/omap4/image/boot.script b/target/linux/omap/image/boot.script
index 521f4389cf..d884a70195 100644
--- a/target/linux/omap4/image/boot.script
+++ b/target/linux/omap/image/boot.script
@@ -1,3 +1,3 @@
-fatload mmc 0:1 0x80000000 openwrt-omap4-uImage
+fatload mmc 0:1 0x80000000 openwrt-omap-uImage
setenv bootargs vram=32M fixrtc mem=1G@0x80000000 root=/dev/mmcblk0p2 rootfstype=ext4 console=ttyO2,115200n8 rootwait
bootm 0x80000000
diff --git a/target/linux/omap4/patches/001-omap4_pandaboard-wlan_fix.patch b/target/linux/omap/patches/001-omap4_pandaboard-wlan_fix.patch
index 9499e3b8af..9499e3b8af 100644
--- a/target/linux/omap4/patches/001-omap4_pandaboard-wlan_fix.patch
+++ b/target/linux/omap/patches/001-omap4_pandaboard-wlan_fix.patch