aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-01-23 19:16:33 +0000
committerJohn Crispin <blogic@openwrt.org>2011-01-23 19:16:33 +0000
commit3021d3ebe81480324dd14051cc1e4e34fbcb5d59 (patch)
treed64a6ca2404bb4e12fa172309f91b53de84dbde4 /target/linux/lantiq/image
parentc1c5604d3f348ca6d2885258499848cc59a0d499 (diff)
downloadmaster-187ad058-3021d3ebe81480324dd14051cc1e4e34fbcb5d59.tar.gz
master-187ad058-3021d3ebe81480324dd14051cc1e4e34fbcb5d59.tar.bz2
master-187ad058-3021d3ebe81480324dd14051cc1e4e34fbcb5d59.zip
[lantiq]
* adds arv4518pw mach support * fixes arv4525pw * make sure all mach names have the same style * move code around git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25075 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index f00c8e753a..2d6acc8d41 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -59,8 +59,11 @@ define Image/BuildKernel
$(call Image/BuildKernel/Template,EASY4010,$(xway_cmdline))
$(call Image/BuildKernel/Template,EASY50712,$(xway_cmdline))
$(call Image/BuildKernel/Template,EASY50812,$(xway_cmdline))
- $(call Image/BuildKernel/Template,ARV452,$(xway_cmdline))
- $(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
+ $(call Image/BuildKernel/Template,ARV4510PW,$(xway_cmdline))
+ $(call Image/BuildKernel/Template,ARV4518PW,$(xway_cmdline))
+ $(call Image/BuildKernel/Template,ARV4520PW,$(xway_cmdline))
+ $(call Image/BuildKernel/Template,ARV4525PW,$(xway_cmdline))
+ $(call Image/BuildKernel/Template,ARV752DPW,$(xway_cmdline))
$(call Image/BuildKernel/Template,ARV7518PW,$(xway_cmdline))
$(call Image/BuildKernel/Template,NONE)
endef
@@ -69,8 +72,11 @@ define Image/Build
$(call Image/Build/$(1),$(1),EASY4010)
$(call Image/Build/$(1),$(1),EASY50712)
$(call Image/Build/$(1),$(1),EASY50812)
- $(call Image/Build/$(1),$(1),ARV452)
- $(call Image/Build/$(1),$(1),ARV752DPW22)
+ $(call Image/Build/$(1),$(1),ARV4510PW)
+ $(call Image/Build/$(1),$(1),ARV4518PW)
+ $(call Image/Build/$(1),$(1),ARV4520PW)
+ $(call Image/Build/$(1),$(1),ARV4525PW)
+ $(call Image/Build/$(1),$(1),ARV752DPW)
$(call Image/Build/$(1),$(1),ARV7518PW)
$(call Image/Build/$(1),$(1),NONE)
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs