aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/profiles
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-05-21 19:31:54 +0000
committerJonas Gorski <jogo@openwrt.org>2015-05-21 19:31:54 +0000
commit2bb994b22ce834efde1fbb930ca88b718a598add (patch)
treec462de14511ddd8123c10235e15db3c603b803c1 /target/linux/brcm63xx/profiles
parent335023a903d78976bd102d086542002b38f74b87 (diff)
downloadmaster-187ad058-2bb994b22ce834efde1fbb930ca88b718a598add.tar.gz
master-187ad058-2bb994b22ce834efde1fbb930ca88b718a598add.tar.bz2
master-187ad058-2bb994b22ce834efde1fbb930ca88b718a598add.zip
brcm63xx: Add Huawei HG655b support
This patch adds support for the Huawei HG655b. Nothing much special in this router, it's just another BCM6368 with a Ralink RT3062 wifi chip and the calibration data embedded in the main flash chip at offset 0x7c0000. There is also configuration data used by the OEM firmware before the cal_data partition, this area is protected by the board_data partition in this patch. Signed-off-by: Daniel Gonzalez <dgcbueu@gmail.com> Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45708 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/profiles')
-rw-r--r--target/linux/brcm63xx/profiles/huawei.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/profiles/huawei.mk b/target/linux/brcm63xx/profiles/huawei.mk
index 594389ec0e..a6764b73e3 100644
--- a/target/linux/brcm63xx/profiles/huawei.mk
+++ b/target/linux/brcm63xx/profiles/huawei.mk
@@ -43,3 +43,13 @@ define Profile/HG556a_C/Description
Package set optimized for Huawei HG556a version C (Ralink).
endef
$(eval $(call Profile,HG556a_C))
+
+define Profile/HG655b
+ NAME:=Huawei HG655b
+ PACKAGES:=kmod-rt2800-pci wpad-mini \
+ kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/HG655b/Description
+ Package set optimized for Huawei HG655b, HG655d.
+endef
+$(eval $(call Profile,HG655b))