aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-06-07 15:19:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-06-07 15:19:40 +0000
commit758e298a5ddb74ad1693c521cb3a4634fe8efc3e (patch)
tree4076d2b81256d60f739c88ced88c59b29e51a585 /target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
parent772ff2ddf481b9c3aa1b9ef88dc8ee973565f98f (diff)
downloadmaster-187ad058-758e298a5ddb74ad1693c521cb3a4634fe8efc3e.tar.gz
master-187ad058-758e298a5ddb74ad1693c521cb3a4634fe8efc3e.tar.bz2
master-187ad058-758e298a5ddb74ad1693c521cb3a4634fe8efc3e.zip
brcm47xx: add a "legacy" subtarget that is usable for low-end 802.11g devices like WRT54G
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41041 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk')
-rw-r--r--target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk b/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
new file mode 100644
index 0000000000..50d777010b
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b43
+ NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (b43, default)
+ PACKAGES:=kmod-b43 kmod-b43legacy
+endef
+
+define Profile/Broadcom-b43/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and
+ b43legacy drivers and b44, tg3 or bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-b43))
+