aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-06-07 15:19:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-06-07 15:19:40 +0000
commit758e298a5ddb74ad1693c521cb3a4634fe8efc3e (patch)
tree4076d2b81256d60f739c88ced88c59b29e51a585
parent772ff2ddf481b9c3aa1b9ef88dc8ee973565f98f (diff)
downloadmaster-187ad058-758e298a5ddb74ad1693c521cb3a4634fe8efc3e.tar.gz
master-187ad058-758e298a5ddb74ad1693c521cb3a4634fe8efc3e.tar.bz2
master-187ad058-758e298a5ddb74ad1693c521cb3a4634fe8efc3e.zip
brcm47xx: add a "legacy" subtarget that is usable for low-end 802.11g devices like WRT54G
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41041 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/mac80211/Makefile6
-rw-r--r--target/linux/brcm47xx/Makefile2
-rw-r--r--target/linux/brcm47xx/legacy/config-default9
-rw-r--r--target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk20
-rw-r--r--target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk20
-rw-r--r--target/linux/brcm47xx/legacy/profiles/WGT634U.mk17
-rw-r--r--target/linux/brcm47xx/legacy/profiles/WRTSL54GS.mk17
-rw-r--r--target/linux/brcm47xx/legacy/target.mk6
8 files changed, 96 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index d3169587f8..e260993b89 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1167,6 +1167,7 @@ config PACKAGE_B43_USE_BCMA
config B43_FW_SQUASH_COREREVS
string "Core revisions to include"
depends on B43_FW_SQUASH
+ default "5,6,7,8,9,10,11,13,15" if TARGET_brcm47xx_legacy
default "5,6,7,8,9,10,11,13,15,16,29"
help
This is a comma seperated list of core revision numbers.
@@ -1180,6 +1181,7 @@ config PACKAGE_B43_USE_BCMA
config B43_FW_SQUASH_PHYTYPES
string "PHY types to include"
depends on B43_FW_SQUASH
+ default "G,LP" if TARGET_brcm47xx_legacy
default "G,LP,N,HT"
help
This is a comma seperated list of PHY types:
@@ -1204,9 +1206,11 @@ config PACKAGE_B43_USE_BCMA
This allows choosing buses that b43 should support.
config PACKAGE_B43_BUSES_BCMA_AND_SSB
+ depends on !TARGET_brcm47xx_legacy
bool "BCMA and SSB"
config PACKAGE_B43_BUSES_BCMA
+ depends on !TARGET_brcm47xx_legacy
bool "BCMA only"
config PACKAGE_B43_BUSES_SSB
@@ -1234,6 +1238,7 @@ config PACKAGE_B43_USE_BCMA
config PACKAGE_B43_PHY_N
bool "Enable support for N-PHYs"
+ default n if TARGET_brcm47xx_legacy
default y
help
Enable support for N-PHY. This includes support for the following devices:
@@ -1256,6 +1261,7 @@ config PACKAGE_B43_USE_BCMA
config PACKAGE_B43_PHY_HT
bool "Enable support for HT-PHYs"
+ default n if TARGET_brcm47xx_legacy
default y
help
Enable support for HT-PHY. This includes support for the following devices:
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
index 17a9e314bf..ca1239028b 100644
--- a/target/linux/brcm47xx/Makefile
+++ b/target/linux/brcm47xx/Makefile
@@ -10,7 +10,7 @@ ARCH:=mipsel
BOARD:=brcm47xx
BOARDNAME:=Broadcom BCM47xx/53xx (MIPS)
FEATURES:=squashfs usb pcmcia low_mem
-SUBTARGETS:=generic mips74k
+SUBTARGETS:=generic mips74k legacy
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
LINUX_VERSION:=3.10.36
diff --git a/target/linux/brcm47xx/legacy/config-default b/target/linux/brcm47xx/legacy/config-default
new file mode 100644
index 0000000000..d0799caedc
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/config-default
@@ -0,0 +1,9 @@
+CONFIG_B44=y
+CONFIG_B44_PCI=y
+CONFIG_B44_PCICORE_AUTOSELECT=y
+CONFIG_B44_PCI_AUTOSELECT=y
+# CONFIG_BCM47XX_BCMA is not set
+# CONFIG_BCMA is not set
+CONFIG_LEDS_GPIO_REGISTER=y
+# CONFIG_MTD_NAND is not set
+# CONFIG_SSB_DRIVER_GIGE is not set
diff --git a/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk b/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
new file mode 100644
index 0000000000..50d777010b
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b43
+ NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (b43, default)
+ PACKAGES:=kmod-b43 kmod-b43legacy
+endef
+
+define Profile/Broadcom-b43/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and
+ b43legacy drivers and b44, tg3 or bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-b43))
+
diff --git a/target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk b/target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk
new file mode 100644
index 0000000000..6a4c5b0394
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-wl
+ NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (wl, proprietary)
+ PACKAGES:=-wpad-mini kmod-brcm-wl-mini wlc nas
+endef
+
+define Profile/Broadcom-wl/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
+ wireless "wl" driver and b44, tg3 or bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-wl))
+
diff --git a/target/linux/brcm47xx/legacy/profiles/WGT634U.mk b/target/linux/brcm47xx/legacy/profiles/WGT634U.mk
new file mode 100644
index 0000000000..ebe5e2345c
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/WGT634U.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WGT634U
+ NAME:=Netgear WGT634U
+ PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb2 kmod-ocf-ubsec-ssb
+endef
+
+define Profile/WGT634U/Description
+ Package set compatible with the Netgear WGT634U. Contains USB support
+endef
+$(eval $(call Profile,WGT634U))
+
diff --git a/target/linux/brcm47xx/legacy/profiles/WRTSL54GS.mk b/target/linux/brcm47xx/legacy/profiles/WRTSL54GS.mk
new file mode 100644
index 0000000000..0e53c7d138
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/WRTSL54GS.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WRTSL54GS
+ NAME:=Linksys WRTSL54GS
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage kmod-scsi-core kmod-fs-ext3 e2fsprogs kmod-b43
+endef
+
+define Profile/WRTSL54GS/Description
+ Package set compatible with the Linksys WRTSL54GS. Contains USB support
+endef
+$(eval $(call Profile,WRTSL54GS))
+
diff --git a/target/linux/brcm47xx/legacy/target.mk b/target/linux/brcm47xx/legacy/target.mk
new file mode 100644
index 0000000000..7cbf42c08e
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/target.mk
@@ -0,0 +1,6 @@
+BOARDNAME:=Legacy (802.11g)
+
+define Target/Description
+ Build generic firmware for legacy 802.11g Broadcom BCM47xx
+ and BCM53xx MIPS devices.
+endef