aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/bcm2708
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-17 12:47:50 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-17 12:47:50 +0000
commit0fd73c82ed5afe0a7e0214a15542f6d350da558f (patch)
tree939f09fd1928f4ec6891b0386189fdebf31148ee /target/linux/brcm2708/bcm2708
parent5f6ce511add3ac9b5af8dec339165cdbf1a65f9d (diff)
downloadmaster-187ad058-0fd73c82ed5afe0a7e0214a15542f6d350da558f.tar.gz
master-187ad058-0fd73c82ed5afe0a7e0214a15542f6d350da558f.tar.bz2
master-187ad058-0fd73c82ed5afe0a7e0214a15542f6d350da558f.zip
brcm2708: improve profiles and image generation
- Add profiles for bcm2708 subtarget. - Check subtarget for image generation. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46396 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708/bcm2708')
-rw-r--r--target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk22
1 files changed, 18 insertions, 4 deletions
diff --git a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
index 94d0a068c0..82a7910ba1 100644
--- a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
+++ b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
@@ -5,12 +5,26 @@
# See /LICENSE for more information.
#
-define Profile/RaspberryPi
+define Profile/Default
NAME:=Raspberry Pi
endef
+define Profile/Default/Description
+ Raspberry Pi
+endef
+$(eval $(call Profile,Default))
-define Profile/RaspberryPi/Description
- Raspberry Pi board
+define Profile/RaspberryPi_B
+ NAME:=Raspberry Pi Model B
+endef
+define Profile/RaspberryPi_B/Description
+ Raspberry Pi Model B
endef
+$(eval $(call Profile,RaspberryPi_B))
-$(eval $(call Profile,RaspberryPi))
+define Profile/RaspberryPi_BPlus
+ NAME:=Raspberry Pi Model B+
+endef
+define Profile/RaspberryPi_BPlus/Description
+ Raspberry Pi Model B+
+endef
+$(eval $(call Profile,RaspberryPi_BPlus))