aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-17 12:47:50 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-17 12:47:50 +0000
commit0fd73c82ed5afe0a7e0214a15542f6d350da558f (patch)
tree939f09fd1928f4ec6891b0386189fdebf31148ee /target
parent5f6ce511add3ac9b5af8dec339165cdbf1a65f9d (diff)
downloadmaster-187ad058-0fd73c82ed5afe0a7e0214a15542f6d350da558f.tar.gz
master-187ad058-0fd73c82ed5afe0a7e0214a15542f6d350da558f.tar.bz2
master-187ad058-0fd73c82ed5afe0a7e0214a15542f6d350da558f.zip
brcm2708: improve profiles and image generation
- Add profiles for bcm2708 subtarget. - Check subtarget for image generation. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46396 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk22
-rw-r--r--target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk12
-rw-r--r--target/linux/brcm2708/image/Makefile19
3 files changed, 36 insertions, 17 deletions
diff --git a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
index 94d0a068c0..82a7910ba1 100644
--- a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
+++ b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
@@ -5,12 +5,26 @@
# See /LICENSE for more information.
#
-define Profile/RaspberryPi
+define Profile/Default
NAME:=Raspberry Pi
endef
+define Profile/Default/Description
+ Raspberry Pi
+endef
+$(eval $(call Profile,Default))
-define Profile/RaspberryPi/Description
- Raspberry Pi board
+define Profile/RaspberryPi_B
+ NAME:=Raspberry Pi Model B
+endef
+define Profile/RaspberryPi_B/Description
+ Raspberry Pi Model B
endef
+$(eval $(call Profile,RaspberryPi_B))
-$(eval $(call Profile,RaspberryPi))
+define Profile/RaspberryPi_BPlus
+ NAME:=Raspberry Pi Model B+
+endef
+define Profile/RaspberryPi_BPlus/Description
+ Raspberry Pi Model B+
+endef
+$(eval $(call Profile,RaspberryPi_BPlus))
diff --git a/target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk b/target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk
index d3d1617176..ef7483d841 100644
--- a/target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk
+++ b/target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk
@@ -5,12 +5,10 @@
# See /LICENSE for more information.
#
-define Profile/RaspberryPi2
- NAME:=Raspberry Pi 2
+define Profile/RaspberryPi_2
+ NAME:=Raspberry Pi 2 Model B
endef
-
-define Profile/RaspberryPi2/Description
- Raspberry Pi 2 board
+define Profile/RaspberryPi_2/Description
+ Raspberry Pi 2 Model B
endef
-
-$(eval $(call Profile,RaspberryPi2))
+$(eval $(call Profile,RaspberryPi_2))
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 10ecfdaef0..00bee22555 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -67,11 +67,18 @@ define add_bcm2708
TARGET_DEVICES += $(2)
endef
-# Raspberry Pi Model B
-$(eval $(call add_bcm2708,RaspberryPi,rpi-b,bcm2708-rpi-b))
-# Raspberry Pi Model B+
-$(eval $(call add_bcm2708,RaspberryPi,rpi-b-plus,bcm2708-rpi-b-plus))
-# Raspberry Pi 2 Model B
-$(eval $(call add_bcm2708,RaspberryPi2,rpi-2-b,bcm2709-rpi-2-b))
+### BCM2708/BCM2835 ###
+ifeq ($(SUBTARGET),bcm2708)
+ # Raspberry Pi Model B
+ $(eval $(call add_bcm2708,RaspberryPi_B,rpi-b,bcm2708-rpi-b))
+ # Raspberry Pi Model B+
+ $(eval $(call add_bcm2708,RaspberryPi_BPlus,rpi-b-plus,bcm2708-rpi-b-plus))
+endif
+
+### BCM2709/BCM2836 ###
+ifeq ($(SUBTARGET),bcm2709)
+ # Raspberry Pi 2 Model B
+ $(eval $(call add_bcm2708,RaspberryPi_2,rpi-2-b,bcm2709-rpi-2-b))
+endif
$(eval $(call BuildImage))