aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-11-24 18:30:50 +0000
committerJohn Crispin <blogic@openwrt.org>2015-11-24 18:30:50 +0000
commit7929372c24ab6caf6892bc1cd71fcf3301a1f2b2 (patch)
tree7ce0b01facf7418882ecb24a39859392a89bb379 /target/linux/ar71xx/patches-4.1
parent49d38ad8c15d948426d4b48b6f2e7d7f3480c686 (diff)
downloadmaster-187ad058-7929372c24ab6caf6892bc1cd71fcf3301a1f2b2.tar.gz
master-187ad058-7929372c24ab6caf6892bc1cd71fcf3301a1f2b2.tar.bz2
master-187ad058-7929372c24ab6caf6892bc1cd71fcf3301a1f2b2.zip
ar71xx: add GL-Domino Pi support V3
This is the patch for GL-Domino Pi V3. Updated against the latest trunk. Signed-off-by: alzhao<alzhao@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47622 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-4.1')
-rw-r--r--target/linux/ar71xx/patches-4.1/913-MIPS-ath79-add-domino-support.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.1/913-MIPS-ath79-add-domino-support.patch b/target/linux/ar71xx/patches-4.1/913-MIPS-ath79-add-domino-support.patch
new file mode 100644
index 0000000000..80351cf979
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.1/913-MIPS-ath79-add-domino-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -597,6 +597,16 @@ config ATH79_MACH_GL_AR300
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_GL_DOMINO
++ bool "DOMINO support"
++ select SOC_AR933X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_GL_INET
+ bool "GL-INET support"
+ select SOC_AR933X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -85,6 +85,7 @@ obj-$(CONFIG_ATH79_MACH_ESR1750) += mach
+ obj-$(CONFIG_ATH79_MACH_F9K1115V2) += mach-f9k1115v2.o
+ obj-$(CONFIG_ATH79_MACH_GL_AR150) += mach-gl-ar150.o
+ obj-$(CONFIG_ATH79_MACH_GL_AR300) += mach-gl-ar300.o
++obj-$(CONFIG_ATH79_MACH_GL_DOMINO) += mach-gl-domino.o
+ obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
+ obj-$(CONFIG_ATH79_MACH_GS_MINIBOX_V1) += mach-gs-minibox-v1.o
+ obj-$(CONFIG_ATH79_MACH_GS_OOLITE) += mach-gs-oolite.o
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -74,6 +74,7 @@ enum ath79_mach_type {
+ ATH79_MACH_F9K1115V2, /* Belkin AC1750DB */
+ ATH79_MACH_GL_AR150, /* GL-AR150 support */
+ ATH79_MACH_GL_AR300, /* GL-AR300 */
++ ATH79_MACH_GL_DOMINO, /* Domino */
+ ATH79_MACH_GL_INET, /* GL-CONNECT GL-INET */
+ ATH79_MACH_GS_MINIBOX_V1, /* Gainstrong MiniBox V1.0 */
+ ATH79_MACH_GS_OOLITE, /* GS OOLITE V1.0 */