aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-11-24 18:30:19 +0000
committerJohn Crispin <blogic@openwrt.org>2015-11-24 18:30:19 +0000
commit49d38ad8c15d948426d4b48b6f2e7d7f3480c686 (patch)
tree8ed3da20af575dc14de000351ce53fc438287f87 /target/linux/ar71xx/patches-4.1
parentd95f4c6ca377edcdf8c827a50b5e67e12313f9f6 (diff)
downloadmaster-187ad058-49d38ad8c15d948426d4b48b6f2e7d7f3480c686.tar.gz
master-187ad058-49d38ad8c15d948426d4b48b6f2e7d7f3480c686.tar.bz2
master-187ad058-49d38ad8c15d948426d4b48b6f2e7d7f3480c686.zip
ar71xx: add GL-AR300 support V3
This is the patch for GL-AR300 V3, tested against the latest trunk. Signed-off-by: alzhao<alzhao@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47621 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-4.1')
-rw-r--r--target/linux/ar71xx/patches-4.1/912-MIPS-ath79-add-gl_ar300.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.1/912-MIPS-ath79-add-gl_ar300.patch b/target/linux/ar71xx/patches-4.1/912-MIPS-ath79-add-gl_ar300.patch
new file mode 100644
index 0000000000..6ca9913b2d
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.1/912-MIPS-ath79-add-gl_ar300.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -587,6 +587,16 @@ config ATH79_MACH_GL_AR150
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_GL_AR300
++ bool "GL_AR300 support"
++ select SOC_AR934X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_GL_INET
+ bool "GL-INET support"
+ select SOC_AR933X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -84,6 +84,7 @@ obj-$(CONFIG_ATH79_MACH_EPG5000) += mach
+ obj-$(CONFIG_ATH79_MACH_ESR1750) += mach-esr1750.o
+ obj-$(CONFIG_ATH79_MACH_F9K1115V2) += mach-f9k1115v2.o
+ obj-$(CONFIG_ATH79_MACH_GL_AR150) += mach-gl-ar150.o
++obj-$(CONFIG_ATH79_MACH_GL_AR300) += mach-gl-ar300.o
+ obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
+ obj-$(CONFIG_ATH79_MACH_GS_MINIBOX_V1) += mach-gs-minibox-v1.o
+ obj-$(CONFIG_ATH79_MACH_GS_OOLITE) += mach-gs-oolite.o
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -73,6 +73,7 @@ enum ath79_mach_type {
+ ATH79_MACH_EPG5000, /* EnGenius EPG5000 */
+ ATH79_MACH_F9K1115V2, /* Belkin AC1750DB */
+ ATH79_MACH_GL_AR150, /* GL-AR150 support */
++ ATH79_MACH_GL_AR300, /* GL-AR300 */
+ ATH79_MACH_GL_INET, /* GL-CONNECT GL-INET */
+ ATH79_MACH_GS_MINIBOX_V1, /* Gainstrong MiniBox V1.0 */
+ ATH79_MACH_GS_OOLITE, /* GS OOLITE V1.0 */