aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-11-24 18:29:59 +0000
committerJohn Crispin <blogic@openwrt.org>2015-11-24 18:29:59 +0000
commitd95f4c6ca377edcdf8c827a50b5e67e12313f9f6 (patch)
tree08bb9cfc5df16260ad07bafd598d09a1000cac87 /target/linux/ar71xx/patches-4.1
parent1a5d8c271f351f8dc8679a68a969b0fe6c3cad62 (diff)
downloadmaster-187ad058-d95f4c6ca377edcdf8c827a50b5e67e12313f9f6.tar.gz
master-187ad058-d95f4c6ca377edcdf8c827a50b5e67e12313f9f6.tar.bz2
master-187ad058-d95f4c6ca377edcdf8c827a50b5e67e12313f9f6.zip
ar71xx: add GL-AR150 support V3
This is the 3rd version. Modified against the latest trunk. Signed-off-by: alzhao<alzhao@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47620 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-4.1')
-rw-r--r--target/linux/ar71xx/patches-4.1/911-MIPS-ath79-add-gl_ar150.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.1/911-MIPS-ath79-add-gl_ar150.patch b/target/linux/ar71xx/patches-4.1/911-MIPS-ath79-add-gl_ar150.patch
new file mode 100644
index 0000000000..8c7b4d731b
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.1/911-MIPS-ath79-add-gl_ar150.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -577,6 +577,16 @@ config ATH79_MACH_EL_MINI
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_GL_AR150
++ bool "GL AR150 support"
++ select SOC_AR933X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_GL_INET
+ bool "GL-INET support"
+ select SOC_AR933X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -83,6 +83,7 @@ obj-$(CONFIG_ATH79_MACH_EL_MINI) += mach
+ obj-$(CONFIG_ATH79_MACH_EPG5000) += mach-epg5000.o
+ obj-$(CONFIG_ATH79_MACH_ESR1750) += mach-esr1750.o
+ obj-$(CONFIG_ATH79_MACH_F9K1115V2) += mach-f9k1115v2.o
++obj-$(CONFIG_ATH79_MACH_GL_AR150) += mach-gl-ar150.o
+ obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
+ obj-$(CONFIG_ATH79_MACH_GS_MINIBOX_V1) += mach-gs-minibox-v1.o
+ obj-$(CONFIG_ATH79_MACH_GS_OOLITE) += mach-gs-oolite.o
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -72,6 +72,7 @@ enum ath79_mach_type {
+ ATH79_MACH_ESR1750, /* EnGenius ESR1750 */
+ ATH79_MACH_EPG5000, /* EnGenius EPG5000 */
+ ATH79_MACH_F9K1115V2, /* Belkin AC1750DB */
++ ATH79_MACH_GL_AR150, /* GL-AR150 support */
+ ATH79_MACH_GL_INET, /* GL-CONNECT GL-INET */
+ ATH79_MACH_GS_MINIBOX_V1, /* Gainstrong MiniBox V1.0 */
+ ATH79_MACH_GS_OOLITE, /* GS OOLITE V1.0 */