aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-23 09:49:01 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-23 09:49:01 +0000
commit8f083deaab52c86b1faec1cf346794a0590db396 (patch)
tree56779fdb7e770212a6830b578e6420ad29383544 /target/linux/ar71xx/patches-3.10
parent92b4d1552c92f2923a8d041435a7a13b864e5d03 (diff)
downloadmaster-187ad058-8f083deaab52c86b1faec1cf346794a0590db396.tar.gz
master-187ad058-8f083deaab52c86b1faec1cf346794a0590db396.tar.bz2
master-187ad058-8f083deaab52c86b1faec1cf346794a0590db396.zip
ar71xx: add kernel support for the TEW-732BR board
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38131 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.10')
-rw-r--r--target/linux/ar71xx/patches-3.10/627-MIPS-ath79-add-TEW-732BR-support.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/627-MIPS-ath79-add-TEW-732BR-support.patch b/target/linux/ar71xx/patches-3.10/627-MIPS-ath79-add-TEW-732BR-support.patch
new file mode 100644
index 0000000000..b45c350d4f
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/627-MIPS-ath79-add-TEW-732BR-support.patch
@@ -0,0 +1,38 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -735,6 +735,15 @@ config ATH79_MACH_TEW_712BR
+ select ATH79_DEV_WMAC
+ select ATH79_NVRAM
+
++config ATH79_MACH_TEW_732BR
++ bool "TRENDnet TEW-732BR support"
++ select SOC_AR934X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_UBNT
+ bool "Ubiquiti AR71xx based boards support"
+ select SOC_AR71XX
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -83,6 +83,7 @@ enum ath79_mach_type {
+ ATH79_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
+ ATH79_MACH_TEW_673GRU, /* TRENDnet TEW-673GRU */
+ ATH79_MACH_TEW_712BR, /* TRENDnet TEW-712BR */
++ ATH79_MACH_TEW_732BR, /* TRENDnet TEW-732BR */
+ ATH79_MACH_TL_MR10U, /* TP-LINK TL-MR10U */
+ ATH79_MACH_TL_MR11U, /* TP-LINK TL-MR11U */
+ ATH79_MACH_TL_MR13U, /* TP-LINK TL-MR13U */
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -80,6 +80,7 @@ obj-$(CONFIG_ATH79_MACH_RW2458N) += mach
+ obj-$(CONFIG_ATH79_MACH_TEW_632BRP) += mach-tew-632brp.o
+ obj-$(CONFIG_ATH79_MACH_TEW_673GRU) += mach-tew-673gru.o
+ obj-$(CONFIG_ATH79_MACH_TEW_712BR) += mach-tew-712br.o
++obj-$(CONFIG_ATH79_MACH_TEW_732BR) += mach-tew-732br.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR11U) += mach-tl-mr11u.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR13U) += mach-tl-mr13u.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR3020) += mach-tl-mr3020.o