aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-23 09:49:01 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-23 09:49:01 +0000
commit8f083deaab52c86b1faec1cf346794a0590db396 (patch)
tree56779fdb7e770212a6830b578e6420ad29383544 /target
parent92b4d1552c92f2923a8d041435a7a13b864e5d03 (diff)
downloadmaster-187ad058-8f083deaab52c86b1faec1cf346794a0590db396.tar.gz
master-187ad058-8f083deaab52c86b1faec1cf346794a0590db396.tar.bz2
master-187ad058-8f083deaab52c86b1faec1cf346794a0590db396.zip
ar71xx: add kernel support for the TEW-732BR board
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38131 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/config-3.101
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-tew-732br.c127
-rw-r--r--target/linux/ar71xx/patches-3.10/627-MIPS-ath79-add-TEW-732BR-support.patch38
3 files changed, 166 insertions, 0 deletions
diff --git a/target/linux/ar71xx/config-3.10 b/target/linux/ar71xx/config-3.10
index 92019812e1..109d7d0ab1 100644
--- a/target/linux/ar71xx/config-3.10
+++ b/target/linux/ar71xx/config-3.10
@@ -65,6 +65,7 @@ CONFIG_ATH79_MACH_RW2458N=y
CONFIG_ATH79_MACH_TEW_632BRP=y
CONFIG_ATH79_MACH_TEW_673GRU=y
CONFIG_ATH79_MACH_TEW_712BR=y
+CONFIG_ATH79_MACH_TEW_732BR=y
CONFIG_ATH79_MACH_TL_MR11U=y
CONFIG_ATH79_MACH_TL_MR13U=y
CONFIG_ATH79_MACH_TL_MR3020=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tew-732br.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tew-732br.c
new file mode 100644
index 0000000000..1f26f6f4b0
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-tew-732br.c
@@ -0,0 +1,127 @@
+/*
+ * TRENDnet TEW-732BR board support
+ *
+ * Copyright (C) 2013 Gabor Juhos <juhosg@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define TEW_732BR_GPIO_BTN_WPS 16
+#define TEW_732BR_GPIO_BTN_RESET 17
+
+#define TEW_732BR_GPIO_LED_POWER_GREEN 4
+#define TEW_732BR_GPIO_LED_POWER_AMBER 14
+#define TEW_732BR_GPIO_LED_PLANET_GREEN 12
+#define TEW_732BR_GPIO_LED_PLANET_AMBER 22
+
+#define TEW_732BR_KEYS_POLL_INTERVAL 20 /* msecs */
+#define TEW_732BR_KEYS_DEBOUNCE_INTERVAL (3 * TEW_732BR_KEYS_POLL_INTERVAL)
+
+#define TEW_732BR_ART_ADDRESS 0x1fff0000
+#define TEW_732BR_CALDATA_OFFSET 0x1000
+#define TEW_732BR_LAN_MAC_OFFSET 0xffa0
+#define TEW_732BR_WAN_MAC_OFFSET 0xffb4
+
+static struct gpio_led tew_732br_leds_gpio[] __initdata = {
+ {
+ .name = "trendnet:green:power",
+ .gpio = TEW_732BR_GPIO_LED_POWER_GREEN,
+ .active_low = 0,
+ },
+ {
+ .name = "trendnet:amber:power",
+ .gpio = TEW_732BR_GPIO_LED_POWER_AMBER,
+ .active_low = 0,
+ },
+ {
+ .name = "trendnet:green:wan",
+ .gpio = TEW_732BR_GPIO_LED_PLANET_GREEN,
+ .active_low = 1,
+ },
+ {
+ .name = "trendnet:amber:wan",
+ .gpio = TEW_732BR_GPIO_LED_PLANET_AMBER,
+ .active_low = 0,
+ },
+};
+
+static struct gpio_keys_button tew_732br_gpio_keys[] __initdata = {
+ {
+ .desc = "Reset button",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = TEW_732BR_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TEW_732BR_GPIO_BTN_RESET,
+ .active_low = 1,
+ },
+ {
+ .desc = "WPS button",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .debounce_interval = TEW_732BR_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TEW_732BR_GPIO_BTN_WPS,
+ .active_low = 1,
+ },
+};
+
+static void __init tew_732br_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(TEW_732BR_ART_ADDRESS);
+ u8 lan_mac[ETH_ALEN];
+ u8 wan_mac[ETH_ALEN];
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(tew_732br_leds_gpio),
+ tew_732br_leds_gpio);
+
+ ath79_register_gpio_keys_polled(1, TEW_732BR_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(tew_732br_gpio_keys),
+ tew_732br_gpio_keys);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_parse_ascii_mac(art + TEW_732BR_LAN_MAC_OFFSET, lan_mac);
+ ath79_parse_ascii_mac(art + TEW_732BR_WAN_MAC_OFFSET, wan_mac);
+
+ ath79_register_wmac(art + TEW_732BR_CALDATA_OFFSET, lan_mac);
+
+ ath79_register_mdio(1, 0x0);
+
+ ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_SW_ONLY_MODE);
+
+ /* LAN: GMAC1 is connected to the internal switch */
+ ath79_init_mac(ath79_eth1_data.mac_addr, lan_mac, 0);
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+
+ ath79_register_eth(1);
+
+ /* WAN: GMAC0 is connected to the PHY4 of the internal switch */
+ ath79_init_mac(ath79_eth0_data.mac_addr, wan_mac, 0);
+
+ ath79_switch_data.phy4_mii_en = 1;
+ ath79_switch_data.phy_poll_mask = BIT(4);
+
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.phy_mask = BIT(4);
+ ath79_eth0_data.mii_bus_dev = &ath79_mdio1_device.dev;
+
+ ath79_register_eth(0);
+}
+
+MIPS_MACHINE(ATH79_MACH_TEW_732BR, "TEW-732BR", "TRENDnet TEW-732BR",
+ tew_732br_setup);
diff --git a/target/linux/ar71xx/patches-3.10/627-MIPS-ath79-add-TEW-732BR-support.patch b/target/linux/ar71xx/patches-3.10/627-MIPS-ath79-add-TEW-732BR-support.patch
new file mode 100644
index 0000000000..b45c350d4f
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/627-MIPS-ath79-add-TEW-732BR-support.patch
@@ -0,0 +1,38 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -735,6 +735,15 @@ config ATH79_MACH_TEW_712BR
+ select ATH79_DEV_WMAC
+ select ATH79_NVRAM
+
++config ATH79_MACH_TEW_732BR
++ bool "TRENDnet TEW-732BR support"
++ select SOC_AR934X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_UBNT
+ bool "Ubiquiti AR71xx based boards support"
+ select SOC_AR71XX
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -83,6 +83,7 @@ enum ath79_mach_type {
+ ATH79_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
+ ATH79_MACH_TEW_673GRU, /* TRENDnet TEW-673GRU */
+ ATH79_MACH_TEW_712BR, /* TRENDnet TEW-712BR */
++ ATH79_MACH_TEW_732BR, /* TRENDnet TEW-732BR */
+ ATH79_MACH_TL_MR10U, /* TP-LINK TL-MR10U */
+ ATH79_MACH_TL_MR11U, /* TP-LINK TL-MR11U */
+ ATH79_MACH_TL_MR13U, /* TP-LINK TL-MR13U */
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -80,6 +80,7 @@ obj-$(CONFIG_ATH79_MACH_RW2458N) += mach
+ obj-$(CONFIG_ATH79_MACH_TEW_632BRP) += mach-tew-632brp.o
+ obj-$(CONFIG_ATH79_MACH_TEW_673GRU) += mach-tew-673gru.o
+ obj-$(CONFIG_ATH79_MACH_TEW_712BR) += mach-tew-712br.o
++obj-$(CONFIG_ATH79_MACH_TEW_732BR) += mach-tew-732br.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR11U) += mach-tl-mr11u.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR13U) += mach-tl-mr13u.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR3020) += mach-tl-mr3020.o