aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-07 13:46:38 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-07 13:46:38 +0000
commitbe9054a22e2131f369f68d70d408d51e77c749ea (patch)
tree3bcad2e7c1c019760562b31565f1766ef2ae6bd0 /target/linux/ar71xx/image/Makefile
parent4de15b7633237b38b820536d4ee8d162ea92e814 (diff)
downloadmaster-187ad058-be9054a22e2131f369f68d70d408d51e77c749ea.tar.gz
master-187ad058-be9054a22e2131f369f68d70d408d51e77c749ea.tar.bz2
master-187ad058-be9054a22e2131f369f68d70d408d51e77c749ea.zip
ar71xx: add support for ubnt rocket-m ti
rocket-m titanium is a device based on ar9344 with 802.11af poe. It doesn't use the SoC wifi, instead it's using an ar9280 connected to the pci bus. The gps version of the rocket-m ti is working, but gps is untested. The gps is connected to the first serial port. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46234 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 53ce56bbd2..3c052424bd 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -787,7 +787,14 @@ define Device/ubnt-rocket-m-xw
$(Device/ubnt-xw)
BOARDNAME := UBNT-RM-XW
endef
-TARGET_DEVICES += ubnt-nano-m-xw ubnt-loco-m-xw ubnt-rocket-m-xw
+
+define Device/ubnt-rocket-m-ti
+ $(Device/ubnt-xw)
+ BOARDNAME := UBNT-RM-TI
+ UBNT_TYPE := TI
+ UBNT_BOARD := XM
+endef
+TARGET_DEVICES += ubnt-nano-m-xw ubnt-loco-m-xw ubnt-rocket-m-xw ubnt-rocket-m-ti
define Device/ubnt-air-gateway
$(Device/ubnt-xm)