aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-07 13:46:38 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-07 13:46:38 +0000
commitbe9054a22e2131f369f68d70d408d51e77c749ea (patch)
tree3bcad2e7c1c019760562b31565f1766ef2ae6bd0 /target/linux
parent4de15b7633237b38b820536d4ee8d162ea92e814 (diff)
downloadmaster-187ad058-be9054a22e2131f369f68d70d408d51e77c749ea.tar.gz
master-187ad058-be9054a22e2131f369f68d70d408d51e77c749ea.tar.bz2
master-187ad058-be9054a22e2131f369f68d70d408d51e77c749ea.zip
ar71xx: add support for ubnt rocket-m ti
rocket-m titanium is a device based on ar9344 with 802.11af poe. It doesn't use the SoC wifi, instead it's using an ar9280 connected to the pci bus. The gps version of the rocket-m ti is working, but gps is untested. The gps is connected to the first serial port. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46234 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
-rw-r--r--target/linux/ar71xx/base-files/etc/uci-defaults/01_leds9
-rw-r--r--target/linux/ar71xx/base-files/etc/uci-defaults/02_network1
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/image/Makefile9
-rw-r--r--target/linux/ar71xx/patches-3.18/904-MIPS-ath79-ubnt-rocket-m-ti-supprt.patch139
7 files changed, 164 insertions, 1 deletions
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index c02efa8751..f3625712e0 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -40,6 +40,9 @@ get_status_led() {
bullet-m | rocket-m | rocket-m-xw | nano-m | nanostation-m | nanostation-m-xw | loco-m-xw)
status_led="ubnt:green:link4"
;;
+ rocket-m-ti)
+ status_led="ubnt:green:link6"
+ ;;
bxu2000n-2-a1)
status_led="bhu:green:status"
;;
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds b/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
index 7c10f42467..ec7303c066 100644
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
@@ -52,6 +52,15 @@ loco-m-xw)
ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "ubnt:green:link4" "wlan0" "76" "100" "-75" "13"
;;
+rocket-m-ti)
+ ucidef_set_led_rssi "rssiverylow" "RSSIVERYLOW" "ubnt:green:link1" "wlan0" "1" "100" "0" "13"
+ ucidef_set_led_rssi "rssilow" "RSSILOW" "ubnt:green:link2" "wlan0" "26" "100" "-25" "13"
+ ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "ubnt:green:link3" "wlan0" "51" "100" "-50" "13"
+ ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "ubnt:green:link4" "wlan0" "76" "100" "-75" "13"
+ ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "ubnt:green:link5" "wlan0" "76" "100" "-75" "13"
+ ucidef_set_led_rssi "rssiveryhigh" "RSSIVERYHIGH" "ubnt:green:link4" "wlan0" "76" "100" "-75" "13"
+ ;;
+
bxu2000n-2-a1)
ucidef_set_led_wlan "wlan" "WLAN" "bhu:green:wlan" "phy0tpt"
;;
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
index b62fe859b1..6762adfdd4 100644
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
@@ -18,6 +18,7 @@ case "$board" in
all0315n |\
all0258n |\
ja76pf2|\
+rocket-m-ti |\
ubnt-unifi-outdoor)
ucidef_set_interface_lan "eth0 eth1"
;;
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 4fee82c8cc..8dbc6af34f 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -640,6 +640,9 @@ ar71xx_board_detect() {
*"Rocket M")
name="rocket-m"
;;
+ *"Rocket M TI")
+ name="rocket-m-ti"
+ ;;
*"Rocket M XW")
name="rocket-m-xw"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 79e52fcb19..c8eb8e401f 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -228,6 +228,7 @@ platform_check_image() {
nanostation-m | \
rocket-m | \
rocket-m-xw | \
+ rocket-m-ti | \
nanostation-m-xw | \
rw2458n | \
wpj531 | \
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 53ce56bbd2..3c052424bd 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -787,7 +787,14 @@ define Device/ubnt-rocket-m-xw
$(Device/ubnt-xw)
BOARDNAME := UBNT-RM-XW
endef
-TARGET_DEVICES += ubnt-nano-m-xw ubnt-loco-m-xw ubnt-rocket-m-xw
+
+define Device/ubnt-rocket-m-ti
+ $(Device/ubnt-xw)
+ BOARDNAME := UBNT-RM-TI
+ UBNT_TYPE := TI
+ UBNT_BOARD := XM
+endef
+TARGET_DEVICES += ubnt-nano-m-xw ubnt-loco-m-xw ubnt-rocket-m-xw ubnt-rocket-m-ti
define Device/ubnt-air-gateway
$(Device/ubnt-xm)
diff --git a/target/linux/ar71xx/patches-3.18/904-MIPS-ath79-ubnt-rocket-m-ti-supprt.patch b/target/linux/ar71xx/patches-3.18/904-MIPS-ath79-ubnt-rocket-m-ti-supprt.patch
new file mode 100644
index 0000000000..f485e62f46
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.18/904-MIPS-ath79-ubnt-rocket-m-ti-supprt.patch
@@ -0,0 +1,139 @@
+Index: linux-3.18.14/arch/mips/ath79/mach-ubnt-xm.c
+===================================================================
+--- linux-3.18.14.orig/arch/mips/ath79/mach-ubnt-xm.c
++++ linux-3.18.14/arch/mips/ath79/mach-ubnt-xm.c
+@@ -21,6 +21,8 @@
+ #include <asm/mach-ath79/irq.h>
+ #include <asm/mach-ath79/ar71xx_regs.h>
+
++#include <linux/platform_data/phy-at803x.h>
++
+ #include "common.h"
+ #include "dev-ap9x-pci.h"
+ #include "dev-eth.h"
+@@ -404,6 +406,40 @@ static struct gpio_led ubnt_xw_leds_gpio
+ },
+ };
+
++#define UBNT_ROCKET_TI_GPIO_LED_L1 16
++#define UBNT_ROCKET_TI_GPIO_LED_L2 17
++#define UBNT_ROCKET_TI_GPIO_LED_L3 18
++#define UBNT_ROCKET_TI_GPIO_LED_L4 19
++#define UBNT_ROCKET_TI_GPIO_LED_L5 20
++#define UBNT_ROCKET_TI_GPIO_LED_L6 21
++static struct gpio_led ubnt_rocket_ti_leds_gpio[] __initdata = {
++ {
++ .name = "ubnt:green:link1",
++ .gpio = UBNT_ROCKET_TI_GPIO_LED_L1,
++ .active_low = 1,
++ }, {
++ .name = "ubnt:green:link2",
++ .gpio = UBNT_ROCKET_TI_GPIO_LED_L2,
++ .active_low = 1,
++ }, {
++ .name = "ubnt:green:link3",
++ .gpio = UBNT_ROCKET_TI_GPIO_LED_L3,
++ .active_low = 1,
++ }, {
++ .name = "ubnt:green:link4",
++ .gpio = UBNT_ROCKET_TI_GPIO_LED_L4,
++ .active_low = 0,
++ }, {
++ .name = "ubnt:green:link5",
++ .gpio = UBNT_ROCKET_TI_GPIO_LED_L5,
++ .active_low = 0,
++ }, {
++ .name = "ubnt:green:link6",
++ .gpio = UBNT_ROCKET_TI_GPIO_LED_L6,
++ .active_low = 0,
++ },
++};
++
+ static void __init ubnt_xw_init(void)
+ {
+ u8 *eeprom = (u8 *) KSEG1ADDR(0x1fff0000);
+@@ -477,6 +513,62 @@ static void __init ubnt_rocket_m_xw_setu
+ ath79_register_eth(0);
+ }
+
++static struct at803x_platform_data ubnt_rocket_m_ti_at803_data = {
++ .disable_smarteee = 1,
++ .enable_rgmii_rx_delay = 1,
++ .enable_rgmii_tx_delay = 1,
++};
++static struct mdio_board_info ubnt_rocket_m_ti_mdio_info[] = {
++ {
++ .bus_id = "ag71xx-mdio.0",
++ .phy_addr = 4,
++ .platform_data = &ubnt_rocket_m_ti_at803_data,
++ },
++};
++
++static void __init ubnt_rocket_m_ti_setup(void)
++{
++ u8 *eeprom = (u8 *) KSEG1ADDR(0x1fff0000);
++
++ ath79_register_m25p80(NULL);
++
++ ath79_register_leds_gpio(-1, ARRAY_SIZE(ubnt_rocket_ti_leds_gpio),
++ ubnt_rocket_ti_leds_gpio);
++ ath79_register_gpio_keys_polled(-1, UBNT_XM_KEYS_POLL_INTERVAL,
++ ARRAY_SIZE(ubnt_xm_gpio_keys),
++ ubnt_xm_gpio_keys);
++
++ ap91_pci_init(eeprom + 0x1000, NULL);
++
++ ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_RGMII_GMAC0);
++ ath79_setup_ar934x_eth_rx_delay(3, 3);
++ ath79_init_mac(ath79_eth0_data.mac_addr,
++ eeprom + UAP_PRO_MAC0_OFFSET, 0);
++ ath79_init_mac(ath79_eth1_data.mac_addr,
++ eeprom + UAP_PRO_MAC1_OFFSET, 0);
++
++ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
++ ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
++ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
++ ath79_eth1_data.mii_bus_dev = &ath79_mdio1_device.dev;
++
++ mdiobus_register_board_info(ubnt_rocket_m_ti_mdio_info,
++ ARRAY_SIZE(ubnt_rocket_m_ti_mdio_info));
++ ath79_register_mdio(0, 0x0);
++
++
++ ath79_eth0_data.phy_mask = BIT(4);
++ /* read out from vendor */
++ ath79_eth0_pll_data.pll_1000 = 0x2000000;
++ ath79_eth0_pll_data.pll_10 = 0x1313;
++ ath79_register_eth(0);
++
++ ath79_register_mdio(1, 0x0);
++ ath79_eth1_data.phy_mask = BIT(3);
++ ath79_register_eth(1);
++}
++
++
+ MIPS_MACHINE(ATH79_MACH_UBNT_NANO_M_XW, "UBNT-NM-XW", "Ubiquiti Nanostation M XW",
+ ubnt_nano_m_xw_setup);
+
+@@ -486,6 +578,9 @@ MIPS_MACHINE(ATH79_MACH_UBNT_LOCO_M_XW,
+ MIPS_MACHINE(ATH79_MACH_UBNT_ROCKET_M_XW, "UBNT-RM-XW", "Ubiquiti Rocket M XW",
+ ubnt_rocket_m_xw_setup);
+
++MIPS_MACHINE(ATH79_MACH_UBNT_ROCKET_M_TI, "UBNT-RM-TI", "Ubiquiti Rocket M TI",
++ ubnt_rocket_m_ti_setup);
++
+ static struct gpio_led ubnt_airgateway_gpio_leds[] __initdata = {
+ {
+ .name = "ubnt:blue:wlan",
+Index: linux-3.18.14/arch/mips/ath79/machtypes.h
+===================================================================
+--- linux-3.18.14.orig/arch/mips/ath79/machtypes.h
++++ linux-3.18.14/arch/mips/ath79/machtypes.h
+@@ -172,6 +172,7 @@ enum ath79_mach_type {
+ ATH79_MACH_UBNT_NANO_M_XW, /* Ubiquiti NanoStation M XW */
+ ATH79_MACH_UBNT_ROCKET_M, /* Ubiquiti Rocket M */
+ ATH79_MACH_UBNT_ROCKET_M_XW, /* Ubiquiti Rocket M XW*/
++ ATH79_MACH_UBNT_ROCKET_M_TI, /* Ubiquiti Rocket M TI*/
+ ATH79_MACH_UBNT_RSPRO, /* Ubiquiti RouterStation Pro */
+ ATH79_MACH_UBNT_RS, /* Ubiquiti RouterStation */
+ ATH79_MACH_UBNT_UAP_PRO, /* Ubiquiti UniFi AP Pro */