aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-24 09:09:49 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-24 09:09:49 +0000
commit48ed568e01d424ab21b9b81f4f5a3bdcf3ef1a39 (patch)
tree1047392db4c045b6b2f3e454eff7057da6511d96 /target/linux/ar71xx/generic
parent8bf4a3fc9973498eef70d4c083b49bc3a8c56db0 (diff)
downloadmaster-187ad058-48ed568e01d424ab21b9b81f4f5a3bdcf3ef1a39.tar.gz
master-187ad058-48ed568e01d424ab21b9b81f4f5a3bdcf3ef1a39.tar.bz2
master-187ad058-48ed568e01d424ab21b9b81f4f5a3bdcf3ef1a39.zip
ar71xx: add support for Onion Omega
This patch adds support for the Onion Omega. https://onion.io/omega Signed-off-by: L. D. Pinney <ldpinney@gmail.com> Acked-by: Boken Lin <bl@onion.io> Tested-by: Jacky Huang <huangfangcheng@163.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46458 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/onion.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/onion.mk b/target/linux/ar71xx/generic/profiles/onion.mk
new file mode 100644
index 0000000000..dd5874ea41
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/onion.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/OMEGA
+ NAME:=Onion Omega
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-storage kmod-i2c-core kmod-i2c-gpio-custom kmod-spi-bitbang kmod-spi-dev kmod-spi-gpio kmod-spi-gpio-custom kmod-usb-serial
+endef
+
+define Profile/OMEGA/Description
+ Package set optimized for the Onion Omega development platform.
+endef
+$(eval $(call Profile,OMEGA))