aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/ubnt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-05-07 16:20:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-05-07 16:20:32 +0000
commitaa319d87f6e2a0608e485b2b30de70c56beb6b27 (patch)
treeaa3c35129007185c523ba8da15ce39f0c6085712 /target/linux/ar71xx/generic/profiles/ubnt.mk
parent84407eb7cb30db11ee4c45e715f4712ecab3ab18 (diff)
downloadmaster-187ad058-aa319d87f6e2a0608e485b2b30de70c56beb6b27.tar.gz
master-187ad058-aa319d87f6e2a0608e485b2b30de70c56beb6b27.tar.bz2
master-187ad058-aa319d87f6e2a0608e485b2b30de70c56beb6b27.zip
ar71xx: add a new subtarget for nand based devices - saves around 44k on the lzma compressed generic kernel image
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21396 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/ubnt.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/ubnt.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/ubnt.mk b/target/linux/ar71xx/generic/profiles/ubnt.mk
new file mode 100644
index 0000000000..a7fd9a2619
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/ubnt.mk
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/UBNTRS
+ NAME:=Ubiquiti RouterStation
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNTRS/Description
+ Package set optimized for the Ubiquiti RouterStation.
+endef
+
+$(eval $(call Profile,UBNTRS))
+
+define Profile/UBNTRSPRO
+ NAME:=Ubiquiti RouterStation Pro
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNTRSPRO/Description
+ Package set optimized for the Ubiquiti RouterStation Pro.
+endef
+
+$(eval $(call Profile,UBNTRSPRO))
+
+define Profile/UBNT
+ NAME:=Ubiquiti Products
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNT/Description
+ Build images for all Ubiquiti products (including LS-SR71, RouterStation and RouterStation Pro)
+endef
+
+$(eval $(call Profile,UBNT))