aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-05-07 16:20:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-05-07 16:20:32 +0000
commitaa319d87f6e2a0608e485b2b30de70c56beb6b27 (patch)
treeaa3c35129007185c523ba8da15ce39f0c6085712 /target/linux/ar71xx/generic/profiles
parent84407eb7cb30db11ee4c45e715f4712ecab3ab18 (diff)
downloadmaster-187ad058-aa319d87f6e2a0608e485b2b30de70c56beb6b27.tar.gz
master-187ad058-aa319d87f6e2a0608e485b2b30de70c56beb6b27.tar.bz2
master-187ad058-aa319d87f6e2a0608e485b2b30de70c56beb6b27.zip
ar71xx: add a new subtarget for nand based devices - saves around 44k on the lzma compressed generic kernel image
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21396 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles')
-rw-r--r--target/linux/ar71xx/generic/profiles/00-default.mk16
-rw-r--r--target/linux/ar71xx/generic/profiles/01-minimal.mk16
-rw-r--r--target/linux/ar71xx/generic/profiles/02-madwifi.mk16
-rw-r--r--target/linux/ar71xx/generic/profiles/atheros.mk63
-rw-r--r--target/linux/ar71xx/generic/profiles/atlantis.mk17
-rw-r--r--target/linux/ar71xx/generic/profiles/buffalo.mk17
-rw-r--r--target/linux/ar71xx/generic/profiles/compex.mk17
-rw-r--r--target/linux/ar71xx/generic/profiles/d-link.mk41
-rw-r--r--target/linux/ar71xx/generic/profiles/linksys.mk27
-rw-r--r--target/linux/ar71xx/generic/profiles/netgear.mk17
-rw-r--r--target/linux/ar71xx/generic/profiles/planex.mk28
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk94
-rw-r--r--target/linux/ar71xx/generic/profiles/trendnet.mk28
-rw-r--r--target/linux/ar71xx/generic/profiles/ubnt.mk39
-rw-r--r--target/linux/ar71xx/generic/profiles/zyxel.mk17
15 files changed, 453 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/00-default.mk b/target/linux/ar71xx/generic/profiles/00-default.mk
new file mode 100644
index 0000000000..aa46f22c54
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/00-default.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile (all drivers)
+ PACKAGES:=kmod-ath9k kmod-madwifi kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig vsc7385-ucode-ap83 vsc7385-ucode-pb44 vsc7395-ucode-ap83 vsc7395-ucode-pb44 wpad-mini
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/ar71xx/generic/profiles/01-minimal.mk b/target/linux/ar71xx/generic/profiles/01-minimal.mk
new file mode 100644
index 0000000000..3651c88ab2
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/01-minimal.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DefaultNoWifi
+ NAME:=Default Profile (no WiFi)
+ PACKAGES:=
+endef
+
+define Profile/DefaultNoWifi/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,DefaultNoWifi))
diff --git a/target/linux/ar71xx/generic/profiles/02-madwifi.mk b/target/linux/ar71xx/generic/profiles/02-madwifi.mk
new file mode 100644
index 0000000000..7c22c53db5
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/02-madwifi.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Madwifi
+ NAME:=Atheros WiFi (madwifi)
+ PACKAGES:=kmod-madwifi wpad-mini
+endef
+
+define Profile/Madwifi/Description
+ Package set compatible with hardware using Atheros WiFi cards.
+endef
+$(eval $(call Profile,Madwifi))
diff --git a/target/linux/ar71xx/generic/profiles/atheros.mk b/target/linux/ar71xx/generic/profiles/atheros.mk
new file mode 100644
index 0000000000..4ce0e605c6
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/atheros.mk
@@ -0,0 +1,63 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/AP81
+ NAME:=Atheros AP81 reference board
+ PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
+endef
+
+define Profile/AP81/Description
+ Package set optimized for the Atheros AP81 reference board.
+endef
+
+$(eval $(call Profile,AP81))
+
+define Profile/AP83
+ NAME:=Atheros AP83 reference board
+ PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2 \
+ vsc7385-ucode-ap83 vsc7395-ucode-ap83
+endef
+
+define Profile/AP83/Description
+ Package set optimized for the Atheros AP83 reference board.
+endef
+
+$(eval $(call Profile,AP83))
+
+define Profile/PB42
+ NAME:=Atheros PB42 reference board
+ PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/PB42/Description
+ Package set optimized for the Atheros PB42 reference board.
+endef
+
+$(eval $(call Profile,PB42))
+
+define Profile/PB44
+ NAME:=Atheros PB44 reference board
+ PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ vsc7385-ucode-pb44 vsc7395-ucode-pb44
+endef
+
+define Profile/PB44/Description
+ Package set optimized for the Atheros PB44 reference board.
+endef
+
+$(eval $(call Profile,PB44))
+
+define Profile/PB92
+ NAME:=Atheros PB92 reference board
+ PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
+endef
+
+define Profile/PB92/Description
+ Package set optimized for the Atheros PB92 reference board.
+endef
+
+$(eval $(call Profile,PB92))
diff --git a/target/linux/ar71xx/generic/profiles/atlantis.mk b/target/linux/ar71xx/generic/profiles/atlantis.mk
new file mode 100644
index 0000000000..c63fd9c275
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/atlantis.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/A02RBW300N
+ NAME:=Atlantis-Land A02-RB-W300N
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/A02RBW300N/Description
+ Package set optimized for the Atlantis-Land A02-RB-W300N.
+endef
+
+$(eval $(call Profile,A02RBW300N))
diff --git a/target/linux/ar71xx/generic/profiles/buffalo.mk b/target/linux/ar71xx/generic/profiles/buffalo.mk
new file mode 100644
index 0000000000..69819e586d
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/buffalo.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WZRHPG300NH
+ NAME:=Buffalo WZR-HP-G300NH
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+endef
+
+define Profile/WZRHPG300NH/Description
+ Package set optimized for the Buffalo WZR-HP-G300NH
+endef
+
+$(eval $(call Profile,WZRHPG300NH))
diff --git a/target/linux/ar71xx/generic/profiles/compex.mk b/target/linux/ar71xx/generic/profiles/compex.mk
new file mode 100644
index 0000000000..38d963a5c1
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/compex.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WP543
+ NAME:=Compex WP543/WPJ543
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/WP543/Description
+ Package set optimized for the Compex WP543/WPJ543 boards.
+endef
+
+$(eval $(call Profile,WP543))
diff --git a/target/linux/ar71xx/generic/profiles/d-link.mk b/target/linux/ar71xx/generic/profiles/d-link.mk
new file mode 100644
index 0000000000..bf99e099a9
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/d-link.mk
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DIR600A1
+ NAME:=D-Link DIR-600 rev. A1
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/DIR600A1/Description
+ Package set optimized for the D-Link DIR-600 rev. A1.
+endef
+
+$(eval $(call Profile,DIR600A1))
+
+
+define Profile/DIR615C1
+ NAME:=D-Link DIR-615 rev. C1
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/DIR615C1/Description
+ Package set optimized for the D-Link DIR-615 rev. C1.
+endef
+
+$(eval $(call Profile,DIR615C1))
+
+
+define Profile/DIR825B1
+ NAME:=D-Link DIR-825 rev. B1
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+endef
+
+define Profile/DIR825B1/Description
+ Package set optimized for the D-Link DIR-825 rev. B1.
+endef
+
+$(eval $(call Profile,DIR825B1))
diff --git a/target/linux/ar71xx/generic/profiles/linksys.mk b/target/linux/ar71xx/generic/profiles/linksys.mk
new file mode 100644
index 0000000000..f3253e728f
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/linksys.mk
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WRT160NL
+ NAME:=Linksys WRT160NL
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2 swconfig
+endef
+
+define Profile/WRT160NL/Description
+ Package set optimized for the Linksys WRT160NL.
+endef
+
+define Profile/WRT400N
+ NAME:=Linksys WRT400N
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/WRT400N/Description
+ Package set optimized for the Linksys WRT400N.
+endef
+
+$(eval $(call Profile,WRT160NL))
+$(eval $(call Profile,WRT400N))
diff --git a/target/linux/ar71xx/generic/profiles/netgear.mk b/target/linux/ar71xx/generic/profiles/netgear.mk
new file mode 100644
index 0000000000..8545cad0c6
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/netgear.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WNDR3700
+ NAME:=NETGEAR WNDR3700
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+endef
+
+define Profile/WNDR3700/Description
+ Package set optimized for the NETGEAR WNDR3700
+endef
+
+$(eval $(call Profile,WNDR3700))
diff --git a/target/linux/ar71xx/generic/profiles/planex.mk b/target/linux/ar71xx/generic/profiles/planex.mk
new file mode 100644
index 0000000000..63e539c4e4
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/planex.mk
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MZKW04NU
+ NAME:=Planex MZK-W04NU
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+endef
+
+define Profile/MZKW04NU/Description
+ Package set optimized for the Planex MZK-W04NU.
+endef
+
+$(eval $(call Profile,MZKW04NU))
+
+define Profile/MZKW300NH
+ NAME:=Planex MZK-W300NH
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/MZKW300NH/Description
+ Package set optimized for the Planex MZK-W300NH.
+endef
+
+$(eval $(call Profile,MZKW300NH))
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
new file mode 100644
index 0000000000..7efb1a3766
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -0,0 +1,94 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/TLWR741NDV1
+ NAME:=TP-LINK TL-WR741ND v1
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR741NDV1/Description
+ Package set optimized for the TP-LINK TL-WR741ND v1.
+endef
+
+$(eval $(call Profile,TLWR741NDV1))
+
+define Profile/TLWR841NV15
+ NAME:=TP-LINK TL-WR841N v1.5
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR841NV15/Description
+ Package set optimized for the TP-LINK TL-WR841N v1.5.
+endef
+
+$(eval $(call Profile,TLWR841NV15))
+
+define Profile/TLWR841NDV3
+ NAME:=TP-LINK TL-WR841ND v3
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR841NDV3/Description
+ Package set optimized for the TP-LINK TL-WR841ND v3.
+endef
+
+$(eval $(call Profile,TLWR841NDV3))
+
+define Profile/TLWR841NDV5
+ NAME:=TP-LINK TL-WR841ND v5
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR841NDV5/Description
+ Package set optimized for the TP-LINK TL-WR841ND v5.
+endef
+
+$(eval $(call Profile,TLWR841NDV5))
+
+define Profile/TLWR941NDV2
+ NAME:=TP-LINK TL-WR941ND v2
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR941NDV2/Description
+ Package set optimized for the TP-LINK TL-WR941ND v2.
+endef
+
+$(eval $(call Profile,TLWR941NDV2))
+
+define Profile/TLWR941NDV3
+ NAME:=TP-LINK TL-WR941ND v3
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR941NDV3/Description
+ Package set optimized for the TP-LINK TL-WR941ND v3.
+endef
+
+$(eval $(call Profile,TLWR941NDV3))
+
+define Profile/TLWR941NDV4
+ NAME:=TP-LINK TL-WR941ND v4
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR941NDV4/Description
+ Package set optimized for the TP-LINK TL-WR941ND v4.
+endef
+
+$(eval $(call Profile,TLWR941NDV4))
+
+define Profile/TLWR1043NDV1
+ NAME:=TP-LINK TL-WR1043ND v1
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLWR1043NDV1/Description
+ Package set optimized for the TP-LINK TL-WR1043ND v1.
+endef
+
+$(eval $(call Profile,TLWR1043NDV1))
diff --git a/target/linux/ar71xx/generic/profiles/trendnet.mk b/target/linux/ar71xx/generic/profiles/trendnet.mk
new file mode 100644
index 0000000000..20a08f3842
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/trendnet.mk
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/TEW632BRP
+ NAME:=TRENDNet TEW-632BRP
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TEW632BRP/Description
+ Package set optimized for the TRENDNet TEW-632BRP.
+endef
+
+$(eval $(call Profile,TEW632BRP))
+
+define Profile/TEW652BRP
+ NAME:=TRENDNet TEW-652BRP
+ PACKAGES:=kmod-ath9k
+endef
+
+define Profile/TEW652BRP/Description
+ Package set optimized for the TRENDNet TEW-652BRP.
+endef
+
+$(eval $(call Profile,TEW652BRP))
diff --git a/target/linux/ar71xx/generic/profiles/ubnt.mk b/target/linux/ar71xx/generic/profiles/ubnt.mk
new file mode 100644
index 0000000000..a7fd9a2619
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/ubnt.mk
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/UBNTRS
+ NAME:=Ubiquiti RouterStation
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNTRS/Description
+ Package set optimized for the Ubiquiti RouterStation.
+endef
+
+$(eval $(call Profile,UBNTRS))
+
+define Profile/UBNTRSPRO
+ NAME:=Ubiquiti RouterStation Pro
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNTRSPRO/Description
+ Package set optimized for the Ubiquiti RouterStation Pro.
+endef
+
+$(eval $(call Profile,UBNTRSPRO))
+
+define Profile/UBNT
+ NAME:=Ubiquiti Products
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNT/Description
+ Build images for all Ubiquiti products (including LS-SR71, RouterStation and RouterStation Pro)
+endef
+
+$(eval $(call Profile,UBNT))
diff --git a/target/linux/ar71xx/generic/profiles/zyxel.mk b/target/linux/ar71xx/generic/profiles/zyxel.mk
new file mode 100644
index 0000000000..73ae4e224c
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/zyxel.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NBG_460N_550N_550NH
+ NAME:=Zyxel NBG 460N/550N/550NH
+ PACKAGES:=kmod-ath9k swconfig
+endef
+
+define Profile/NBG_460N_550N_550NH/Description
+ Package set optimized for the Zyxel NBG 460N/550N/550NH Routers.
+endef
+
+$(eval $(call Profile,NBG_460N_550N_550NH))