aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/openmesh.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-12-18 15:16:05 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-12-18 15:16:05 +0000
commit600d17a044bce041a6fb80784b632afc8941f934 (patch)
tree32d2418ab32a4d5be9b24e818cc53a3ac3dc1f69 /target/linux/ar71xx/generic/profiles/openmesh.mk
parent9cf97ce9dc50c3cd0a1e23e0ae76154326bea0ab (diff)
downloadmaster-187ad058-600d17a044bce041a6fb80784b632afc8941f934.tar.gz
master-187ad058-600d17a044bce041a6fb80784b632afc8941f934.tar.bz2
master-187ad058-600d17a044bce041a6fb80784b632afc8941f934.zip
ar71xx: image: add OpenMesh profile
It allows to build firmware images for all OpenMesh products in one step. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34761 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/openmesh.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/openmesh.mk13
1 files changed, 12 insertions, 1 deletions
diff --git a/target/linux/ar71xx/generic/profiles/openmesh.mk b/target/linux/ar71xx/generic/profiles/openmesh.mk
index 92aec4b79c..53ae5987f9 100644
--- a/target/linux/ar71xx/generic/profiles/openmesh.mk
+++ b/target/linux/ar71xx/generic/profiles/openmesh.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -27,3 +27,14 @@ endef
$(eval $(call Profile,MR600))
+define Profile/OPENMESH
+ NAME:=OpenMesh products
+ PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/OPENMESH/Description
+ Build images for all OpenMesh products.
+endef
+
+$(eval $(call Profile,OPENMESH))
+